• CamyMG30

    (@camymg30)


    Buenos días:
    Llevo varias semanas con problemas al acceder al panel de administración, pero ahora también esta pasando al visitar la página pública, me indica error 500.
    La página lleva un año publicada y todo iba bien hasta que a finales de abri intenté acceder al panel de administración y me dio el error. Contacte con el hosting y cambiando la versión de php puede entrar, realicé actualizaciones de wordpress y plugins, y todo bien hasta que volví a intentar entrar a las dos hora más o menos y nada otra vez lo mismo.
    Únicamente puedo acceder a la web cambiando la versión de php, de la 7 a la 5.6 y viceversa.
    Hace unos 5 días se veía bien y ahora vuelva a dar error 500.
    He desactivado los plugins y activado uno a uno…pero falla igual con plugin activados que sin ellos.
    La línea de error que veo en el log del servidor es: FastCGI: incomplete headers (0 bytes) received from server «/fcgi-bin-php70-fpm-merceriamilagros.es»
    El servidor me dice que es problema de programación.
    Por favor, necesito ayuda urgente para solucionar dicho problema. Gracias!

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Juanma Aranda

    (@juanmaaranda)

    Hola @camymg30!

    Yo probaría con 2 opciones distintas:

    – Reemplazar el archivo .htaccess -> Renómbralo (accediendo por FTP o CPanel) y prueba a ver si te muestra la web correcta. Si funciona bien, vete a Ajustes -> Enlaces permanentes y, sin tocar nada más, dale a guardar cambios para que te genere un .htaccess limpio.

    – Si no se resuelve con el paso anterior, intenta aumentar el límite de memoria PHP de la siguiente forma:
    * Crea un archivo en blanco mediante tu bloc de notas, al que llamarás php.ini
    * Pega el siguiente código tal cual: memory=64MB
    * Sube el nuevo archivo a tu servidor, mediante un cliente FTP o desde el Administrador de archivos de tu CPanel y guárdalo en la carpeta «wp-admin»

    A ver si con esto tienes suerte 😉

    Moderador LGrusin

    (@lgrusin)

    También puedes consultar con el programador del tema. Deberías actualizar a PHP 7.

    Si de tu parte está todo bien y los del servidor no resuelven el problema deberías pensar en cambiar de hosting.

    Un saludo

    Iniciador del debate CamyMG30

    (@camymg30)

    Hola, gracias por vuestras respuestas.
    Si, el cambio del archivo htacces, fue lo primero que he hecho y cuando pensé q se había solucionada, nada al día siguiente otra vez error.
    Ahora lleva unas horas q se ve bien pero voy a probar a subir el archivo q me comentas Juamma, el php.ini.
    También he enviado un correo al soporte del tema pero aún no se nada, a ver q me dicen!
    He exportado la página a una sub carpeta de otro dominio y voy a probar si sucede lo mismo.
    Me resulta muy raro q después de un año pase esto, no lo entiendo…
    Os mantendré informados a ver si encontramos el problema o mejor dicho la solución. Muchas gracias.
    Saludos
    Carmen

    • Esta respuesta fue modificada hace 7 años por CamyMG30.
Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • El debate ‘Problemas error 500’ está cerrado a nuevas respuestas.