Soporte » Instalación – Actualizaciones » Problemas para actualizar de PHP 7.2.34 a 7.4 en mi Website

  • Buenas noches, acudo a ustedes a fin que me puedan apoyar con este problema:
    Por recomendación de WP debo actualizar mi PHP de 7.2.34 –> 7.4, sin embargo, una vez realizado, me aparece èste warning en mi escritorio:

    `ng: «continue» targeting switch is equivalent to «break». Did you mean to use «continue 2»? in /home/beatlesm/public_html/wp-content/plugins/revslider/includes/operations.class.php on line 2364

    Warning: «continue» targeting switch is equivalent to «break». Did you mean to use «continue 2»? in /home/beatlesm/public_html/wp-content/plugins/revslider/includes/operations.class.php on line 2368

    Warning: «continue» targeting switch is equivalent to «break». Did you mean to use «continue 2»? in /home/beatlesm/public_html/wp-content/plugins/revslider/includes/output.class.php on line 3169

    Warning: Creating default object from empty value in /home/beatlesm/public_html/wp-content/themes/buzzblog/admin-panel/redux-framework/inc/class.redux_filesystem.php on line 29.

    Muchas gracias anticipadas por vuestro apoyo.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 2 respuestas - de la 1 a la 2 (de un total de 2)
  • Moderador almendron

    (@almendron)

    Lo primero de todo es conveniente que esos mensajes no aparezcan cuando entras a tu sitio. Para ello, deberás editar el archivo wp-config.php (haz primero una copia) y buscar la línea:

    define('WP_DEBUG', true);

    Donde pone true, debes poner false.

    Esto no corrige los errores pero evita que aparezcan en pantalla.

    Por otro lado, el nivel de aviso (Warning) es bajo y en principio todo debería funcionar sin problemas. No obstante, sería conveniente que lo solucionaras.

    En primer lugar, te falla el plugin que está en la carpeta «revslider». Opciones: actualziar (si procede), contactar con su desarrollador (creo que es de pago el que tienes) o utilizar otro plugin.

    En segundo lugar, te falla el propio tema. Las mismas opciones que en el anterior.

    Para asegurarte que los cambios surtan efectos, vuelves a poner «true» en el debug.

    Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte. Aparte de hacer lo que te indica @almendron para que no se vean los errores tienes que actualizar el tema, estás usando la versión 2.6 del tema, una versión con más de seis años de antigüedad, en cuanto actualices el tema te aparecerán las opciones para actualizar los plugins incluidos con el tema, entre los que seguramente estará Slider Revolution. Te dejo en enlace al soporte del tema por si tienes alguna consulta específica:

    Support for Buzz – Lifestyle Blog & Magazine WordPress Theme

    Recuerda marcar el debate como resuelto, así nos ayudas a mantener el foro al día.

Viendo 2 respuestas - de la 1 a la 2 (de un total de 2)
  • Debes estar registrado para responder a este debate.