• Resuelto gabehh95

    (@gabehh95)


    Hola,

    Tengo un sitio web de venta de artículos, y la mayoría de mis clientes son españoles, pero también he hecho envíos por diferentes paises de Europa.

    El problema que tengo es en la traducción de los correos, desde siempre han estado en castellano, pero desde hace no mucho algunas frases están en ingles, es decir, tengo un espanglish en los correos (crear cuenta, nuevo pedido, etc). No entiendo que está ocurriendo, porque desde que creé la página ha sido configurada en castellano.

    Mi idea era utilizar un plugin para enviar correos en diferentes idiomas, pero primero debo tener todos los correos en castellanos para traducirlos.

    Nota: tengo instalado el weglot, pero no influye en los correos.

    Mi página es: https://diverko.com

    Gracias,

    Un saludo.

    • Este debate fue modificado hace 11 meses, 3 semanas por gabehh95.
Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Hola, a ver si te puedo ayudar, ya me dices que tal

    1. Verifica la configuración del plugin Weglot: Asegúrate de que el plugin Weglot esté configurado correctamente para traducir todo el contenido de tu sitio web al español. Revisa la documentación del plugin para asegurarte de que no estés omitiendo la traducción de los correos electrónicos.
    2. Revisa las plantillas de correos electrónicos: Si utilizas algún sistema de gestión de contenido o un plugin específico para enviar correos electrónicos (como confirmaciones de pedido, crear cuenta, etc.), revisa las plantillas de estos correos para asegurarte de que estén en español.
    3. Verifica las traducciones: Si tienes una opción para traducir manualmente los correos electrónicos, asegúrate de que las traducciones sean precisas y estén en español.
    4. Prueba con una cuenta de prueba: Crea una cuenta de prueba en tu sitio web y realiza diferentes acciones para activar los correos electrónicos (hacer un nuevo pedido, crear una cuenta, etc.). Observa si los correos que recibes están en español o en inglés, y así podrás identificar mejor el origen del problema.
    Iniciador del debate gabehh95

    (@gabehh95)

    Hola @hoswedaje

    Gracias por responder.

    El plugin lo desactive por completo y con diferentes cuentas realicé pruebas y el problema persistía, por eso descarté Weglot como el problema raíz. Personalmente creo que es un problema del Woocomerce, porque desde que movieron la sección de Emails dentro de Marketing, ahora tengo una mezcla de inglés/castellano, y la verdad yo prefiero que esté en un solo idioma para luego traducirlo, pero no quiero tener una mezcla.

    Probé descargando un plugin que me dejara editar al 100% todos los templates, pero sigue cogiendo el original con los textos en inglés/castellano.

    Un saludo.

    Entiendo tu situación. Si has descartado que Weglot sea el problema y sospechas que el conflicto está relacionado con WooCommerce, es posible que haya alguna configuración o código en conflicto que esté causando que la mezcla de idiomas aparezca en la sección de Emails.

    Dado que descargaste un plugin para editar los templates y no obtuviste el resultado deseado, es probable que haya alguna otra personalización o código personalizado en tu sitio que esté interfiriendo con la traducción adecuada de los textos.

    Aquí hay algunos pasos que podrías seguir para intentar resolver el problema:

    1. Verificar tus archivos de plantillas: Asegúrate de que estás editando los archivos de plantillas de correos electrónicos correctos en WooCommerce. A veces, los temas o plugins pueden tener sus propias plantillas que sobrescriben las predeterminadas de WooCommerce.
    2. Eliminar personalizaciones: Si has agregado código personalizado en el pasado para modificar la apariencia o el contenido de los correos electrónicos de WooCommerce, prueba a revertir esas personalizaciones para ver si el problema desaparece.
    3. Revisar otros plugins y temas: Algunos plugins o temas pueden afectar la forma en que WooCommerce maneja los correos electrónicos o los idiomas. Desactiva temporalmente otros plugins y cambia al tema predeterminado de WordPress para ver si el problema persiste.
    4. Verificar las configuraciones de WooCommerce: Asegúrate de revisar todas las opciones relacionadas con los idiomas en WooCommerce. Busca configuraciones relacionadas con la traducción de correos electrónicos y asegúrate de que estén configuradas correctamente.
    5. Consultar con el soporte de WooCommerce: Si después de probar estos pasos el problema aún persiste, te recomiendo que te pongas en contacto con el soporte de WooCommerce o busques en sus foros para ver si otros usuarios han experimentado un problema similar y si hay alguna solución conocida.

    Recuerda siempre hacer una copia de seguridad completa de tu sitio antes de realizar cambios importantes, para evitar problemas mayores en caso de que algo salga mal durante el proceso.

    Espero que encuentres una solución satisfactoria para el problema de la mezcla de idiomas en los correos electrónicos de WooCommerce. ¡Buena suerte! Si tienes más preguntas o necesitas más ayuda, no dudes en preguntar.

    Iniciador del debate gabehh95

    (@gabehh95)

    Hola,

    Gracias otra vez @hoswedaje

    Es deprimente lo que voy a contar, pero el problema no era yo, ni el WooCommerce, es mi proveedor. Hace no mucho hice un upgrade en mi host de WordPress, debido al mayor tráfico que iba teniendo en mi página y así mejorar la experiencia del usuario, ya que un mal performance ahuyenta a los clientes.

    El caso es que mi proveedor «GoDaddy» (no se lo recomiendo a nadie en este mundo) ofrece a los planes superiores un gestor de emails (una castaña.), que es algo básico para que cualquier persona con un conocimiento amateur de HTML puede hacer una plantilla cutre.

    Obviamente a mi eso no me sirve, yo quiero editar mi plantilla a mi manera, y ya el problema empieza cuando el gestor de marketing/correos de GoDaddy me inyecta líneas en ingles/castellano. Empecé a utilizar la extensiones de terceros, edité directamente los ficheros php de los mails, desactivé el Weglot, he estado analizando y leyendo foros, etc., hasta que me ha dado por revisar la documentación de GoDaddy y leo este mensaje:

    «Nota: En este momento, no es posible editar el contenido de los correos electrónicos agregados por extensiones de terceros. Si estás interesado en poder hacerlo, infórmaselo al equipo yendo a Obtener ayuda en la parte superior izquierda de la vista de administrador de WordPress. Tus comentarios ayudarán a priorizar nuestro trabajo»

    Básicamente, GoDaddy me controla las plantillas y no puedo hacer mucho, he ido al soporte a quejarme y me dicen «Bueno deberías hacer un downgrade de tu plan actual para poder editar tus plantillas con algún plugin externo». Para mi es un chiste, mientras más pago menos control tengo sobre el el sistema??????.

    Gracias igualmente @hoswedaje

    Un saludo.

    Iniciador del debate gabehh95

    (@gabehh95)

    Hola,

    Ya lo he solucionado, efectivamente es lo que decía en el mensaje anterior, eran configuraciones de mi host, dejaré la solución por si alguien más tiene problemas con el gestor de correos despreciable de GoDaddy.

    /** DISABLE GODADDY EMAILS */
    define( ‘DISABLE_MWC_EMAIL_NOTIFICATIONS’, true );

    Con añadir esa línea en el wp-config.php antes de declarar las variables de WordPress, ya desactiva todo el sistema de correos y lo deja en su estado natural, para una libre edición.

    Problema resuelto.

    Un saludo y suerte!.

    Perfecto entonces, espero que este tema le sirva a más gente que tenga los servicios en Goodady y esas limitaciones

    Si quieres accede a mi web y al WhatsApp y hablamos más cómodamente

    Gracias y Feliz verano

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • El debate ‘Problemas Traducción’ está cerrado a nuevas respuestas.