Soporte » Guías – Resolución de problemas » problemas widget Archivos

  • Resuelto nigromonte

    (@nigromonte)


    Hola !

    Tengo colocado a la derecha del blog http://www.evaevuxxy.com el Widget Archivos y me esta dando un problema que no se como solucionarlo (seguramente sea falta de información por mi parte).

    La cuestión es que en el momento que le doy click a cualquiera de los meses y se abre una vista nueva del blog donde están todas las entradas de ese mes (como corresponde) el título que me aparece es el siguiente:

    «Mes: PMñ2017 f43332017-10-07T12:43:33+00:00pmsábado»

    Me gustaría que apareciera «Mes: Nombre del mes correspondiente»

    Link de la web: http://evaevuxxy.com
    Tema que utilizo: Activello

    Tener en cuenta que no soy un especialista en WordPress y menos de lenguaje y código.
    Lo aclaro por que tendrían que tratar de explicarme como si tuviera 6 años

    Desde ya Gracias a todos!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Por favor confirma..
    has tocado el código del archivo archive.php ?
    De ser así, indica que has hecho exactamente.. (pega el código aquí mismo de ser necesario, pero recuerda usar de este editor del foro las etiqueta code y cerrar code)

    Acabo de realizar una instalación limpia de este theme y se ve correctamente

    • Esta respuesta fue modificada hace 3 años, 1 mes por oldlastman.

    Hola @oldlastman !

    No he tocado nada.
    Solamente en su tiempo cuando instale el tema genere un tema hijo a base de un tutoríal encontrado.

    Dejo el el código del archivo archive.php
    (espero haberlo hecho bien)

    <?php
    /**
     * The template for displaying Archive pages.
     *
     * Learn more: http://codex.wordpress.org/Template_Hierarchy
     *
     * @package activello
     */
    
    get_header(); ?>
    
    	<section id="primary" class="content-area">
    		<main id="main" class="site-main" role="main">
    
    		<?php if ( have_posts() ) : ?>
    
    			<header class="page-header">
    				<h1 class="page-title">
    					<?php
    					if ( is_category() ) :
    						single_cat_title();
    
    						elseif ( is_tag() ) :
    							single_tag_title();
    
    						elseif ( is_author() ) :
    							/* translators: %s: author name */
    							printf( esc_html__( 'Author: %s', 'activello' ), '<span class="vcard">' . get_the_author() . '</span>' );
    
    						elseif ( is_day() ) :
    							/* translators: %s: day */
    							printf( esc_html__( 'Day: %s', 'activello' ), '<span>' . get_the_date() . '</span>' );
    
    						elseif ( is_month() ) :
    							/* translators: %s: month */
    							printf( esc_html__( 'Month: %s', 'activello' ), '<span>' . get_the_date( _x( 'F Y', 'monthly archives date format', 'activello' ) ) . '</span>' );
    
    						elseif ( is_year() ) :
    							/* translators: %s: year */
    							printf( esc_html__( 'Year: %s', 'activello' ), '<span>' . get_the_date( _x( 'Y', 'yearly archives date format', 'activello' ) ) . '</span>' );
    
    						elseif ( is_tax( 'post_format', 'post-format-aside' ) ) :
    							esc_html_e( 'Asides', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-gallery' ) ) :
    							esc_html_e( 'Galleries', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-image' ) ) :
    							esc_html_e( 'Images', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-video' ) ) :
    							esc_html_e( 'Videos', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-quote' ) ) :
    							esc_html_e( 'Quotes', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-link' ) ) :
    							esc_html_e( 'Links', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-status' ) ) :
    							esc_html_e( 'Statuses', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-audio' ) ) :
    							esc_html_e( 'Audios', 'activello' );
    
    						elseif ( is_tax( 'post_format', 'post-format-chat' ) ) :
    							esc_html_e( 'Chats', 'activello' );
    
    						else :
    							esc_html_e( 'Archives', 'activello' );
    
    						endif;
    					?>
    				</h1>
    				<?php
    					// Show an optional term description.
    					$term_description = term_description();
    				if ( ! empty( $term_description ) ) :
    					printf( '<div class="taxonomy-description">%s</div>', $term_description );
    					endif;
    				?>
    			</header><!-- .page-header -->
    
    			<?php /* Start the Loop */ ?>
    			<?php while ( have_posts() ) : the_post(); ?>
    
    				<?php
    					/* Include the Post-Format-specific template for the content.
    					 * If you want to override this in a child theme, then include a file
    					 * called content-___.php (where ___ is the Post Format name) and that will be used instead.
    					 */
    					get_template_part( 'template-parts/content', get_post_format() );
    				?>
    
    			<?php endwhile; ?>
    
    			<?php activello_paging_nav(); ?>
    
    		<?php else : ?>
    
    			<?php get_template_part( 'template-parts/content', 'none' ); ?>
    
    		<?php endif; ?>
    
    		</main><!-- #main -->
    	</section><!-- #primary -->
    
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>
    

    El código que me has dado es del childtheme?
    se ve correctamente en mi instalación.. así que el error no está ahí

    Tienes algún plugin instalado que afecte a las fechas?

    has revisado l configuración presente en
    Ajustes -> Generales
    formato de fecha y formato de hora?
    has puesto algo en las opciones personalizado?
    de ser así, quítalo y usa las opciones ofrecidas por WordPress

    (una vez se vea correctamente intentaremos poner lo que deseas bien)

    Ante todo Muchísimas gracias por tu pronta respuestas.

    «Tienes algún plugin instalado que afecte a las fechas?»
    el unico que creo que puede afectar en algo es Yoast SEO,no obstante voy a listar los plugins instalados:

    ACTIVOS
    -Akismet Anti-Spam
    -Importador de WordPress
    -Jetpack by WordPress.com
    -Kiwi Social Share – Social Media Share Buttons & Icons
    -Simple Google Analytics
    -Widget Importer & Exporter
    -WP Smush
    -Yoast SEO
    -YouTube

    DESACTIVOS
    -Límitador de intentos de login
    -WP Maintenance Mode

    «Formato de fecha y formato de hora? has puesto algo en las opciones personalizado?»
    Fue lo primero que pense, con lo cual, lo que hice fue probar todas las combinaciones posibles para luego volver a los ajustes predeterminados de esta opción.

    Sinceramente no se que puede pasar.

    En cuanto a lo que quiero que se vea en esa parte, sencillamente es que se vea como el tema ni más ni menos

    Muchas gracias nuevamente!

    Estaba revisando en tu página para intentar adivinar porqué te sucedía..
    pero veo que ahora está ok..

    has cambiado algo?
    nos cuentas que sucedía?
    y si ya está ok, das el tema por resuelto? (puedes hacerlo a la derecha donde pone estado)

    Un saludo

    Hola @oldlastman

    Sinceramente no se como se solucionó el problema, de repente estaba actualizando plugins y demás cositas y de un momento para otro cuando refresque la página se puso normal.

    No se realmente lo que puedo ser ni como se solucionó, lo que si se, es que yo personalmente no hice nada de forma consciente para solucionarlo.

    De todas formas muchísimas gracias por intentar ayudarme.

    Saludos

    Por si le sirve a alguien…
    A mí me pasaba lo mismo.
    Creo que es por la traducción al español de WordPress y que tiene algún tipo de fallo con ese tipo de código en la plantilla de archivos.
    Si lo pongo en gallego, por ejemplo, se arregla el problema.
    Ya había probado todo lo que comentáis, hasta había desactivado todos los plugins. Estoy con las últimas actualizaciones posibles de todo.
    Al final, esperando una próxima actualización, lo he arreglando con este código en archive.php:

    <?php
    /**
     * The template for displaying Archive pages.
     *
     * Learn more: http://codex.wordpress.org/Template_Hierarchy
     *
     * @package activello
     */
    
    get_header(); ?>
    
    	<section id="primary" class="content-area">
    		<main id="main" class="site-main" role="main">
    
    		<?php if ( have_posts() ) : ?>
    
    			<header class="page-header">
    				<h1 class="page-title">
    					<?php
    					the_archive_title( '<h1 class="page-title">', '</h1>' );
    					the_archive_description( '<div class="taxonomy-description">', '</div>' );
    				?>
    			</header><!-- .page-header -->
    
    			<?php /* Start the Loop */ ?>
    			<?php while ( have_posts() ) : the_post(); ?>
    
    				<?php
    					/* Include the Post-Format-specific template for the content.
    					 * If you want to override this in a child theme, then include a file
    					 * called content-___.php (where ___ is the Post Format name) and that will be used instead.
    					 */
    					get_template_part( 'template-parts/content', get_post_format() );
    				?>
    
    			<?php endwhile; ?>
    
    			<?php activello_paging_nav(); ?>
    
    		<?php else : ?>
    
    			<?php get_template_part( 'template-parts/content', 'none' ); ?>
    
    		<?php endif; ?>
    
    		</main><!-- #main -->
    	</section><!-- #primary -->
    
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>
    
    
    • Esta respuesta fue modificada hace 2 años, 12 meses por .
    • Esta respuesta fue modificada hace 2 años, 12 meses por .
Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘problemas widget Archivos’ está cerrado a nuevas respuestas.