• Buenas tardes:

    Tengo el siguiente error al intentar acceder a los productos de Woocommerce..

    Class WP_Image_Editor_Imagick extends WP_Image_Editor { /** * Imagick object. * * @var Imagick….

    No sé si he de desistalarlo por completo o volver a instalar. El caso es que no sé como solucionarlo, no me deja instalar ningún plugin ni nada. Si me podéis echar un cable.

    Saludos.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Marta Torre

    (@martatorre)

    Hola, @txopy,

    Gracias por escribir a los foros oficiales de soporte España.

    Entiendo que si desactivas el plugin no te ocurre ese error, verdad?

    ¿Puedes probar, si desinstalando, e instalando nuevamente te puede pasar? ¿Has visto que sea compatible con la nueva versión de WordPress?

    Gracias.

    Iniciador del debate Juan Nieto Cano

    (@txopy)

    Hola @martatorre , el plugin lo desactive y lo eliminé.

    No recuerdo muy bien que hice, pero creo que el error está en el archivo de Wp_Image_Editor. El caso es que no se arreglarlo.

    Pongo ejemplo del error:

    https://www.sieteciudades.com/wp-admin/post-new.php?post_type=page

    class WP_Image_Editor_Imagick extends WP_Image_Editor { /** * Imagick object. * * @var Imagick */ protected $image; public function __destruct() { if ( $this->image instanceof Imagick ) { // We don’t need the original in memory anymore. $this->image->clear(); $this->image->destroy(); } } /** * Checks to see if current environment supports Imagick. * * We require Imagick 2.2.0 or greater, based on whether the queryFormats() * method can be called statically. * * @since 3.5.0 * * @param array $args * @return bool */ public static function test( $args = array() ) { // First, test Imagick’s extension and classes. if ( ! extension_loaded( ‘imagick’ ) || ! class_exists( ‘Imagick’, false ) || ! class_exists( ‘ImagickPixel’, false ) ) { return false; } if ( version_compare( phpversion( ‘imagick’ ), ‘2.2.0’, ‘<‘ ) ) { return false; } $required_methods = array….

    Saludos y gracias por la ayuda.

    Iniciador del debate Juan Nieto Cano

    (@txopy)

    He intentado solucionarlo pero no me deja instalar de nuevo el plugin, tampoco subir uno nuevo en sustitución, no me da acceso a la carpeta de uploads, aunque le he cambiado los permisos en el hosting.

    Intento instalarlo por SSH y me dice quota excedeed.

    No encuentro la forma de arreglar el error. Si me podéis ayudar con ello, os estaría muy agradecido.

    Saludos.

    Marta Torre

    (@martatorre)

    Hola, @txopy:

    Este ultimo error que cuentas, es un error del servidor. Tienes que hablar con ellos, porque seguramente se deba a que te has pasado de la cuota contratada.

    Ya nos dices,

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • El debate ‘Problemas Woocommerce Imagick’ está cerrado a nuevas respuestas.