Soporte » Plugins y Hacks » qTranslator arranque

  • Resuelto pimpinela

    (@pimpinela)


    Hola, necesitaría saber como implementar el plug-in qtranslator una vez instalado y activado. He buscado por internet y no hay manera de saber como realmente funciona.
    Es la versión gratuita a la que creo he de añadir mi traducción página por página, pero no veo el modo de hacerlo pues editando cada una de ellas desde el idioma conmutado (ya he ubicado el conmutador) no resuelve en previsualizado. No soy programador por ello necesito una ayuda no excesivamente técnica. Gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Juan Hernando

    (@unintended8)

    Hola Pimpinela, la verdad es que el plugin qTranslate-X lleva años sin ser actualizado y aunque funciona tal cual, es probable que con algún plugin que estés utilizando para crear el contenido (Elementor tal vez) no sea compatible. Tampoco es compatible con Yoast, con lo cual no es una solución que yo te recomendaría para crear el multilenguaje de tu web.

    Existe un proyecto en GitHub donde están intentando resolver estos problemas y muchos otros (compatibilidad con el nuevo editor de bloques, por ejemplo) pero aún no está el proyecto avanzado del todo: https://github.com/qtranslate/qtranslate-xt

    Mi recomendación sería que utilizaras otro plugin para realizar el multilenguaje de tu web, una solución gratuita como Polylang o una de pago muy extendida como WPML pueden ser mejor solución.

    En qTranslate-X en principio, cuando estás editando el contenido, tienes el conmutador de los idiomas y cuando pulsas en cada pestaña debería aparecerte el contenido de cada una de las versiones, pero imagino que no es así, ¿verdad? Si estás utilizando el editor de bloques y no es totalmente necesario para tu web, probaría instalando el plugin del Editor Clásico, para ver si así sí te funciona y entonces sería un problema de compatibilidad con el nuevo editor.

    Ya nos dices si pruebas esta opción para ver si se arregla o si nos das alguna otra pista sobre el comportamiento no deseado del plugin.

    Gracias! 🙂

    pimpinela

    (@pimpinela)

    Hola Juan, de acuerdo, pues elimino qTranslate. He intentado usar Elementor en toda las páginas pero en alguna había cosas que no ejecutaba y he tirado de Beaver Buider aunque me resulta bastante tosco. Dicho esto, efectivamente no me aparece en ningún editor, las opciones de idioma aunque sí los conmutadores.

    He mirado un tutorial de Polylang antes de activarlo y veo que hay que clonar (plugin Duplicate Post) cada página para introducir las traducciones correspondientes. Osea, clono cada página, edito la que será en inglés (p.ej), vuelco la traducción y guardo. A partir de ahí se entiende que conmutando efectuará el cambio, no? Por cierto, he activado Polylang y al seleccionar «mi sitio» no podía hacerlo (not found) y casi me da algo. Lo he desinstalado esperando a ver que me dices.

    pimpinela

    (@pimpinela)

    Hola Juan. Finalmente he podido trabajar con Polylang en todas las páginas. He clonado esas páginas y entradas, editado, volcado de traducción, traducción de menús, técnicos. Ya lo tengo todo resuelto y colgado en la web. Sólo una pregunta más: antes de incluir el segundo idioma, en la estructura de menú (Apariencia-Menus) mi página de Inicio tenía la etiqueta de «enlace personalizado» e incluía la dirección web. Desde que cloné las páginas ya no está, hay algún problema con ello?

    Todo resuelto, gracias.

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Debes estar registrado para responder a este tema.