Soporte » Guías – Resolución de problemas » Redirección a directorio ha dejado de funcionar

  • Resuelto raulval

    (@raulval)


    Hola,

    Tengo una web alojada en mi propio servidor (NAS) que ha estado funcionando sin problemas. Instalé WordPress en un subdirectorio (/wordpress) y conseguí hacer una redirección con .htacces en la carpeta root siguiendo varios tutoriales. Esto ha estado funcionando hasta que de repente y sin razón aparente me ha dado un error que dice «There has been a critical error on this website.»

    La web funciona bien si entro al index.php de la subcarpeta y puedo entrar al panel de administración sin problemas.

    He intentado volver a restablecer la redirección con estos dos metodos:

    https://wordpress.org/support/article/giving-wordpress-its-own-directory/

    Pero ninguno de los dos me ha funcionado.

    Para el metodo 1 he creado un .htacces en root con el siguiente contenido:

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^(www.)?academiaindex.es$
    RewriteCond %{REQUEST_URI} !^/wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /wordpress/$1
    RewriteCond %{HTTP_HOST} ^(www.)?academiaindex.es$
    RewriteRule ^(/)?$ wordpress/index.php [L] 
    </IfModule>

    Pero sigue dando el mismo error.

    El metodo 2 lo he intentado y he hecho:

    – En el menú general he modificado la Dirección del sitio (URL) para eliminar el subdirectorio.
    – He copiado index.php y .htacces desde el subdirectorio al root.
    – He modificado el index.php y lo he dejado con require( dirname( __FILE__ ) . ‘/wordpress/wp-blog-header.php’ );

    Ya no he podido hacer nada más, no he podido acceder al mp_admin en la nueva ruta, da el mismo error (Vamos que no he podido actualizar los permalinks).

    También he intentado tirar toda la web al root pero con escaso éxito. A ver si me podéis ayudar ya que me he quedado con pocas opciones y ya no sé qué más intentar.

    Muchas gracias de antemano

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 19)
  • Moderador almendron

    (@almendron)

    Si lo que quieres es mover tu sitio desde la carpeta «wordpress» a la raíz, tienes que hacer lo siguiente:

    1) Nota previa: doy por hecho que https://academiaindex.es/wordpress/ funciona correctamente y que tienes acceso a la administración.

    2) Borrar lo que tengas en la raíz de tu sitio.

    3) Seguir la guía: https://wordpress.org/support/article/moving-wordpress/#moving-directories-on-your-existing-server

    Iniciador del debate raulval

    (@raulval)

    Hola, muchas gracias por el aporte, pero tampoco me funciona, ya lo he intentado varias veces, pero cuando toca entrar a la web de administración en la nueva ubicación me da el mismo error:

    «There has been a critical error on this website.»

    He dado los pasos tal cual del link que me has pasado:

    – Root limpio, sin ningún fichero.
    – Modifico las dos rutas WordPress y site URL quitando el subdirectorio «https://academiaindex.es», eso sí, esto me toca hacerlo forzando las variables en el fichero wp-options.php, ya que por alguna razún ya las tenía creadas con el subdirectorio (En el panel de administración están en gris y si las borro las variables estarán apuntando a otro sitio y no me deja entrar de nuevo).
    – Muevo todo lo que hay dentro de la carpeta «wordpress» a root.

    Aquí se acaba la fiesta, ya no puedo entrar ni a wp-admin ni a wp-login.php, ni de la dirección nueva ni de la vieja, la vieja da error 404 y la nueva el error que pongo antes.

    Voy a intentar instalarme el php-myadmin para ver si puedo seguir los pasos al 100%, pero no le tengo mucha fe…

    Gracias!

    Moderador almendron

    (@almendron)

    ¿Modificando el fichero wp-options.php?

    Esto no lo entiendo.

    Iniciador del debate raulval

    (@raulval)

    Perdón, wp-config.php, tengo estos defines:

    define('WP_HOME','http://academiaindex.es/wordpress' );
    define('WP_SITEURL','http://academiaindex.es/wordpress' );

    Al tenerlos no me deja modificarlos desde el panel de administración, pero bueno, los modifico con la ruta que toca desde el fichero.

    Moderador almendron

    (@almendron)

    1) Elimina esa dos líneas del archivo.

    2) Como no tengo claro que dos valores tienes en la base de datos, sigue el proceso indicado en https://wordpress.org/support/article/changing-the-site-url/#edit-functions-php y coloca la URL del subdirectorio (https://academiaindex.es/wordpress ). Fíjate que lo he puesto con «https».

    Importante: una vez puedas entrar en https://academiaindex.es/wordpress, borra las dos líneas del functions.php.

    Ahora te debería dejar cambiar las dos variables en el panel de WordPress.

    Seguimos una vez confirmes estos cambios.

    Iniciador del debate raulval

    (@raulval)

    Genial! Muchas gracias, ya me deja modificar los valores desde la web de admin. Esto es lo que he hecho (He continuado con el tutorial):

    – He guardado esos mismos valores para que se guarde bien en la base de datos.
    – He vuelto a dejar el functions.php como estaba.
    – He modificado las dos direcciones desde la web de admin quitándoles el subdirectorio (https://academiaindex.es) y he guardado de nuevo (La web de admin ha desaparecido).
    – He movido los ficheros a root (/wordpress queda vacío).
    – Ahora intento entrar a https://academiaindex.es/wp-admin o / wp-login.php pero me sigue dando el mismo error.

    Muchas gracias por el soporte, voy muy perdido con estas cosas…

    Moderador almendron

    (@almendron)

    Quiero que hagas lo siguiente:

    1) Copia todo al subdirectorio. NO LO MUEVAS. Solo copia. Es para tener una copia en caso de problemas.

    2) Borra el archivo .htaccess

    3) Intenta entrar.

    Iniciador del debate raulval

    (@raulval)

    Nada, lo mismo… he borrado el .htacces del root.

    Sin embargo si voy a la que tengo copiada en el subdirectorio (https://academiaindex.es/wordpress/wp-login.php) sí que sale el login, aunque si me logueo me tira a la root y da error.

    • Esta respuesta fue modificada hace 2 meses, 2 semanas por raulval.
    Moderador almendron

    (@almendron)

    En el root:

    1) htaccess borrado.

    2) Renombra carpeta «plugins» (dentro de wp-content)

    3) Intenta entrar

    Iniciador del debate raulval

    (@raulval)

    Nada, el mismo error.

    Moderador almendron

    (@almendron)

    A ver:

    1. Borra lo del root

    2) En la subcarpeta «wordpress»: cambia de nuevo las dos variables usando el método del functions.php (no olvides borrarlas después de haber entrado).

    3) Borra htaccess. Luego te vas a «Ajustes > Enlaces permanentes», marca «simple» y guardas.

    4) Vuelve a usar la guía https://wordpress.org/support/article/moving-wordpress/#moving-directories-on-your-existing-server pero ahora en el paso 5 4 y 5 pones «http» en lugar de «https».

    Iniciador del debate raulval

    (@raulval)

    Nada, lo mismo, y ahora me sigue enviando a https. Puede ser algo con el DDNS o una redirección de puertos del router? Esto ya es mosqueante.

    Moderador almendron

    (@almendron)

    me sigue enviando a https

    Si borras el htaccess del root: ¿también te manda a https?

    Iniciador del debate raulval

    (@raulval)

    Sí, también acabo en https

    Moderador almendron

    (@almendron)

    1. Borra lo del root

    2. Crea una nueva base de datos

    3. Instala en root un nuevo WordPress y lo asocias a la nueva base de datos.

    A ver is te funciona.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 19)
  • Debes estar registrado para responder a este debate.