Soporte » Guías – Resolución de problemas » REDIRECCIÓN DE PERMALINKS A LA PÁGINA PRINCIPAL DEL TEMA

  • Buenas tardes, tengo un problemilla y no doy con la tecla. Soy novato, he estado mirando el foro, pero como decía no doy con la solución. Estoy trabajando en un subdominio http://tienda.cincuentopia.com, he instalado un tema, y varios plugins, y al activar uno de ellos, YOAST, me redirecciona a la página de inicio sitio (http://tienda.cincuentopia.com),
    Lo mismo me pasa con woocommerce. Cuando he ido a ajustes-enlaces permanentes, me pasa lo mismo.
    He probado a desactivar los plugins, (todos), cambiar el tema, … pero sigue igual.
    ¿Podríais echarme una mano si os ha pasado?
    Muchas gracias

Viendo 11 respuestas - de la 1 a la 11 (de un total de 11)
  • ¿Te refieres que entras a http://tienda.cincuentopia.com y te lleva a http://cincuentopia.com ?

    Porque no se entiende el problema.

    1- Desactiva todos los plugins.
    2- Utiliza los enlaces permanentes por omisión.

    Aquí suponemos que son dos instalaciones diferentes y que las bases de datos son distintas. ¿Es así?

    Iniciador del debate joseluisdncomercial.com

    (@joseluisdncomercialcom)

    Buenas tardes Peter,
    gracias por la respuesta.
    Me intento explicar mejor: en tienda.cincuentopia.com, he instalado wordpress, cuando estoy en http://tienda.cincuentopia.com/wp-admin/ y voy a Ajustes – Enlaces Permanentes, (http://tienda.cincuentopia.com/wp-admin/options-permalink.php/) en lugar de abrir la página para que pueda gestionar los enlaces permanentes, me manda a la página de Inicio del tema que he instalado (e-store)
    A la pregunta que me haces, son instalaciones independientes con bases de datos independientes.
    Los plugins los he desactivado todos y los he eliminado. El tema también lo he desactivado.
    Aún así nada. Sigo sin poder configurar los permalink
    Me dí cuenta del problema cuando instale el plugin Yoast, y al pinchar en activar plugin, en lugar de activarlo me mandaba a la página de inicio del tema.
    Es como si en la instalación algo se ha instalado mal.
    Muchas gracias por adelantado

    Si solo al querer entrar te manda a portada es otra cosa, porque deberías de poder entrar a la sección de enlaces permanentes, pero si ni eso puedes ver, hay algún conflicto.

    Revisa tu archivo .htaccess a ver si hay alguna regla que lo pueda estar causando, porque si ya probaste sin plugins, por ahi puede ser que tengas algo. Pero asegurate que todos los plugins están desactivados.

    Saludos.

    Iniciador del debate joseluisdncomercial.com

    (@joseluisdncomercialcom)

    Hola Peter, muchas gracias por la respuesta,
    EL archivo .htaccess no contiene nada, esto.
    text/x-generic .htaccess
    empty

    No domino nada este tema, ¿Como lo tendría que hacer? o donde podría encontrar un manual para «pardillos» como yo.
    Muchas Gracias por tu ayuda

    ¿En Ajustes > Enlaces permanentes los tienes por omisión como te comente arriba?

    Iniciador del debate joseluisdncomercial.com

    (@joseluisdncomercialcom)

    uff, discúlpame porque creo que no me explico muy bien.
    Cuando voy a ajustes – enlaces permanentes, ahora me da un error 404. Por lo que no puedo modificar los enlaces permanentes.

    Vamos por partes.

    1- Desactiva todos los plugins para empezar y comenta que es lo que pasa.

    Saludos.

    Iniciador del debate joseluisdncomercial.com

    (@joseluisdncomercialcom)

    Hola Peter. Situación actual.
    Wordpress 4.0
    http://tienda.cincuentopia.com/
    Plugins, Yoast y Woocommerce, al pinchar en activar plugin redirecciónan a la pagina de inicio, por lo que están borrados todos menos akismet y comming soon. Ninguno de los dos activos.

    Temas instalados e-store (desactivado y eliminado). Tema actual Twenty Fourteen. (no sera este el etema, sera e-store si consigo solucionar esto)
    Con WordPress virgen o casi virgen, al pinchar en Ajustes – Enlaces Permanentes dirige a esta url http://tienda.cincuentopia.com/wp-admin/options-permalink.php/ y se abre la pagina principal del tema.

    Por otro lado, el archivo .htaccess ahora mismo contiene esto.
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # End WordPress

    Y nada, ya no se que hacer, gracias por tu ayuda

    Primero desactiva todos los plugins, todos todos, no dejes ni uno solo activo.

    Si el problema sigue, borra eso del htaccess y prueba a ver si te deja entrar y utilizar los enlaces permanentes por omisión.

    Saludos.

    Iniciador del debate joseluisdncomercial.com

    (@joseluisdncomercialcom)

    Buenos días Peter,
    Todos los plugins están desactivados
    El .htaccess esta en blanco, he borrado todo.
    El problema persiste, cuando pincho en ajustes-enlaces permanentes, se abre con esta url http://tienda.cincuentopia.com/wp-admin/options-permalink.php/ la pagina de inicio, la misma página que puedes ver en http://tienda.cincuentopia.com/.
    La desesperación empieza a ser un problema.
    He mirado más soluciones en el foro y en otras páginas, pero parece que ninguna me vale. con todas me da el mismo problema.
    Si tienes alguna idea más te lo agradezco mucho.
    Muchas gracias

    Pues esta muy raro, si no hay plugins activos y el htaccess no tiene nada, te debería de cargar normal.

    Prueba volver a subir todos los archivos de WordPress, todos menos wp-content y wp-config. Reemplaza todo lo demás en tu servidor.

    Yo cuando entro a esa dirección me manda correctamente al login con una redirección a los permalinks, pero claro, sin usuario es imposible probar.

    Como extra. ¿Te pasa en todos los navegadores?

    Saludos.

Viendo 11 respuestas - de la 1 a la 11 (de un total de 11)
  • El debate ‘REDIRECCIÓN DE PERMALINKS A LA PÁGINA PRINCIPAL DEL TEMA’ está cerrado a nuevas respuestas.