Soporte » Instalación – Actualizaciones » Reinstalar a nueva versión en localhost

  • Resuelto LuisVican

    (@luisvican)


    He instalado WordPress la version 3.5 en localhost, bajo Linux. No he empezado a utilizarla ( la versión). He intentado actualizar a la versión 3.5.1 y me pide nombre de usuario y contraseña de la ftp. Quisiera saber el procedimiento para la actualización o quizá simplemente haya que reinstalar la versión. Si es así, ¿se puede montar sin previamente eliminar/borrar la anterior? ¿hay que eliminar la versión anterior?.

    gracias

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • No borres nada, puedes instalar la v 3.5.1. Te pide user y password de ftp para poder bajar la última versión de WP mediante ftp.

    Si quieres que lo baje de forma directa sin ftp, puedes añadir esta linea en el archivo wp_config.php.

    define('FS_METHOD','direct');

    Así no te preguntará más por usuario/contraseña

    Un saludo

    Iniciador del debate LuisVican

    (@luisvican)

    Hola Pedro,

    tengo alguna duda:

    ¿en que lugar coloco la linea?. Al principio , al final, detrás de algun dato.

    ¿vale solamente con esta linea? o ¿hay que darle algún otro dato como //**FTP……..**//.

    gracias

    Luis

    Colocala al final. Con eso es suficiente.

    Un saludo

    Iniciador del debate LuisVican

    (@luisvican)

    Correcto. Ha sido suficiente, pero además tenía un error en la concesión de permisos. La instalación de Apache está con propiedad y grupo root y el resto de los archivos de WordPress se le habian concedido permisos de usuario, así que concedí permisos 777. Como estoy actuando en localhost no me importa de momento la seguridad.

    Gracias Pedro

    un saludo

    Iniciador del debate LuisVican

    (@luisvican)

    Correcto. Ha sido suficiente, pero además tenía un error en la concesión de permisos. La instalación de Apache está con propiedad y grupo root y el resto de los archivos de WordPress se le habian concedido permisos de usuario, así que concedí permisos 777. Como estoy actuando en localhost no me importa de momento la seguridad.

    Gracias Pedro

    un saludo

    gracias pedro… tenía el mismo problema y me traía de cabezas, hasta ahora que lo he resuelto con tu ayuda

    Hola, he añadido la línea y ya no me sale lo de ftp pero al descargar el tema y descomprimirlo me da el siguiente error:

    Descargando el archivo de instalación de http://wordpress.org/themes/download/dine-with-me.1.0.5.zip…

    Descomprimiendo…

    No ha sido posible crear el directorio /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/upgrade/dine-with-me.tmp

    que puedo hacer?
    gracias
    un saludo

    Ya dí con ello, era cuestión de permisos, simplemente le he dado permiso leer y escribir a los directorios que me decía que era imposible crear.
    un saludo

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • El debate ‘Reinstalar a nueva versión en localhost’ está cerrado a nuevas respuestas.