Soporte » Guías – Resolución de problemas » Se cierra la base de datos mysql en local y me impide dejarla accesible

  • Resuelto isp00rt

    (@isp00rt)


    Saludos,
    No estoy seguro de que sea este el foro adecuado para mi duda, con lo que pido disculpas por adelantado si no es así. Mi problema es que soy muy, muy novato y me he encontrado con un problema inesperado que no sé resolver. Trabajo en local usando XAMPP y durante el mes largo que llevo preparando mi primera página web no me había dado ningún problema. Sin embargo, hoy no puedo acceder a ella porque desde el XAMPP me cierra la base de datos mysql a los pocos segundos de abrirla. Este es el mensaje que me aparece en la propia pantalla del XAMPP:

    —————————————————-
    9:22:08 AM [Apache] Attempting to start Apache app…
    9:22:08 AM [Apache] Status change detected: running
    9:22:16 AM [mysql] Attempting to start MySQL app…
    9:22:16 AM [mysql] Status change detected: running
    9:22:26 AM [mysql] Status change detected: stopped
    9:22:26 AM [mysql] Error: MySQL shutdown unexpectedly.
    9:22:26 AM [mysql] This may be due to a blocked port, missing dependencies,
    9:22:26 AM [mysql] improper privileges, a crash, or a shutdown by another method.
    9:22:26 AM [mysql] Press the Logs button to view error logs and check
    9:22:26 AM [mysql] the Windows Event Viewer for more clues
    9:22:26 AM [mysql] If you need more help, copy and post this
    9:22:26 AM [mysql] entire log window on the forums
    —————————————————

    Tal como indica el mensaje, abrí el archivo de logs para ver qué dice, y esto es lo que aparece:

    —————————————————
    2019-08-12 9:19:11 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2019-08-12 9:19:11 0 [Note] InnoDB: Uses event mutexes
    2019-08-12 9:19:11 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
    2019-08-12 9:19:11 0 [Note] InnoDB: Number of pools: 1
    2019-08-12 9:19:11 0 [Note] InnoDB: Using SSE2 crc32 instructions
    2019-08-12 9:19:11 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M
    2019-08-12 9:19:11 0 [Note] InnoDB: Completed initialization of buffer pool
    2019-08-12 9:19:11 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
    2019-08-12 9:19:11 0 [Note] InnoDB: Creating shared tablespace for temporary tables
    2019-08-12 9:19:11 0 [Note] InnoDB: Setting file ‘C:\xampp\mysql\data\ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …
    2019-08-12 9:19:11 0 [Note] InnoDB: File ‘C:\xampp\mysql\data\ibtmp1’ size is now 12 MB.
    2019-08-12 9:19:11 0 [Note] InnoDB: Waiting for purge to start
    2019-08-12 9:19:11 0 [Note] InnoDB: 10.3.16 started; log sequence number 55984813; transaction id 51307
    2019-08-12 9:19:11 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool
    2019-08-12 9:19:11 0 [Note] InnoDB: Buffer pool(s) load completed at 190812 9:19:11
    2019-08-12 9:19:11 0 [Note] Plugin ‘FEEDBACK’ is disabled.
    2019-08-12 9:19:11 0 [Note] Server socket created on IP: ‘::’.
    —————————————————

    No tengo ni idea de lo que dice y por eso me gustaría que alguien me pudiese ayudar, ya que no puedo continuar trabajando en mi web. El único motivo que se me ocurre por el cual esto ha pasado es que la última vez que trabajé en ella hace unos días me instalé el plugin «Duplicator» para hacer copias de seguridad. Hice la primera de ellas y no medió ningún problema, pero desde entonces no había vuelto a tocar el emulador.

    ¿Podría alguien echarme una mano, por favor?

    Muchas gracias pro adelantado.

Viendo 2 respuestas - 1 de 2 (de 2 total)
  • Moderador LGrusin

    (@lgrusin)

    Como te comenté en otro debate anterior la configuración de un servidor no es algo específico de WordPress, hay infinidad de combinaciones posibles según cada caso partidular.

    Prueba optimizar y/o reparar las tablas de las bases de datos desde phpMyAdmin

    Ok. Gracias.

Viendo 2 respuestas - 1 de 2 (de 2 total)
  • Debes estar registrado para responder a este debate.