Soporte » Guías – Resolución de problemas » Sitemap: X-Robots-Tag: noindex, follow

  • Resuelto mauroamestoy

    (@mauroamestoy)


    Hola, que tal? Mi nombre es Mauro. Soy nuevo en este universo WordPress. Estoy intentando armar un blog para mi novia, recién estoy dando mis primeros pasos pero ya me encuentro con algunos problemas que no puedo resolver y esperaba pedirles un poco de ayuda. El problema que estoy teniendo es que no puedo enviar a google search console el sitemap de mi web. Al intentar inspeccionar mi URL me responde que «la URL no esta en Google». Luego al solicitar que lo indexe tampoco lo puede hacer porque «se ha detectado la etiqueta «noindex» en el encabezado HTTP «X-Robots-Tag»». Despues de mucho investigar note que el problema podría venir de YOAST SEO que utilizo por lo que modifique todo lo que pude para que sea visible a los motores de búsqueda pero aun así no tuve éxito. Ya no se que mas podría hacer para que esto se soluciones, probé absolutamente todo lo que encontré en distintos foros y aun así sigo sin tener éxito. Desde ya les agradezco cualquier sugerencia que puedan hacerme. Saludos

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • kallookoo

    (@kallookoo)

    Hola,

    He mirado tu web y creo que primero deberias hacer la web con contenido y luego cuando tengas contenido y entiendas un poco mas ya te preocuparas por el SEO y deberes aprender los conceptos basicos. El Yoast esta bien pero tambien tienes que saber configurarlo ya que tiene lo suyo. Personalmente si la web no es para uso comercial y no se tiene intencion de sacarle beneficio hay otro plugins mas sencillos. Lo que quiero decir es que no puedes empezar una casa por el tejado.

    Dicho esto hay una opcion que ahora no me acuerdo si el yoast la controla y es que el propio WordPress puede decir que los buscadores no indexen. La puedes encontrar en Ajustes – Lectura, por si acaso compruebala.

    mauroamestoy

    (@mauroamestoy)

    Buenos dias kallookoo, antes que nada queria agradecerte por la respuesta que me brindaste. Si no te molesta te hago algunos comentarios de dudas que me surgen. Primero que nada esto ultimo que escribes ya lo he intentado pero aun asi sigue todo igual. Lo segundo es que, al ser nuevo en este universo, tengo miedo de crear la web (que ademas de un blog va a ser de venta de productos) y luego por no poder indexarla de forma correcta con search console tenga que volver a cero todo lo creado. Es solo por eso que no he podido avanzar en la construccion de la web, me gustaria resolver este problema para asi ya olvidarme. Muchas graciassss

    kallookoo

    (@kallookoo)

    Hola,

    No te puedo ayudar mucho, mas. Como te comentaron en el foro de Yoast solo debes añadir el sitemap_index.html en el google.

    Solo se me ocurre que pase lo siguiente:
    – El servidor lo tiene por configurado por algun motivo.
    – Tengas un archivo llamado robots.txt o .htaccess y lo tengas configurado para no indexar, puedes tener los dos o ninguno.

    • Esta respuesta fue modificada hace 8 meses por  kallookoo.
    Moderador Fernando Tellado

    (@fernandot)

    Hola Mauro ¿con qué páginas te pasa? He revisado tu robots.txt y no está bloqueando nada, pero como te dice @kallookoo ahora no tienes contenido, solo el hola mundo, así que antes concéntrate en crear contenido propio y, cuando ya lo tengas, entonces manda el mapa del sitio a la consola de Google, no antes.

    Tu entrada y portada no tienen cabecera noindex así que es simplemente que no tienes contenido, que Google te ha rastreado antes de tiempo y encontró tu sitio con otro robots.txt que bloqueaba todo. De todos modos dale al contenido, a priori lo tienes bien.

    Cuando lo tengas vacía todas las cachés de tu web y servidor y envía el mapa del sitio a la Search Console.

    mauroamestoy

    (@mauroamestoy)

    Vale, pues hare esto que me dices, No me detengo mas y continuare en la construccion del sitio. Les agradezco muchisimo la informacion brindada tanto a @kallookoo como a ti @fernandot
    Gracias y saludos.

    Mauro

    kallookoo

    (@kallookoo)

    Mauro añado algo mas que no lo comente,

    Mientras que no este en produccion (terminada), desactiva cualquier plugin de SEO y marca la opcion que te comente en Ajustes – Lectura para prevenir que se indexe las pruebas y que luego tengas 404 por ejemplo en google.

    Cuando estes introduciendo el producto final, post o paginas, entonces antes desmarca la option y activa el plugin de SEO que uses para que se empice a indexar el contenido correcto

    • Esta respuesta fue modificada hace 8 meses por  kallookoo.

    Hola, tengo exactamente el mismo problema, estoy arrancando con mi web, envié el sitemap de mi sitio con todas las url’s de mi web para que Search Console lo indexara (aclaro que tienen contenido) como no lo hizo, inspeccioné la URL en el apartado específico del Search Console y en el informe me tira «La URL no está disponible para Google» y en los detalles de la causa me aparece:

    «¿Se permite la indexación? No: se ha detectado la etiqueta «noindex» en el encabezado HTTP «X-Robots-Tag»

    Revisé mi robot.txt y NO está bloqueando nada, entonces cual es el problema y cómo podría solucionarlo?

    Gracias de antemano

Viendo 7 respuestas - 1 de 7 (de 7 total)
  • El debate ‘Sitemap: X-Robots-Tag: noindex, follow’ está cerrado a nuevas respuestas.