Soporte » Comunidad » Peticiones y feedback » SITIO CON CONTRASEÑA

  • Resuelto cdbm1980

    (@cdbm1980)


    Hola.

    Acabo de adquirir un VPS para ir migrando servicios desde otro hosting que tengo. He trasladado un par de dominios para ir probando y a la hora de crear un proyecto WordPress nuevo en el modo edicion no hay problema, puedo maquetar la web sin pegas. Pero cuando quiero acceder como si fuera un visitante me solicita el usuario y contraseña para poder visualizarse.

    Ya probe varias cosas con http y https desactivar la seguridad incluso reinstale WordPress pero sigue igual. ¿Alguna idea?

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Jose Luis

    (@jose64)

    Hola

    Eso que planteas no es problema de la instalación de WordPress, sino de la configuración de seguridad en el servidor, tienes protegido por contraseña el acceso a la carpeta de tu instalación.

    Puedes eliminar esa limitación editando el archivo .htacces:

    AuthType, AuthName, AuthUserFile y require valid-user son los parámetros que definen la autenticación, si eliminas el último (require valid-user) el acceso será libre.

    Si con esto queda aclarada tu duda coméntalo y porfavor, recuerda cerrar el debate marcándolo como resuelto, de esta forma nos ayudas a mantener el foro al día.

    cdbm1980

    (@cdbm1980)

    Buenas tardes.

    He mirado pero no tengo ningun archivo .HTACCESS ni en la raiz ni en httpdocs, he probado creandolos vacios pero el problema persiste. Estos son los cuatro que encuentro y no contienen dichas entradas tampoco.

    httpdocs/wp-content/plugins/akismet/.htaccess
    httpdocs/.well-known/acme-challenge/.htaccess
    .composer/cache/.htaccess
    .composer/.htaccess

    cdbm1980

    (@cdbm1980)

    Tras un rato trasteando foros y demas he encontrado el problema.

    En el panel PLESK dentro de DOMINIOS y al abrir el dominio en cuestion hay una opcion que es «DIRECTORIOS PROTEGIDOS POR CONTRASEÑA» que por algun motivo habia añadido la ruta ./ dentro tras borrar la entrada la web ya es accesible sin necesidad de claves.

    Gracias por la ayuda.

    Moderador Jose Luis

    (@jose64)

    Hola.

    Dependiendo de la configuración del servidor está en algunos sitios o en otros. Esa opción la puedes usar para hacer inaccesibles partes de tu instalación.

    Grcias por compartir la solución, y por favor, recuerda cerrar el debate marcándolo como resuelto, así nos ayudas a mantener el foro al día.

    cdbm1980

    (@cdbm1980)

    SOLUCIONADO

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.