Soporte » Plugins y Hacks » Solicitud: Problemas para insertar reproductor de Twitch en mi pagina

  • Resuelto makdiele

    (@makdiele)


    Buenos dias, solicito por favor su colaboración, al insertar en mi pagina el player de Twitch me dice «¡Ups! Esta inserción está mal configurada.
    (Desarrolladores: comprueben la consola del navegador para más información.)»
    me redirige a la siguiente pagina:
    https://dev.twitch.tv/docs/embed/video-and-clips/

    He intentado varias maneras de solucionar y no he podido hacerlo, agradezco su ayuda con alguna forma de corregirlo, desde ya: Muchas gracias.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 17)
  • Moderador Jose Luis

    (@jose64)

    Hola

    Si nos dices cómo lo has implementado y cómo has tratado de solucionarlo es posible que podamos ayudarte, sin un código para hacer pruebas no vamos a poder darte ayuda.

    Muchas gracias por contestar:
    En primera opcion fue incrustando el iframe que brinda Twitch por defecto (antes me trabajaba sin problemas, desde aproximadamente un mes hacia es que comenzó a tirar el error), el codigo es el siguiente:
    <iframe src="https://player.twitch.tv/?channel=lanuevavisionhd&parent=www.example.com" frameborder="0" allowfullscreen="true" scrolling="no" height="378" width="620"></iframe>

    Intenté a la vez con otro canal de Twitch al azar para verificar que no fuese solo

    Intenté a la vez con otro canal de Twitch al azar para verificar que no fuese solo mi canal el del error, en efecto, es en general que presenta el inconveniente.

    Luego probé la instalación de diferentes plugins como ser:
    – Twitch for WordPress
    – Twitch Status
    – entre otros

    los cuales no me aparece el reproductor (queda un cuadro gris) pero si coloco que muestre el status (online u offline) eso si lo refleja, pero no me aparece el video en directo.

    agradezco nuevamente su colaboración.

    • Esta respuesta fue modificada hace 3 semanas, 1 día por Jose Luis. Razón: Corregir y etiquetar código
    Moderador Jose Luis

    (@jose64)

    Hola

    Tienes este código en el iframe:

    parent=www.example.com

    Ese es un código con una url de ejemplo, debes reemplazarlo por la tuya, según la documentación de Twitch:

    parent (string) (required): Domain(s) that will be embedding Twitch. You must have one parent key for each domain your site uses.

    Coméntanos si con ese ajuste lo resuelves y, por favor, recuerda cerrar el debate marcándolo como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Tambien realicé esa prueba, perdon se me olvido mencionarlo, y aparece un recuadro transparente. adjunto link para que veas la imagen como aparece.

    Imagen del error

    makdiele

    (@makdiele)

    pero si no modifico el sitio web (www.example.com) ahi me aparece el recuadro que esta mal configurado, cuando le cambio a mi pagina entonces se coloca totalmente transparente.

    Adjunto nueva imagen.

    Imagen

    Moderador Jose Luis

    (@jose64)

    Hola

    Yo acabo de insertarlo usando el plugin Simple Iframe

    En la configuración del bloque usa como URL:

    https://player.twitch.tv/?channel=lanuevavisionhd&parent=lanuevavisionhd.com

    Con este plugin lo puedes incluir como un bloque e inclusive visualizarlo a pantalla completa.

    Si quieres insertarlo como un bloque html con el código:

    <iframe src="https://player.twitch.tv/?channel=lanuevavisionhd&parent=lanuevavisionhd.com" frameborder="0" allowfullscreen="true" scrolling="no" height="378" width="620"></iframe>

    Coméntanos y recuerda cerrar el debate marcándolo como resuelto cuando así sea, así nos ayudas a mantener el foro al día.

    • Esta respuesta fue modificada hace 3 semanas por Jose Luis. Razón: Corregir código
    makdiele

    (@makdiele)

    Realicé la prueba de las dos maneras que me indicas y el resultado es el de la imagen siguiente:

    Imagen

    La parte superior es la de incrustar como un bloque html lo que me refleja es mi misma pagina web (www.lanuevavisionhd.com) pero incrustado, lo que necesito es que este el enlace de mi canal en vivo en twitch (www.twitch.tv/lanuevavisionhd); y el otro modo me queda el reproductor en negro, si funcionar play cualquier botonera.

    gracias por tu ayuda, a la espera siempre.

    Moderador Jose Luis

    (@jose64)

    Hola

    Algo estás haciendo mal, aquí tienes tu canal insertado como html y con el plugin que te indiqué, con el código que te indiqué (cambiando el parámetro parent por la url de mi dominio):

    https://imgur.com/a/ZBqsyvg

    makdiele

    (@makdiele)

    Tienes mucha razon a vos te trabaja a la perfección.

    que estaré haciendo mal?

    adjunto imagen del iframe

    imagen

    Moderador Jose Luis

    (@jose64)

    Acabo de hacer una prueba y una corrección en el código, le quité el último /, haz la prueba con:

    https://player.twitch.tv/?channel=lanuevavisionhd&parent=lanuevavisionhd.com

    makdiele

    (@makdiele)

    imagen

    Tambien lo hice, asi lo tengo y me queda transparente todo.

    voy a eliminar los plugins de twitch que tengo para ver si eso es que me esta afectando

    makdiele

    (@makdiele)

    Te comento que borré todos los plugins de twitch y publiqué la pagina con las dos utilidades (iframe y html) y al abrirlo con otro navegador me muestra lo siguiente:

    imagen

    makdiele

    (@makdiele)

    si quieres entrar para ver la pagina es http://www.lanuevavisionhd.com/test

    Si das clic en «abre esto en una ventana nueva» te abre la pestaña con el video correctamente.

    hola buenas tardes, tengo el mismo problema y no logro como arreglar esto, segui los pasos que indican aqui y lo unico que encuentro este este error

    http://lavozdegenova.com.co/?page_id=74

    gracias por su ayuda

    Estamos igual con el problema estimado.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 17)
  • Debes estar registrado para responder a este debate.