Soporte » Instalación – Actualizaciones » Subir nuevas imagenes luego de haber migrado el DNS

  • Resuelto irinamixfilms

    (@irinamixfilms)


    Saludos nuevamente,
    Luego de recuperar mi sitio, el WP no muestra las nuevas imagenes que subo a la biblioteca.

    Las nuevas imagenes se encuentran direccionados al nuevo DNS, pero al hacer click no se muestran tampoco.

    Como puedo resolver esto?
    Muchas gracias de antemano.

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • Moderador almendron

    (@almendron)

    No entiendo muy bien a qué refieres. A ver si puedes poner la URL de la entrada o página donde fallan las cargas de esas imágenes.

    Iniciador del debate irinamixfilms

    (@irinamixfilms)

    Hola @almendron

    He subido 3 fotos luego de haber migrado el DNS de mi WP.
    Estos son los enlaces:
    http://www.tierragrande.co/wp-content/uploads/2017/01/portada_00.jpg
    http://www.tierragrande.co/wp-content/uploads/2017/01/SALAR_UYUNI_header.jpg
    http://www.tierragrande.co/wp-content/uploads/2017/01/rodaje_2015.jpg
    Los .jpg no se muestran dentro de la galería multimedia de WP y tampoco se muestran cuando los enlazo dentro de una entrada.

    Porqué ocurre este fallo? Gracias de antemano

    Moderador almendron

    (@almendron)

    Accede vía FTP y comprueba si esos archivos están en la carpeta «uploads».

    En el caso de que no estén, comprueba los permisos de la carpeta. Deben ser 755 o 775.

    Iniciador del debate irinamixfilms

    (@irinamixfilms)

    Buen dia, he accesado por FTP y quizas he detectado el problema, pero no se como resolverlo.

    El WP ha creado de forma automática una carpeta llamada geo (antiguo nombre) donde esta subiendo las imagenes a una carpeta /2017
    Mis archivos del sitio estan en una carpeta llamada geologia (nuevo nombre que le di al folder cuando hice la migración). ¿ Sera que debo cambiarle el nombre a geo a esta carpeta ?

    Gracias por el apoyo 🙂

    Moderador almendron

    (@almendron)

    No entiendo eso de que tus archivos están en la carpeta «geologia». ¿Te refieres a las imágenes o a todos los archivos?
    Es que, por lo que yo veo, los archivos están en el directorio raíz y las imágenes en la carpeta Uploads.
    En Ajustes > Generales, ¿qué tienes puesto en Dirección de WordPress (URL) y Dirección del sitio (URL)?

    Me olvidaba: ¿puedes poner la ruta completa a alguna de las imágenes que ha metido en «geo»?

    • Esta respuesta fue modificada hace 4 años, 2 meses por almendron.
    Moderador almendron

    (@almendron)

    Otra cosa que deberías hacer es mirar en la tabla xx-options y ver le valor que tiene «upload_path».

    Iniciador del debate irinamixfilms

    (@irinamixfilms)

    Todos los archivos del sitio estan el una carpeta llamada geologia, que antes de la migración se llamaba geo

    En esta carpeta geo (que se ha creado automaticamente) se estan subiendo las imagenes ahora ¿?

    Por ejemplo una ruta es: /htdocs/geo/wp-content/uploads/2017/01/portada_00.jpg

    ——
    En ambos campos Dirección y Dirección del Sito he colocado: http://www.tierragrande.co

    En tabla geo_options no encuentro algo llamado ‘upload_path’
    Encuentro algo como esto:
    option_id
    option_name
    option_value
    autoload

    Graciass por el apoyo!

    Moderador almendron

    (@almendron)

    Algo no me cuadra. Tus archivos deberían estar en la raiz y no en una carpeta.
    1) Revisa bien la tabla geo_options a ver si te aparece algo relacionado con la carpeta «geo» o «geología».
    2) ¿Tienes alguna redirección en el htaccess?

    Iniciador del debate irinamixfilms

    (@irinamixfilms)

    1)
    Asi aparecen mis carpetas DE SITIOS no estan en raiz sino en un folder común llamado htdocs

    https://www.dropbox.com/s/aa2opi8dga0sev7/Screenshot%202017-01-23%2010.54.02.png?dl=0

    Asi aparece geo_options:

    https://www.dropbox.com/s/f96d1moquj6m15l/Screenshot%202017-01-23%2011.00.34.png?dl=0

    2) Donde encuentro eso de htaccess ?

    Moderador almendron

    (@almendron)

    Vuelva a buscar en geo_options y busca upload_path (pasa de página que hay más opciones que esas 🙂 )

    htaccess: dentro de la carpeta donde esté instalado WP.

    Y me temo que no puedo ser de más ayuda: no entiendo como puedes tener instalado WP en una carpeta del directorio raíz de tu sitio y acceder a ella con un dominio.
    ¿No tendrás instalado el multisitio?

    Iniciador del debate irinamixfilms

    (@irinamixfilms)

    Encontré el upload_path y Dice lo siguiente:

    /home/users/web/b329/pow.pitbullpty/htdocs/geo/wp-content/uploads

    Cambio geo por geologia?

    Dentro de htdocs tengo todas las carpetas con los sitios que manejo hace años.
    Todos con un WP dedicado

    Moderador almendron

    (@almendron)

    Sí. Cambia geo por geologia. Eso debería solucionar el problema.

    Iniciador del debate irinamixfilms

    (@irinamixfilms)

    GRACIAS UN MILLÓN @almendron
    Asunto resuelto. La web esta en talla http://www.tierragrande.co 🙂
    Saludos desde Panamá

    Moderador almendron

    (@almendron)

    De nada. Un saludo desde España.

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • El debate ‘Subir nuevas imagenes luego de haber migrado el DNS’ está cerrado a nuevas respuestas.