Soporte » Diseño – Temas y plantillas » Tamaño de la letra en movil

  • Resuelto josefigueroa92

    (@josefigueroa92)


    Hola, Tengo un problema en mi web con el tamaño de la letra: https://lightandcoffee.es/

    Para poner en contexto instale el tema de wordpress 2022 como primera opción, aunque por razones que no vienen a cuento lo cambien de nuevo al 2021.

    Tengo la letra por defecto en los párrafos, que es equivalente a 20, pero cuando entro en esta desde el móvil la letra cambia y ya no es de 20 si no mucho más pequeña. Quiero que en móvil se siga viendo a 20 ya que search console se queda de que la letra es pequeña..

    Como puedo hacer esto?? Normalemnte en otras web no es necesario hacer nada, se queda al mismo tammaño en movil, pero algo hizo el tema 2022 que ahora se quedo asi..

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    No es el tema, fue la actualización de WordPress, prueba añandir este código al archivo functions.php de tu tema hijo o a un archivo de personalizaciones como Code Snippets:

    /*  DISABLE GUTENBERG STYLE IN HEADER| WordPress 5.9 */
    function wps_deregister_styles() {
        wp_dequeue_style( 'global-styles' );
    }
    add_action( 'wp_enqueue_scripts', 'wps_deregister_styles', 100 );

    Puedes revisar la explicación en este debate del foro en inglés:

    How to disable inline styling (style id=’global-styles-inline-css’)?

    Recuerda borrar la caché para probarlo. Comenta si con esto lo resuelves y, por favor, recuerda marcar el debate como resuelto cuando así lo consideres, de esta forma nos ayudas a mantener el foro al día.

    • Esta respuesta fue modificada hace 4 meses, 1 semana por Jose Luis. Razón: corregir enlace erróneo
    Iniciador del debate josefigueroa92

    (@josefigueroa92)

    Hola @jose64, gracias por tu respuesta.

    EL enlace que me pusiste esta roto, no puedo ver la explicación y respecto al código la verdad no se en que parte del archivo function.php tengo que ponerlo. Perdona mi ignorancia, no se programar. Lo pongo al final, al principio, en algún lugar en especifico?

    Estaré atento a tu respuesta

    Saludos

    Jose

    Moderador almendron

    (@almendron)

    Lo más sencillo es crear tu propio plugin personal. Es independiente del tema que uses y puedes ir añadiendo distintos códigos:

    https://www.almendron.com/blog/crear-nuestro-plugin-personal/

    En tu caso, las siguientes líneas te servirían (lee primero el artículo que te he enlazado):

    <?php
    /*
    Plugin Name: Funciones
    Description: Plugin personal.
    */
    
    /*  DISABLE GUTENBERG STYLE IN HEADER| WordPress 5.9 */
    function wps_deregister_styles() {
        wp_dequeue_style( 'global-styles' );
    }
    add_action( 'wp_enqueue_scripts', 'wps_deregister_styles', 100 );
    Moderador Jose Luis

    (@jose64)

    Hola @josefigueroa92

    Ya corregí el enlace. Con respecto a lo segundo si tienes un tema hijo puedes añadir el código al final del archivo functions.php, si no tienes tema hijo no lo hagas así porque se perderá con las actualizaciones.

    La mejor opción es la que te indica @almendron, también puedes usar un plugin de personalizaciones como Code Snippets si no quieres crear un plugin personal.

    Finalmente te dejo un enlace con las explicaciones en Español:

    Problema de rendimiento y seguridad: Desactiva ya los estilos globales (global-styles) de la edición completa del sitio

    Coméntanos si con alguna de estas soluciones lo resuelves y, por favor, recuerda marcar el debate como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate josefigueroa92

    (@josefigueroa92)

    Perfecto, me va a costar un poco porque no se de programación ni este tipo de cosas, pero yo averiguo. Gracias por la ayuda @jose64 @almendron

    Saludos!

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

    Iniciador del debate josefigueroa92

    (@josefigueroa92)

    @almendron @jose64 Perdonen chicos por molestarlos otra vez, tengo otro problema con la misma web y no se omo solucionarlo, he desconectado todos los plugin y limpiado caches, pero la web me sale asi en pantallas de pc, no me pasa en el movil.

    https://prnt.sc/d8zP1r8nqrfL

    Tienen idea de que puede ser??

    Moderador Jose Luis

    (@jose64)

    Hola.

    No basta con limpiar la caché, desactiva el plugin de caché y prueba, seguramente las opciones de optimización son las que causan eso.

    Iniciador del debate josefigueroa92

    (@josefigueroa92)

    @jose64 Gracias, te conteste en el otro hilo!

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Debes estar registrado para responder a este debate.