Soporte » Diseño – Temas y plantillas » Tema duplica site-title

  • Resuelto EstherCoach

    (@esthercoach)


    Hola!

    DATOS:
    Versión de WordPres: 5.8.1
    Tema: Astra
    Otros: Elementor

    Acabo de realizar un diagnóstico de la página https://terapiaconalma.es/ y veo que tiene la etiqueta <h1> duplicada en la página de inicio. He estado mirando por los foros de WordPress y, gracias a vosotros, he dado con el por qué, pero no con el cómo solucionarlo, sin cambiar de tema.

    Primero he desactivado Elementor. He abierto el código fuente de la página Ctrl+U y seguía saliendo duplicado el <h1>.
    Después he activado el tema por defecto de WordPress, ctrl+u, y ya no está duplicado.

    Conclusión: es Astra el que duplica la etiqueta del site-title.

    Pero, como no voy a cambiar ahora de tema, ¿alguien sabría decirme si eso lo puedo cambiar en el editor de temas, en qué archivo concretamente y con qué código fuente?

    Sé que es mucho pedir, pero estoy segura de que para muchos de vosotros esto es algo súper simple.

    Quiero agradeceros de antemano vuestra ayuda
    Feliz finde para aquellos que no trabajen!
    Esther

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 12 respuestas - de la 1 a la 12 (de un total de 12)
  • Moderador almendron

    (@almendron)

    Iniciador del debate EstherCoach

    (@esthercoach)

    Hola @almendron! Tú siempre al rescate.

    Sí, este post ya lo había leído, pero no es mi caso y ninguna de las soluciones me sirve. Igual que le pasa a uno de los comentaristas de ese mismo post. Tellado asegura que el problema es la combinación Astra – Elementor, pero, al menos en este caso concreto, no lo es.

    En la web que me interesa, se duplica la etiqueta <h1> en la página de inicio, pero en el resto de páginas no se asigna ninguna en absoluto. Parece que Astra «takes over» WordPress y, a menos que la pongas manualmente, no se asigna de forma automática. No había mencionado esto antes porque me parece un problema aparte, pero lo dejo aquí por si le interesa a alguien.

    En definitiva, como ninguna de las soluciones del post que me facilitas funciona, sabrías decirme cómo eliminar una de esas etiquetas? Gracias de antemano

    (Ahora manos a la obra a meter los h1 que faltan en el resto de páginas. Mira que esto ya se lo dije a Astra hace por lo menos dos años. Pues lo arreglaron y parece que después se les ha vuelto a ir la pinza).

    Moderador Fernando Tellado

    (@fernandot)

    Hola @esthercoach

    ¿Tienes creada la cabecera con el constructor de cabeceras de Astra? Por el código parece que un h1 lo pilla del título del sitio en los ajustes del personalizador (bajo el logo) y el otro por el constructor de cabeceras.

    La manera más sencilla de quitar un h1 sería poner un logo ya con el nombre de tu servicio y quitarlo de los ajustes del personalizador

    Iniciador del debate EstherCoach

    (@esthercoach)

    Hola Fernando!

    Antes de nada, gracias por tu respuesta y consejo.

    No sé si te he entendido bien. He eliminado el título de los ajustes del personalizador de Astra (Apariencia>maquetador de cabeceras>título y logotipo del sitio>Título del sitio). Lo he intentado ahí de dos formas:
    1. Desactivando la opción «Mostrar título del sitio» – sigo viendo dos h1 en el código
    2. Borrando directamente el texto – sigo viendo dos h1 en el código

    Lo dejo tal cual para que lo puedas ver. No sé si te referías a esto?

    Moderador Fernando Tellado

    (@fernandot)

    Yo sigo viendo lo mismo

    Iniciador del debate EstherCoach

    (@esthercoach)

    Por eso te preguntaba si era eso lo que me querías decir… Yo también sigo viendo los dos h1. Lo único que ha desaparecido en realidad es el título que antes se veía bajo el logo, pero los h1 siguen en el código.
    ¿Alguna otra idea?

    Moderador Fernando Tellado

    (@fernandot)

    Ya tendría que ver la web por dentro para más. Porque yo sigo viendo el título bajo el logo, y claro, así sigue habiendo 2 h1

    Iniciador del debate EstherCoach

    (@esthercoach)

    Hola de nuevo Fernando
    LOL, es que acabo de volver a poner el título, puesto que parece que no tiene remedio. No quiero molestarte más. Total, si esto pasase en todas las páginas, me preocuparía, pero siendo nada más que en la home, lo voy a dejar pasar. Pensaba que iba a ser algo mucho más sencillo de corregir.

    De todos modos, muchas gracias por vuestra ayuda, a los dos, y que tengáis una estupenda semana!

    Esther

    Moderador Fernando Tellado

    (@fernandot)

    Seguro que es una bobada que se nos escapa, de ajustes del tema, seguro, yo lo uso en decenas de sitios y en ninguno tengo ese problema, con Elementor o sin él.

    A las malas, no es un problema de SEO ya que ambos h1 tienen el mismo texto, así que ahí no hay problema, y con la manía que ha cogido Google últimamente de pillar cualquier H para los resultados, pues como que esto pasa a segundo plano

    Iniciador del debate EstherCoach

    (@esthercoach)

    En efecto, Fernando. Si lo hacía por niquelar eso, para que no me digan las htas de análisis «mimimi que tienes dos h1!»… Al final es uno solo de los doscientosmil millones de factores que Google toma en cuenta a la hora de rankear y posicionar la web, así que mira, dos duros. No podemos estar aquí perdiendo tiempo por estas nimiedades, verdad?

    Lo dicho, muchas gracias igualmente y hasta otra!
    Esther

    Iniciador del debate EstherCoach

    (@esthercoach)

    Buenas, había cerrado este thread pero acabo de recibir respuesta de los chicos de Astra, que paso a copiar y pegar. Lo siento por los que no hablen inglés, pero básicamente dicen que se pondrán a ello. Ya eran conscientes del error del h1 duplicado. No eran conscientes, por otro lado, del otro error que les indiqué (el h1 desaparece si se desactiva el título en las páginas, cosa que hacemos todos). Os dejo mi email a ellos y su respuesta. Espero que sea útil.

    «Hi
    Tag <h1> appears twice on the home page, despite the fact that I HAVE NOT ADDED IT. It is a recurring Astra problem.

    I have deactivated Astra and activated a WordPress default theme. Result: there is no duplicate h1 anymore.

    So, evidently, there is an error on the Astra home page coding. I’d very much like it to be fixed. This has been happening for years now.

    The other huge error is that when we set up our pages (other than home) to NOT SHOW TITLE, then we have to add tag manually, because your theme doesn´t allow wordpress to use it when this option is uncheck. This doesn’t happen with other themes. We uncheck the option to show title, but the tag is still there in the code.

    I love Astra and have been using it for ages now, along with Elementor. But if things continue like this, and I can honestly tell you that I speak for thousands of WordPress users and designers, we will end up using another theme that doesn’t have these huge errors. Please, do fix it.»

    RESPUESTA DE ASTRA:
    «Hi Esther,

    Thank you for contacting our support. I am Herman from the Astra team.

    Yes, we are aware of the issue and our concerned dev team is working on the fix. We are sorry for the inconvenience you may have because of this.

    And regarding the Disable Title feature, thank you for your insight. I will definitely forward this to our concerned dev team.»

    Moderador almendron

    (@almendron)

    Gracias por la información.

Viendo 12 respuestas - de la 1 a la 12 (de un total de 12)
  • Debes estar registrado para responder a este debate.