Soporte » Plugins y Hacks » WooCommerce » Tienda de woocomerce

  • Resuelto atilio85

    (@atilio85)


    Hola, es un error minimo creo, tengo w10 y esto me ocurre en el navegador crome.
    La pagina tienda de woocomerce muestra 2 veces la misma informaciónn antes solo mostraba todos los numeros de articulos de 1 a (tantos articulos).
    Esto cambio hace poco ya que se actualizo automaticamente la base de datos de woocomerce y la version de wordpress junto con todos los plugins.
    Si se fijan en la cualquier pestaña de alguna categoria hombre mujer etc aparece como siempre mostrando todos los numeros de articulos de 1 a (tantos articulos).
    Lo unico que hice yo hace unos dias atras fue desactivar el autoptimize ya que este no me dejaba visualizar las imagenes en la ficha de productos, este error tambien ocurrio por que se actualizo todo automaticamente y lo solucione desactivando el autoptimize ahora solo queda ver por que me aparece asi la tienda, y si vuelvo a activar autoptimize o lo dejo asi nomas.

    • Este debate fue modificado hace 9 meses por Jose Luis. Razón: Mover al foro adecuado

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • kallookoo

    (@kallookoo)

    Hola @atilio85

    Por lo que comentas cuando se actualizo sucedio algo o hay algun incompatibilidad que esta produciendo ese error.
    Si pudieses restaurar la web con algun backup anterior a la actualizacion que comentas, seria la manera mas rapida de solucionarlo, luego manualmente actualizas cada cosa por separado y compruebas.
    En caso contrario deberas desactivar todo los plugins salvo el WooCommerce y compruebas, luego activa cada plugin uno a uno y compruebas.

    Iniciador del debate atilio85

    (@atilio85)

    Hola @kallookoo restaure todo gracias a una copia de seguridad que tengo en jetpack y por ahora volvio todo a la normalidad, las actualizaciones estaban tildadas con la opcion de forma automatica y por eso se actualizaban solas.

    entonces saque esa opcion de todos los plugins y quedaron en la version de hace 2 semanas incluso la base de datos de woocomerce me volvio a pedir que la actualice.
    la version del wordpress tiene la ultima la 5.7 de ayer y no se por que no se cambio con jetpack pero por ahora no voy a tocar nada.
    en algun momento actualice el wordpress o se actualizo solo la version actual.

    ahora funciona como siempre lo unico no se si debo esperar e ir actualizando primero wordpress plugins tema y base de datos o como hago?

    • Esta respuesta fue modificada hace 9 meses por atilio85.
    kallookoo

    (@kallookoo)

    Hola @atilio85

    En tu caso, diria que seria mejor esperar un poco para que todos los desarrolladores de tus plugins los actualicen, cuando veas una actualizacion comprueba que es compatible con la 5.7, si dentro de un mes por ejemplo sigue igual.
    Copia de seguridad, actualiza un plugin, compruebas que todo esta bien y sigues.
    Si saliese otra actualizacion del propio WordPress esa hazla ya que cuando se lanza una nueva serie, al poco salen correcciones.

    Iniciador del debate atilio85

    (@atilio85)

    ok voy a esperar @kallookoo pero decime como serian el orden de actualizacion por favor que no entendi..
    1 wordpress
    2 base de datos woocomerce
    3 plugins
    4 thema
    es asi el orden?

    Hola @atilio85

    Lo primero antes de actualizar algo que pueda causar problemas es tener una copia de seguridad de la base de datos lo mas reciente posible y de la carpeta wp-content, aunque esto ultimo seria opcional. En muy raras ocasiones en una actualizacion se elimina algun contenido dentro de esa carpeta.
    El orden que yo aplico en las actualizaciones es el siguiente:
    – Theme, en muy pocas ocasiones deja de ser incompatible.
    – Plugins, si alguno como por ejemplo el WooCommerce muestra algun aviso para que realices algo lo haces. Aqui tienes que tener cuidado ya que si por ejemplo tienes varios plugins para actualizarse si seleccionas todos podrias tener problemas, mi regla es si es importante como por ejemplo el WooCommerce, lo actualizo solo y si son sencillos los actualizo todos juntos.
    – WordPress

    Tienes que tener presente que el propio WordPress se actualiza solo cuando son cambios menores, que suelen ser para arreglar algun problema y lo mas seguro es que ni te des cuenta.
    Los plugins y o el theme tambien tienen la opcion de actualizarse automaticamente, y podrias activarlo salvo que no sepas que sea la version que sea del WordPress no sera compatible. Como el WooCommerce es complejo y un fallo podria dejarte sin tienda es mejor hacerlo manualmente.
    Otra cosa que tienes que mirar antes de hacer una actualizacion manual del WordPress es que los plugins que uses sean compatibles, casi todos los problemas suelen ser porque ese motivo, de hay que te comentase que te esperases por dos motivos, el WordPress suele sacar al poco tiempo una actualizacion menor y el otro motivo es que te aseguras que los autores de los plugins tuvieron tiempo para hacer algun cambio si fuese necesario.

    Iniciador del debate atilio85

    (@atilio85)

    Claro entiendo entonces seria:
    el theme, la base de datos (si es que lo requiere), el woocommerce, luego los plugins uno por uno (chequeando la version que sea compatible con la version del wp).

    ahora otra cosa el plugin jetpack yo quise volverlo a otra version y no me dejo y eso que instale la version anterior manualmente pero nunca se bajaba la version eso es normal?

    Hola @atilio85

    Sobre el Jetpack no sabria que decirte.
    Es mejor que inicies una nueva pregunta sobre lo que comentas del Jetpack, ya que se mantiene mas ordenado y facilita que todos encuentren y o ayuden en las preguntas.

    Iniciador del debate atilio85

    (@atilio85)

    si pero jetpack forma parte de los plugins a actualizar por eso te lo pregunto..

    entonces decime el orden @kallookoo por favor, a ver si lo entendi seria:
    primero wordpress el theme, la base de datos (si es que lo requiere), el woocommerce, luego los plugins uno por uno (chequeando la version que sea compatible con la version del wp)??

    Hola @atilio85

    Perdona, pero veo que estas complicando las cosas.
    Actualiza como te sugeri, indenpendientemente del plugin que sea.
    Si por algun motivo algun plugin no puedes actualizarlo, por problemas de recursos y o incompatibilidades deberas asegurarte que tienes desactivada la actualizacion automatica.
    Y ya esta.
    Si quieres usar una version anterior de cualquier plugin, te recomiendo que lo desintales primero para que se borre cualquier informacion de la base de datos, ya que muchos plugins usas la DB para establecer la version que esta instalada y no todos comprueban si la nueva es inferior, lo que se conoce como downgrade y diria que es lo que te sucede con el jetpack, salvo que tengas que se actualice solo y por mucho que lo reisntales manualmente despues volveria a instalarse la ultima.

    Iniciador del debate atilio85

    (@atilio85)

    Hola @kallookoo estoy en proceso, voy con cuidado.. como la version del wp se actualizo sola, hice esto:
    actualice el tema y probe todo marcha bien, ahora pensaba actualizar el woocomerce pero me sale un letrero que dice que los plugins de woocomer etc, (son varios) no han declarado compatibilidad con la version de woocomerce que quiero actualizar, que haga una copia de seguridad y que los revise ante.
    yo los revise y en sus detalles solo dice que son compatibles con la version de wp que tengo y que ha sido probado solo en versiones anteriores pero nunca dice que si es compatible con alguna version del woocomerce. solo hay info del wp.
    que hago pruebo y actualizo solo el woocomerce? yespero mas adelante a ver si alguno de estos plugins se actualizan o no actualizo nada?

    otra pregunta que pasa si actualizo la base de datos se estaria actualizando el plugin de woocomerce tambien?
    por que tengo una cartel que me dice actualizacion obligatoria de la base de datos y que woocomerce se ha actualizado, la actualizo ?

    Hola @atilio85

    Sobre la actualizacion de la DB del WooCommerce es totalmente normal y no deberias tener problemas. Pero como en todo siempre puede suceder algo inesperado.
    Sobre los plugins varios que comentas en teoria deberian funcionar, piensa que mientras el WooCommerce no haga cambios importantes aunque no se actualicen son totalmente funcionales.
    Dependiendo de lo que hagan, obviamente.
    Si quieres asegurarte lo mejor seria ir directamente al foro de cada plugin y preguntar o comentar cuando se actualizaran para la version actual del WooCommerce.

    Iniciador del debate atilio85

    (@atilio85)

    @kallookoo ya he actualizado, el tema de wp y ahora la base de datos y funciona todo bien, me quedaria el woocomerce y luego uno a uno los plugins?
    que haces tu en un caso como el de la imagen?
    posteo

    • Esta respuesta fue modificada hace 8 meses, 1 semana por atilio85.

    Hola @atilio85

    Creo que estamos en un bucle ya que en mas de una ocasion te lo he comentado.

    Para acabarlo, basicamente y por seguridad siempre tener una copia de seguridad. Luego actualizar, probar que todo funciona bien y fin.

    Saludos

    Iniciador del debate atilio85

    (@atilio85)

    ok muchas gracias por tu tiempo @kallookoo

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • El debate ‘Tienda de woocomerce’ está cerrado a nuevas respuestas.