Soporte » Plugins y Hacks » BuddyPress » Traducción no funciona

  • Resuelto DiammondRaptor

    (@diammondraptor)


    Hola, estoy teniendo muchos problemas con la traduccion de buddypress ya que lo he probado todo y no se traduce nada

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Rocio Valdivia

    (@_dorsvenabili)

    Hola DiammondRaptor,

    para que podamos ayudarte mejor, podrías decirnos tu versión de WP y BP que estás usando?

    Y también, para que no te repitamos lo que has probado, podrías decirnos, qué es lo que has probado y no te ha funcionado?

    Muchas gracias!

    Iniciador del debate DiammondRaptor

    (@diammondraptor)

    Hola estoy usando wp 4.0 y BP 2.1.1

    He probado a colocar los .po y .mo en diferentes lugares y luego traducirlos yo mismo y repetir los procesos pero nada sigue sin funcionar si quieres te puedo enviar la cuenta de administrador de mi web para que lo mires tu misma

    Rocio Valdivia

    (@_dorsvenabili)

    Hola DiammondRaptor,

    prueba a poner tus archivos de traducción .mo y .po en esta ruta y con esos nombres:

    /wp-content/languages/plugins/buddypress-es_ES.mo
    /wp-content/languages/plugins/buddypress-es_ES.po

    Si eso te sigue sin funcionar, prueba a abrir el .po con Poedit y pulsa en «Verificar» para ver si la traducción tiene algún error.

    El problema de este tipo de archivos es que si tiene un sólo error en una cadena (una etiqueta sin cerrar, etc.), no se carga nada de la traducción.

    Así que en ese caso, prueba a exportar la traducción oficial de polyglots de aquí (al final de la página puedes exportar el .po y el .mo) y prueba si estos van en tu instalación:

    https://translate.wordpress.org/projects/buddypress/dev/es/default

    Cuéntanos si lo solucionas 😉

    Iniciador del debate DiammondRaptor

    (@diammondraptor)

    Hola, siento decirte que todo eso ya lo he hecho i me sigue saliendo parcialmente en castellano

    Rocio Valdivia

    (@_dorsvenabili)

    Ahhhhh se traduce parcialmente? habías dicho en tu primer mensaje que no se traducía nada.

    Si te aparecen cadenas traducidas y otras no, es simplemente porque el .mo tiene esas cadenas sin traducir.

    Si te fijas, ahora mismo, la traducción de BP está al 86%, así que sería genial, si te animas a ayudar a traducir las que quedan en polyglots 😉

    https://translate.wordpress.org/projects/buddypress/dev

    Iniciador del debate DiammondRaptor

    (@diammondraptor)

    Como ya te he dicho anteriormente he traducido el castellano al 100 % personalmente pero sigue me sigue saliendo las traducciones parciales

    Moderador Mariano Perez

    (@mpcdigital)

    Cómo has hecho la traducción?

    Iniciador del debate DiammondRaptor

    (@diammondraptor)

    con PoEdit

    Moderador Mariano Perez

    (@mpcdigital)

    Y después has generado el .mo correspondiente?

    Iniciador del debate DiammondRaptor

    (@diammondraptor)

    Hola, muchas gracias por todo, un compañero de bp me ha pasado un tutorial de com hacerlo y funciona, gracias de todos modos 🙂

    marianoqueirel

    (@marianoqueirel)

    Bueno entonces podrías compartirlo..

    Hola estoy teniendo exactamente el mismo problema que tu DiammondRaptor ¿Podrias compartir el tutorial por favor?

    Bueno, por si os sirve a alquien que le pase igual, y ante la inutilidad de los tutoriales que encontré yo en google para traducir bpress cuando hay problemas… volví a traducir las cadenas que me daban problemas con el Poedit, pese a que no daban error, ni estaban fuzzy ni nada, pero bueno que al volverlas a editar ya funcionó. 120 strings de nada jeje

    DiammondRaptor serias tan amable de indicarnos cual fue la solución que aplicaste? porque yo por más que le doy mas vueltas la palabra Groups no hay Dios que la traduzca usando las últimas versiones.

    Por favor alguien que me pueda indicar como proceder?

    Hola Rocio. He estado un buen rato traduciendo la versión 2.1, por hoy lo dejo. Por otro lado es la primera vez que traduzco, si puedes decirme si esta bien lo agradezco.

    Si alguien se anima a continuar aquí esta el enlace:

    https://translate.wordpress.org/projects/buddypress/2.1.x/es/default

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • El debate ‘Traducción no funciona’ está cerrado a nuevas respuestas.