Soporte » Guías – Resolución de problemas » URL DE ENLACE DE IMAGENES ERRONEO

  • Resuelto Tito Whisky

    (@titowhisky)


    Hola. Gracias al log de errores 404 hemos detectado que en sitemaps de imagenes aparecen rl de enlances de los archivos multimedias que son invalidas. Suponemos que esto se genero en la migración desde wp.com a wp.org, dado que tiene seteado por default NONE, pero estas imágenes tienen una url que es http://www.titowhisky.com/file (file nombre del archivo), la url de la imagen es correcta y en todos los post esta bien. Ahora bien no hay forma de modificar manualmente ya que no es un dato accesible desde el editor de imágenes, sino que se asigna al cargar y nunca mas se puede modificar. La única solución que encontré es borrar todas las imágenes y volver a cargarlas, cosa que me parece una locura. Por lo que consulto : este dato se guarda en alguna tabla de modo de poder hacer un update y vaciar ese campo ya que no tiene utilidad? O algún plug-in que hace este borrado? o donde se almacena el dato sino es en una tabla en un archivo o en la metadata en el archivo de la imagen? La verdad qu me he encontrado con muchos problemas durante la migración, y algunos los he detectado luego de un mes porque me puse a ver en profundidad las tablas. Muchos enlaces no se cambian y hay que hacerlo con busquedas y remplazos con el riesgo de romper algo. Podrían tener algo mas automatizado o por lo menos que avise si quedan cosas pendientes, por ejemplo en los post las imagenes quedaron direccionando a wp.com y tengo que cambiar ahora mas de 500 url para que apunten al repositorio de wp.org esto podría ser automático. Espero que alguien me de una mano con lo de las imagenes dado que Google Console Search esta registrando mas de 500 errores 404 cada vez que verifica el sitio y eso nos va a impactar negativamente.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Moderador almendron

    (@almendron)

    Antes de hacer nada, yo desactivaría el módulo Photon de JetPack. Así podremos ver la ruta real de la imagen y ver cuál es el problema.

    Iniciador del debate Tito Whisky

    (@titowhisky)

    El problema es que las imagenes en los datos adjuntos tienen como enlace a una pagina https://titowhisky.com/20170713_102402/ donde 20170713_102402 es el nombre del archivo jpg, la url de la imagen es correcta : https://titowhisky.com/wp-content/uploads/2020/12/20170713_102402-scaled.jpg. Entonces JPack cuando genera el xml sitemas de imagenes coloca las dos url y google csearch console da errores 404 por la de enlace a la pagina : https://titowhisky.com/20170713_102402/ ya que no existe. Ese es el problema.

    Moderador almendron

    (@almendron)

    He intentado acceder al sitemap de tu sitio pero me da un error.

    • Esta respuesta fue modificada hace 1 semana, 5 días por almendron.
    Iniciador del debate Tito Whisky

    (@titowhisky)

    ¿Que es lo que necesitas del sitemap? el problema son las imágenes no el sitemap eso esta bien generado por jetpack con la información que tienen las imágenes, el problema es que las imágenes tienen información erronea no se si ya estaba mal en wp.com o es por algo que en la migración agrego ese link. Lo que necesito es como borro ese link de las imagenes si es que lo guarda en la metadata propia de las imágenes o en algún otro lugar, obviamente cuando JP arma el sitemap esos link los rescata de algún sitio junto al link del repositorio de la imagen. Te comparto una imagen del sitemap de imagenes (no el de link de las paginas y entradas del sitio) donde se ven claramente las dos url. https://drive.google.com/file/d/167lKHDSNioRYDMoBHOlz4m1vUKVW5RYr/view?usp=sharing

    • Esta respuesta fue modificada hace 1 semana, 5 días por Tito Whisky.
    Moderador almendron

    (@almendron)

    Quería ver el tipo de URL,s que crea Jetpack en el sitemap.

    Es que no entiendo de donde salen esas URL,s ni por qué las añade al sitemap.

    Las imágenes se guardan como un post del tipo attachment en la tabla «post». Y luego otra información, como la imagen destacada, en la tabla «postmeta». Ninguna de esta información debe eliminarse.

    Yo creo que el error proviene de la migración de y del sitemap de JetPack. Yo probaría a usar el que trae por defecto WordPress: https://titowhisky.com/wp-sitemap.xml o el de Yoast (que veo que lo tienes ahora activado).

    Iniciador del debate Tito Whisky

    (@titowhisky)

    Aca tenes una explicación de donde sale ese link.
    https://ayudawp.com/quitar-o-cambiar-el-enlace-por-defecto-de-las-imagenes/#:~:text=En%20la%20parte%20derecha%20del,deber%C3%ADas%20fijarte%20siempre%20en%20esto
    como dice ahí cuando cargas una imagen en Detalles del adjunto hay un campo que es Datos del Enlace que por default te coloca lo que este seteado en una opoción oculta que se puede ver con tusitio.com/wp-admin/options.php y es el campo image_default_link y se pueden asignar estos valores :
    file: enlace al archivo multimedia, a la imagen completa.
    post: enlace a la entrada dónde está la imagen insertada.
    attachment: enlace a la página de adjunto que crea WordPress.
    none (o dejarlo vacío): para que por defecto las imágenes no enlacen a nada.

    en mi caso verifique en wp.con y dice none con lo cual ese enlace debería estar vacío, pero tiene una url como si el valor del default es «file» como esta opción no la modificamos entonces es de suponer que o estaba mal en wp.com (y nunca nos enteramos, porque no teníamos manera de ver los errores 404 que daría el google search) así que supongo que al migrar las imágenes algo funciono mal y asumió que el default era file.
    El punto es JP arma el sitemaps de imágenes y las incorpora porque hay una url de enlace y eso nos esta llenando de 404 por google search y además nos van a terminar penalizando por muchos 404. por eso me urge borrar esas url que por lo que léi no sirven para nada. Busque en las tablas y no encontré el dato, sino lo que se me ocurre es que el JetPack si las imágenes no tienen esa url la invente. Pero me pare una locura. Gracias por el interés en ayudarme.

    Moderador almendron

    (@almendron)

    En principio, eso que me explicas no tiene nada que ver. En este post, Fernando lo que explica es como cambiar a qué enlazará por defecto una imagen cuando la insertas en una entrada. No tiene nada que ver con tu problema.

    Vamos a comprobar lo siguiente:

    1) Ve a Biblioteca de medios y en la primera imagen que aparezca le das clic a «Editar». En la página que se abre podrás ver el campo «Enlace permanente». Toma nota de ello.

    2) Ve a la entrada donde está esa imagen. Ve cambiando el campo de enlazar a «Archivos de medios» y «Página de adjuntos». Toma nota de las dos URL,s.

    Y luego me las pones aquí.

    Iniciador del debate Tito Whisky

    (@titowhisky)

    1. https://titowhisky.com/2021/04/30/single-cask-single-barrel/diagrama-single-cask/#main , el link de la imagen : https://titowhisky.com/wp-content/uploads/2021/04/Diagrama-single-cask.jpg , en este caso en la biblioteca multimedia deja modificar la ultima parte del link, el cual se accede sin problema desde el navegador.

    2. LA entrada es https://titowhisky.com/2021/04/30/single-cask-single-barrel/ y es la última foto como imagen, voy a imagen y el link que veo en html no muestra otro linkes .
    Archivo (no dice archivos de medios) :https://titowhisky.com/wp-content/uploads/2021/04/Diagrama-single-cask-1024×1024.jpg
    Pagina de adjuntos no lo encuentro.

    Lo de los sitemaps no te entendí. Por lo que veo los sitemaps que esta tomando google son los que genera JetPack, por un lado quiero forzar que los vuelva a crear pero no se como, y sino malinterpresto lo que vos me decís es que cambie en google el de JetPack por el YSEO, pero corregime si me equivoco en la barra lateral del WP estoy seguro de haber visto una opción para configurar Yseo pero ahora no esta y desde ahí se podía administrar el sitemaps. Como restauro esa opción del YSEO.
    Gracias por la ayuda

    Moderador almendron

    (@almendron)

    Ahora mismo tienes activado el sitemap de YoastSEO : https://titowhisky.com/sitemap_index.xml

    En dicho sitemap creo que ya no aparecen las URL,s que daban el error. Compruebalo.

    Aismismo debes comprobar que has desactivado el sitemqap que genera JetPack. Para ello, ve a https://titowhisky.com/wp-admin/admin.php?page=jetpack_modules
    Lo deberías tener desactivado.

    Por último, entra en tu cuenta de Google y vuelve a enviar el sitemap ( https://titowhisky.com/sitemap_index.xml )

    Iniciador del debate Tito Whisky

    (@titowhisky)

    Muchas gracias, excelente el link para los modulos de JP, entradas escondidas, lo del sitemap luego lo modifico y te cuento. Gracias-

    Iniciador del debate Tito Whisky

    (@titowhisky)

    Hola Almendron. Te cuento active el sitemaps de YoastSeo y desactive el de Jet Pack y deje en google console solo el html de Yoast y ya no aparecen mas esos errores ya que le configure al YoastSeo que los enlaces de enganche de las imágenes sean el repositorio. Solo le tuve que desactivar la creación del sitemap par las e-landing ya que no tengo ninguna creada y daba error en la consola de google por estar el html vacio. Por lo que pude revisar esta todo bien generado. Pero he visto que aparecen desde otros buscadores por ejemplo bing accesos a link viejos que podian estar en sitemap de JetPack. TSupongo que en la consola de Bing también esta el sitemap de Jet Pack, lo mismo que en Yandex. Después lo voy a revisar, pero desde ya muchas gracias por la ayuda.

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

    Iniciador del debate Tito Whisky

    (@titowhisky)

    Cabe mencionar que luego de un tiempo el soporte de Jet Pack me contesto indicando que el problema con los link es de WP.org y que recomienda o que use el sitemap de Yoast o el de ello. La verdad que no sabia que ambos generaban sitemap y que además son diferentes.
    El de Yoast me parece mas confiable y ademas se puede seleccionar que queremos que se indexe (post, paginas, artículos, landpages, ect..) y como mencione tienen una opción para salvar el problema con las imágenes de forzar en ese enlace la url del contendedor de la imagen. Puse los diferentes sitemap en Google, Bing y Yandex y todos dieron sin error. Así que si tienen JP y Yoast utilicen los sitemap de Yoast.

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Debes estar registrado para responder a este debate.