Soporte » Plugins y Hacks » Visibilidad de dispositivos en elementor

  • Hola,

    Soy nuevo por aquí, estoy creando mi primera web con elementor y nunca me hubiera imaginado que fuera tan fácil crear una web sencilla sin usar programación.

    Mi pregunta viene porque no sé si a alguien le ha ocurrido algo parecido a lo mio y me podría ayudar. Les comento:

    He creado 4 headers (un header de home para escritorio, otro header de home para tablet, otro header de home para móvil y otro para las demás páginas)
    En el header para la home quise que el fondo tuviera una diapositiva de imágenes tanto para la versión escritorio, como la de tablet y móvil. Por lo cual realicé 3 headers diferentes para que cada uno tuviera un tamaño de imagen diferente y que se fijara a cada dispositivo correctamente. Según mi lógica lo que hice fue que cada header se mostrara o no en según el dispositivo, es decir en escritorio por ejemplo oculté tablet y móvil, y así sucesivamente. Y aquí viene el problema que no sé que ocurre pero el header del móvil me bloquea el header de escritorio y el de tablet. Y el de tablet me bloquea el de escritorio.

    No sé que si me he pasado algo por alto, pero si alguien le ha ocurrido lo mismo y puede ayudar, se lo agradecería.

    Muchas gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Hasta 1024px tienes header con un fondo, para tamaños menores no tienes nada definido, y en el código cambia correctamente:

    data-elementor-device-mode="desktop"
    data-elementor-device-mode="tablet"
    data-elementor-device-mode="mobile"

    Revisa los errores que tiene la página, unos hacen referencia a youtube, otros a contenido servido como http (cntenido mixto), es posible que el problema sea ese, que no puedo mostrar el contenido porque el navegador lo esté bloqueando.

    La combinación Astra – Elementor PRO da problemas (aunque te la recomienden) justamente cuando usas Elementor PRO para maquetar los menús, headers y footer que trae Astra. Lamentablemente con eso no podemos ayudarte porque Elementor PRO es un producto comercial, si estás usando un plugin comercial y necesitas soporte debes ir a su canal de soporte oficial. Para dar el mejor servicio a la comunidad WordPress, y generar progreso e innovación, creemos que es importante dirigir a la gente a los sitios oficiales, en este caso el soporte de Elementor Pro:

    How Can We Help You Today?

    Además, los voluntarios del foro no tenemos acceso a productos comerciales, así que no sabríamos porque tu tema comercial no funciona adecuadamente. Y hay otra razón por la que los voluntarios te dirigimos a los vendedores del producto comercial: los vendedores son responsables de dar soporte a su producto comercial.

    Se podría resumir en que en los foros de WordPress.org podemos dar soporte a todo aquello que se pueda instalar o descargar desde WordPress.org.

    Hola Jose Luis,

    No tenía activas las cabeceras de tablet y móvil por eso se veía correctamente en escritorio. Ahora tengo activas tanto la de tablet y móvil y solamente se ve correctamente en móvil dejando de funcionar en escritorio. Y claro el código que me pasas está correctamente, es por eso que no doy con el problema.

    Con respecto a lo que me dices sobre los errores que hacen referencia a youtube y a contenido mixto, a que te refieres, disculpa pero soy bastante novato con esto.

    Y gracias por pasarme el link del soporte de Elementor, he contactado con ellos a ver si me dicen algo.

    Muchísimas gracias por tu ayuda y tu tiempo.

    Moderador Jose Luis

    (@jose64)

    Me parece que no estás manejando la parte responsive correctamente, te dejo enlace a la documentación:

    Mobile Editing

    Introducing Mobile Editing: The Only Way to Create Truly Responsive Sites

    Los errores de contenido mixto son los que hacen que no te aparezca el candado cerrado al lado de la url en el navegador, revisa estos debates que contienen las instrucciones para solucionarlo:

    Problema de contenido Mixto paginas no seguras

    No carga https

    volcanolaagencia

    (@volcanolaagencia)

    Muchas gracias por su respuesta, voy a ponerme a ello a ver si doy con la solución.

    volcanolaagencia

    (@volcanolaagencia)

    Al final he seguido las instrucciones que me indicaste y he conseguido arreglar el problema del contenido mixto y que todas las páginas sean https. Pero el error que tenia parece que no es debido a eso y he contactado con Elementor sin una respuesta clara.

    Seguiré buscando la manera de poder solucionar lo de las cabeceras en los distintos formatos. Muchas gracias por su ayuda.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.