Soporte » Guías – Resolución de problemas » WooCommerce Gateway PayPal Express Checkout requires OpenSSL >= 1.0.1 to be inst

  • Hola
    migrado la web de alojamiento y me a aparecido este aviso «WooCommerce Gateway PayPal Express Checkout requires OpenSSL >= 1.0.1 to be inst» e contactado con el proveedor y dice «en el servidor tiene la 1.0.1 y si no lo detecta su web, no podemos saber el motivo»
    e estado buscando información y no saco nada en claro (estoy demasiado verde para encontrar una solución)
    Por favor si podeis decir alguna solución lo agradecería mucho

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Buenas,
    En que proveedor estás? la verdad es que la respuesta que te han dado es un tanto fea.

    Bien, en este hilo en inglés están comentado varias soluciones:
    https://wordpress.org/support/topic/requires-openssl-101-to-be-installed-on-your-server-1and1-shared-hosting/

    de ahí lo primero sería saber si aunque tengas openssl>=1.0.1 el curl no puede acceder a el..

    en stackoverflow http://stackoverflow.com/questions/27904854/verify-if-curl-is-using-tls
    nos da este código:

    <?php    
    $curl_info = curl_version();
    echo $curl_info['ssl_version'];

    Debes crear un archivo nuevo y subirlo a alguna carpeta de tu servidor. Luego entra en la url:
    tuserver.com/tucarpeta/nomberquelehaspuestoalarchivo.php

    y comprueba que salga

    OpenSSL/1.0.1k

    si no es así pues dale toque de atención a tu proveedor y dile «cortesmente» que sí podría mirarte eso de que tienes openssl pero que no puedes acceder a el.

    En caso que no sea esto.. pues es necesario seguir mirando.

    Un saludo

    algún progreso?

    • Esta respuesta fue modificada hace 3 años, 8 meses por oldlastman.

    Hola
    Muchisimas gracias por contestar,no lo esperaba (por eso e tardado en contestar)no ,no hay progreso…
    y si lo desinstalo,borro el caché y lo instalo otra vez?
    lo digo porque lo instale también en otro servidor y en local de la misma forma que esta instalado donde me aparecio el aviso (con el plugins Duplicator) y en loas otras instalaciones no e tenido problema y donde me a aparecido el aviso es en la instalación oficial..

    Hola,
    Pero has hecho los test que te he sugerido? Qué te ha salido
    Es muy probable que sea un problema de una mala configuración de hosting

    Un saludo

    Hola
    e hecho las test,e contactado con el proveedor ya comunicando el problema mas preciso (sobre la configuracion del hosting) y a respondido

    Le comunicamos que la versión de openssl actual en el servidor es la 0.9.8. Podemos realizar una migración a un servidor con multiversión php ya que en estos servidores sí tiene la versión 1.0.1 requerida.

    le dicho que procedan a realizarlo,ya te comento si se a solucionado o no

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • El debate ‘WooCommerce Gateway PayPal Express Checkout requires OpenSSL >= 1.0.1 to be inst’ está cerrado a nuevas respuestas.