Soporte » Temas y plantillas » WordPress 4.7.5 + Theme directoryengine child + woocommerce 3.0 , Error

  • germoarg

    (@germoarg)


    Hola, me contacto con ustedes porque estoy teniendo el siguiente problema.

    estoy corriendo WordPress 4.7.5 + Theme directoryengine child + woocommerce 3.0, sobre un servidor con PHP 7

    Me sale el siguiente error y no encuentro la forma de solucionar este problema.

    [23-May-2017 15:49:23 UTC] PHP Warning: Declaration of ET_WC_Order::get_total() should be compatible with WC_Abstract_Order::get_total($context = ‘view’) in /home/tuguiade/public_html/wp-content/themes/directoryengine/includes/aecore/wc_integration/payment/ET_WC_Order.php on line 2

    [23-May-2017 15:49:23 UTC] PHP Warning: Declaration of ET_WC_Package::get_sku() should be compatible with WC_Product::get_sku($context = ‘view’) in /home/tuguiade/public_html/wp-content/themes/directoryengine/includes/aecore/wc_integration/payment/ET_WC_Package.php on line 3

    Adicionalmente estoy tratando de correr un plugin de Mercadopago oficial y al seleccionar el medio de pago, se queda pensando y por consola arroja, Failed to load resource: the server responded with a status of 500 (Internal Server Error), en el log de WP me indica los 2 errores anteriormente mencionados.

    Podrían orientarme como solucionar este problema

    Muchas Gracias

    Germán

    • Este debate fue modificado hace 4 meses por  germoarg.
Viendo 2 respuestas - 1 de 2 (de 2 total)
  • Moderador almendron

    (@almendron)

    Los dos primeros errores están localizados en archivos del tema que usas. Dado que es de pago, poco podemos ayudarte ya que no tenemos acceso a dicho tema.
    Tendrás que ponerte en contacto con el soporte correspondiente para ver si pueden corregir ambos fallos.

    En cuanto al tercero, yo esperaría a que se resolvieran los anteriores problemas y mientras tanto lo desactivaría o probaría a instalar otro que cumpla la misma función.

    Moderador Jose Conti

    (@jconti)

    Hola,

    Son warnings, no errores. Es normal que se encuentren estas cosas cuando el desarrollo no se hace para dos versiones de WooCommerce.

    Te va a funcionar sin problemas, no te preocupes. Lo que si que seguramente en un futuro, el theme será actualizado solo para Woo 3.0 y ya no te saldrá. De momento te va a funcionar sin problemas, y seguramente hasta Woo 3.2 (si es que sale esta versión con este nombre)

    • Esta respuesta fue modificada hace 3 meses, 4 semanas por  Jose Conti.
Viendo 2 respuestas - 1 de 2 (de 2 total)
  • Debes estar registrado para responder a este tema.