Respuestas de foro creadas

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Iniciador del debate Isa Gomez

    (@asi1985)

    Hola de nuevo Kallokoo, finalmente ha quedado resuelto el problema.
    Te comento cómo lo he solventado por si alguna persona que lea el foro a posteriori le pueda interesar.
    He puesto el idioma de WordPress en Alemán y he cambiado el idioma de mi usuario para poder ver el dashboard en mi idioma.
    Para cambiar el idioma del usuario he ido a => Usuarios // Mi Perfil y ahí he indicado Castellano.

    Ahora los emails se envía correctamente y yo puedo ver el Dashboard en mi idioma así que ha quedado solventado 😉

    Muchas gracias por la atención y la ayuda!!
    Un saludo.
    Isa.

    Iniciador del debate Isa Gomez

    (@asi1985)

    Hola Kallookoo, efectivamente tengo X sitios por X idiomas y cada uno de esos sitios tiene un Woocommerce instalado.

    Los templates del resto de los sitios se envían sin problemas. En cada sitio tengo Loco translate y he creado la traducción para el idioma en concreto y todo funciona bien excepto en el sitio en Alemán que genera correctamente el email de procesando pero no el de completado, ya que envía este último en inglés y no en Alemán (aún teniendo una traducción para ese template.)

    Únicamente envía el email correctamente si cambio el idioma del WordPress a Alemán pero esto no es lo que voy buscando ya que la interfaz en alemán es un poquito difícil de entender :D. ¿Sabes si este error es normal o es que no estoy configurando algún apartado correctamente? Cualquier aportación es bienvenida 😉
    Muchas gracias,
    Isa.

    Iniciador del debate Isa Gomez

    (@asi1985)

    Ahora sí 😉
    Gracias!

    Iniciador del debate Isa Gomez

    (@asi1985)

    Muchas gracias @adriandegrafreak, he reducido el peso de la imagen y la ha recogido.

    Solucionado!!
    Muchas gracias,
    Isa.

    Hola Sergio, ¿Has probado a desactivar uno a uno aquellos plugin que actualizaste e ir viendo si funciona el maquetador visual?
    La idea es ir descartando qué plugin está provocando el conflicto y a partir de ahí ver por qué no te permite trabajar con el maquetador visual.
    Por otro lado, ¿Qué maquetador visual estás utilizando?
    Un saludo.
    Isa.

    Hola!
    ¿podrías poner la URL de la web para poder echar un vistazo?
    Muchas gracias.
    Isa.

    Perfecto @salcedo!
    Ya nos comentarás que solución te ofrecen desde el hosting.
    Un saludo!
    Isa.

    Genial @bigdatadestroy! Me alegro que te haya resultado de utilidad aunque siento lo de las comillas. @lgrusin lo tengo en cuenta para la próxima 😉
    Gracias a ambos.
    Un saludo.
    Isa.

    Hola Salcedo!

    El hecho de que tengas una web en construcción (coming soon) no es el motivo para que el navegador te esté mostrando una conexión insegura a tu web.

    Puede ser que el certificado SSL no esté instalado correctamente o puede ser que el error lo esté generando Chrome con la conexión no es «privada».

    Yo hablaría directamente con el proveedor de hosting porque puede ser que no tengas correctamente instalado el certificdo SSL (Let´s encrypt) y por eso te está mostrando una conexión insegura a algunas partes de tu web.
    En la mayoría de los casos este problema lo resuelven desde el propio hosting por eso mi recomendación inicial es hablar con ellos y pedirles que instalen o revisen let´s encrypt.
    Si desde el hosting no te ofrecen ninguna respuesta otra opción es intalar este plugin en tu web.
    Espero que esto resuelva tu problema.
    Un saludo.
    Isa.

    Iniciador del debate Isa Gomez

    (@asi1985)

    Hola Fernando, ha quedado solucionado!!!
    Era un conflicto que existía entre unas clases que utiliza Bootstrap en los archivos:

    /checkout/form-checkout.php
    /my-account/form-login.php
    /order/order-details-customer.php

    La clase que estaba provocando el conflicto era ‘.col-1’
    Para solucionarlo simplemente he copiado la carpeta /checkout/ de Woocommerce en el tema y he remplazado lo siguiente:

    <div class="col-1">
    <?php do_action( 'woocommerce_checkout_billing' ); ?>
    </div>

    Reemplazado por:

    <div class="col-2">
    <?php do_action( 'woocommerce_checkout_billing' ); ?>
    </div>

    Ahora funciona sin problema en móvil.
    Mil gracias por la ayuda!
    Un abrazo,
    Isa.

    • Esta respuesta fue modificada hace 5 años, 1 mes por Fernando Tellado. Razón: Etiquetado correcto del código
    Iniciador del debate Isa Gomez

    (@asi1985)

    Hola Fernando, muchas gracias por tu respuesta porque me ha ayudado a avanzar un poco y empezar a descartar.

    Efectivamente parece que el problema viene del tema, y concretamente si desactivo del archivo functions.php para que no cargar los estilos de Bootstrap funciona correctamente.

    ‘wp_enqueue_style(
    ‘bootstrap-style’,
    get_stylesheet_directory_uri() . ‘/css/bootstrap.min.css’
    );’

    El problema es que necesito que utilice la librería de bootstrap ya que este tema tiene un diseño personalizado para la ficha de producto en la categoría personalizador, y necesita los estilos de bootstrap para funcionar correctamente.

    https://byobcreatubolso.com/producto/sario-frugal/

    ¿Alguna idea de como puedo solventar este conflicto entre Booststrap y Woocomerce?
    Muchas Gracias! 😉
    Isa.

    Hola Bigdatadestroy, si necesitas añadir un texto justo al lado de tu precio en Woocommerce puedes hacerlo añadiendo el siguiente código a tu archivo functions.php
    ¡Recuerda realizar una copia de seguridad de este archivo antes de cualquier modificación!

    El código que debes añadir es el siguiente:

    function custom_price_message( $price ) { 
        global $post;
        $product_id = $post->ID;
        $textafter = ' Desde'; //texto que vamos agregar
        return $price . '<span class="textafter">' . $textafter . '</span>'; //class textafter para el CSS
    }
    add_filter( 'woocommerce_get_price_html', 'custom_price_message' );

    Y añadirá el texto justo después de tu precio.
    Espero que te ayude en el problema.
    Un saludo.
    Isa.

    • Esta respuesta fue modificada hace 2 años, 6 meses por Fernando Tellado. Razón: Etiquetado correcto del código
    Foro: WooCommerce
    En respuesta a: variaciones masivas
    Iniciador del debate Isa Gomez

    (@asi1985)

    Hola Pablo, genial esta era la duda que tenía si existiría algún plugin para poder modificar masivamente desde WordPress sin tener que obligar al cliente a tener que subir .csv

    Muchas gracias!
    Un saludo.
    Isa.

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)