Respuestas de foro creadas

Viendo 15 respuestas - de la 16 a la 30 (de un total de 34)
  • Iniciador del debate ethink1

    (@ethink1)

    Jose´, lo siento pero me devuelve el mismo mensaje… se ve que hay algo que no está bien 🙁
    Esto es lo que estoy poniendo:

    
    add_filter( 'woocommerce_quantity_input_args', 'jk_woocommerce_quantity_input_args', 10, 2 ); // Simple products
    
    function jk_woocommerce_quantity_input_args( $args, $product ) {
        // Obten las categorías del producto
        $product_terms=get_the_term( $product->ID, 'product_cat' );
        // Comprueba si el producto está en esa categoría
        // IMPORTANTE: CAMBIA EL NOMBRE DE LA CATEGORÍA POR EL NOMBRE REAL
        if ( is_singular( 'product' ) && in_array( 'itinerarios-permanentes', $product_terms ) {
            $args['input_value']    = 5;    // Starting value (we only want to affect product pages, not cart)
    
        }
        $args['max_value']  = 80;   // Maximum value
        $args['min_value']  = 5;    // Minimum value
        $args['step']       = 1;    // Quantity steps
        return $args;
    }
    
    add_filter( 'woocommerce_available_variation', 'jk_woocommerce_available_variation' ); // Variations
    
    function jk_woocommerce_available_variation( $args ) {
        $args['max_qty'] = 80;      // Maximum value (variations)
        $args['min_qty'] = 5;       // Minimum value (variations)
        return $args;
    }
    • Esta respuesta fue modificada hace 1 año, 9 meses por josearcos.
    Iniciador del debate ethink1

    (@ethink1)

    Hola José,
    En primer lugar darte gracias por la respuesta. Al añadir este código la página se vuelve en blanco y sale el mensaje «El sitio está experimentando dificultades técnicas.»

    Donde me indicas el nombre de la categoría he puesto uno de los míos, solo he cambiado eso, no sé que puede ser lo que esté dando error. Ojalá puedas corregirlo.
    Muchísimas gracias.

    Iniciador del debate ethink1

    (@ethink1)

    Esta última me ha funcionado Almendrón.
    Muchísimas gracias por tu ayuda. Has sido muy amable!

    Iniciador del debate ethink1

    (@ethink1)

    Hola almendron,
    No tengo conocimientos avanzados en código para resolverlo… es una página que no he hecho yo… El código completo que tengo es este:

    <div id=»caja_info»><p>Variedad <?php foreach((get_the_category()) as $childcat) { if (cat_is_ancestor_of(3, $childcat)) { echo $childcat->cat_name ; }} ?></p></div>

    Tu me estás indicando códigos para poner en otras páginas de php, ¿cierto?
    A ver si me puedes decir como podría hacerlo. siento mi torpeza…

    Iniciador del debate ethink1

    (@ethink1)

    Muchas gracias LGrusin pero siento decir que no me funciona 🙁

    Iniciador del debate ethink1

    (@ethink1)

    Hola José,
    No me ha funcionado 🙁
    ¿Alguna idea para quitarlo? He mirado en las plantillas de los emails (woocommerce / templates / emails) y borrado la acción

    do_action( ‘woocommerce_email_customer_details’, $order, $sent_to_admin, $plain_text, $email );

    pero tampoco ha servido…
    A ver si alguien me puede ayudar, muchas gracias.

    Iniciador del debate ethink1

    (@ethink1)

    Buenas tardes Jose,
    Muchas gracias por la respuesta, he utilizado la primera porque no tengo conocimientos para elaborar la función con condicionales, he pegado eso pero algo me debe faltar para que pueda funcionar…
    Por otra parte, he utilizado el hook woocommerce_after_shop_loop. Tengo la tienda con 3 columnas, pero al tener dos productos me sale el boton en la tercera columna en lugar de ir debajo. Si pongo el siguiente hook woocommerce_after_main_content directamente me desaparece el botón.
    ¿Hay alguna forma de ponerlo justo debajo del bloque de productos aunque hayan dos en esa fila en lugar de tres?
    Muchísimas gracias por tu ayuda. Un saludo.

    Iniciador del debate ethink1

    (@ethink1)

    Hola LGrusin, gracias por la respuesta.
    No necesito cambiar las cadenas, porque las que genera de forma automática están bien. Lo que quiero es añadirle al botón el idioma para que me vaya a ese idioma concreto. Si entro en la web en inglés, me pone ese mismo botón por defecto, y me lleva a una página en español, no en inglés…
    No se si me explico. Gracias de antemano.

    Foro: WooCommerce
    En respuesta a: Generación de miniaturas
    Iniciador del debate ethink1

    (@ethink1)

    Muchas gracias Almendron, en functions.php del tema, encontré esto:

    //define thumbnail sizes
    add_image_size( ‘portfolio-square’, 550, 550, true );
    add_image_size( ‘portfolio-landscape’, 800, 600, true );
    add_image_size( ‘portfolio-portrait’, 600, 800, true );
    add_image_size( ‘portfolio-default’, 550, 498, true ); // and for blog masonry and latest post boxes type
    add_image_size( ‘menu-featured-post’, 345, 198, true );
    add_image_size( ‘qode-carousel_slider’, 400, 260, true );
    add_image_size( ‘portfolio_slider’, 480, 434, true );
    add_image_size( ‘portfolio_masonry_regular’, 500, 500, true );
    add_image_size( ‘portfolio_masonry_wide’, 1000, 500, true );
    add_image_size( ‘portfolio_masonry_tall’, 500, 1000, true );
    add_image_size( ‘portfolio_masonry_large’, 1000, 1000, true );
    add_image_size( ‘portfolio_masonry_with_space’, 700);
    add_image_size( ‘latest_post_small_image’, 125, 112, true );
    add_image_size( ‘blog_image_in_grid’, 1100);

    Teniendo en cuenta que no estoy usando el portfolio ni el carousel, ¿crees que puedo prescindir de estas miniaturas sin problema? Realmente solo necesitaría las que genera el woocommerce y poco más.

    Para cambiar a https esas dos imagenes que me dices, ¿cómo tengo que hacer?

    Probaré a bajar las imágenes del slider también. Estoy bajando de peso todas las demás para optimizar todo lo que pueda la web.

    Muchas gracias por tu ayuda.

    Iniciador del debate ethink1

    (@ethink1)

    Buenas tardes Fernando,
    En otro ordenador me funciona, creo que puede ser tema de caché…
    He borrado la caché de navegación y me funciona pero en cuanto me pongo a hacer algo, me deja de funcionar… ¿crees que para los clientes no habrá problema y es solo cosa mía que estoy en el back haciendo cosas?
    Muchas gracias por haberle echado un vistazo. Un saludo.

    Foro: WooCommerce
    En respuesta a: Recogida en local
    Iniciador del debate ethink1

    (@ethink1)

    Muchísimas gracias Fernando, lo tenía como una nueva zona de envío. ¡Solucionado!

    Iniciador del debate ethink1

    (@ethink1)

    Hola LGrusin, gracias por contestar.

    Lo que necesito es que haya una categoría de producto que se llame TODOS para que cuando clice por ejemplo en la categoría sudaderas, luego pueda volver a ver todos los productos sin distinción de categoría.
    Lo ideal es que categorice todos los productos por defecto y que salga la primera en la lista.

    La opción que se me ocurre es simplemente hacer una categoría que se llame todas y marcarla en todos los productos, pero tendría que ir producto por producto marcandola, no me convence del todo esta opción. ¿Hay otra forma para conseguir lo que necesito?

    Adjunto link de lo que necesito (en amarillo): http://es.tinypic.com/r/152n5fr/9

    Espero haberme explicado. Muchas gracias.
    Un saludo.

    Iniciador del debate ethink1

    (@ethink1)

    Muchas gracias. Probaré aunque ahora el cliente me acaba de decir que quiere implementar el sistema de mrw… tendré que investigar.
    Un saludo.

    Iniciador del debate ethink1

    (@ethink1)

    Hola Fernando,

    No me indicas que plugin utilizas para añadir los 0,50 por cada prenda, ¿me puedes decir cuál es?

    Me gustaría utilizar la función, no sé si es mucho pedir, pero he estado mirando y probando algunos códigos que ví, pero me salía error 500… ¿me podrías decir el código y dónde meterlo?

    Respecto a las traducciones ya decía arriba que no me deja cambiarlo con el Loco translate… probaré con este otro que mencionas.

    Muchas gracias.

    Iniciador del debate ethink1

    (@ethink1)

    Muchísimas gracias esto era justo lo que necesitaba!

    • Esta respuesta fue modificada hace 11 meses por Fernando Tellado. Razón: Anonimizar nombres de usuarios
Viendo 15 respuestas - de la 16 a la 30 (de un total de 34)