Respuestas de foro creadas

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • Iniciador del debate fornarina

    (@fornarina)

    @cehojac PERFECTO!! Muchísimas gracias por tu ayuda 🙂

    Un saludo

    Iniciador del debate fornarina

    (@fornarina)

    @cehojac gracias por contestar. Algo estoy poniendo mal en el codigo del plugin (el de function.php ya lo he puesto) porque cuando incluyo el codigo para colocar el nombre del rol, de error toda la web. Como que me he comido algun simbolo o estoy sustituyendo mal el codigo.

    Si no te importa, podrías indicarme en ese codigo ¿cómo debería ponerlo exactamente?

    La linea donde aparece actualmente la ID del rol es esta:

    echo '<p>';
    						_e('Estás conectado con rango de ', 'ttslw_text_domain');
    						echo '<strong>' . ucfirst( implode(', ', $user_info->roles)) . '</strong> <br>';
    						if($chk_show_postcount=='on'){
    							 _e('Posts by you','ttslw_text_domain'); echo ': '. count_user_posts( $user_info->ID ).'<br>';
    						}

    Este es el código completo:

    /*Check if user is logged in then show user information and logout,dashboardand profile link*/
    			if (is_user_logged_in()) {
    				
    					?>
    					<div class="sidebar-login-info">
    					<?php
    					
    					if ($chk_show_avatar == "on"){
    						$show_avatar = isset( $show_avatar ) ? $show_avatar : 1;
    						if ( $show_avatar == 1 )
    							echo '<div class="avatar_container">' . get_avatar( $user_info->ID, apply_filters( 'sidebar_login_widget_avatar_size', 45 ) ) . '</div>';
    					}
    					echo '<p>';
    						_e('Estás conectado con rango de ', 'ttslw_text_domain');
    						echo '<strong>' . ucfirst( implode(', ', $user_info->roles)) . '</strong> <br>';
    						if($chk_show_postcount=='on'){
    							 _e('Posts by you','ttslw_text_domain'); echo ': '. count_user_posts( $user_info->ID ).'<br>';
    						}
    					echo "</p>";
    					?>
    					
    					<ul id="<?php if($chk_show_avatar=='on') echo 'sidebar-login-links';else echo 'sidebar-login-links-left'; ?>">
    						
    						<?php if($chk_show_dash == 'on'){ ?>
    							<li><a href="<?php echo admin_url() ?>"><?php _e( 'Dashboard' , 'ttslw_text_domain' )//_e( 'Dashboard' , 'default' ) ?> </a>|</li>
    						<?php } ?>
    						<?php if($chk_show_profile == 'on'){ ?>
    							<li><a href="<?php echo admin_url() ?>profile.php"><?php _e( 'Perfil' , 'ttslw_text_domain' )//_e( 'Profile' , 'tie' ) ?> </a>|</li>
    						<?php } ?>	
    							<li><a href="<?php echo wp_logout_url($redirect); ?>"><?php _e( 'Cerrar sesión' , 'ttslw_text_domain' )//_e( 'Logout' , 'tie' ) ?> </a></li>
    												
    					</ul>
    					</div>		
    		
    					
    					
    					<?php
    			}
    • Esta respuesta fue modificada hace 4 años, 1 mes por fornarina.
    Iniciador del debate fornarina

    (@fornarina)

    He hablado con Redsys, hay un error de vuelta en principio ocasionado por mi hosting, bloquea como la respuesta del pago y por eso no lo cambia automaticamente a «Procesanso». El error es el 403, y aparece en las notificaciones de Redsys.

    Ahora he contactado con mi hosting para ver si pueden solucionarme el problema.

    Seguiré informando por si se solucionara y ayudara a otros.

    Un saludo

    Iniciador del debate fornarina

    (@fornarina)

    Gracias José, acabo de escribir un mail a Redsys a ver si pueden ayudarme.

    Un saludo.

    Iniciador del debate fornarina

    (@fornarina)

    ¡Apañado! Como tengo un plugin instalado para customizar el CSS, he incluido:

    
    .gdpr.gdpr-privacy-bar {
        visibility: hidden;
    }

    y he conseguido que la barra desaparezca que es lo que quería. Así que, aunque no encuentro la razón del problema (que me encantaría saberlo), al menos he encontrado una solución alternativa.

    Gracias igualmente

    Iniciador del debate fornarina

    (@fornarina)

    Otra opción que he pensado, como tengo las carpetas del plugin GDPR en el servidor, através de CSS ocultar la barra o en alguna página del plugin desactivarlo con código o incluso configurar el banner para que mida 0% de ancho y alto (lo sé, es una chapuza) pero las pruebas que he hecho tocando código no me modifican nada de eso. Debo estar cambiándolo en el sitio equivocado, así que tampoco he querido toquetear más porque no controlo tanto…

    Iniciador del debate fornarina

    (@fornarina)

    Hola @lgrusin, gracias por intentar ayudarme, pero me temo que ni aun así.

    He borrado ambos.
    He instalado GINGER, no aparece en mi escritorio (y está activado).
    Lo borro.
    Instalo GPDR, no aparece tampoco en mi escritorio (y está activado).
    Lo borro.
    Vuelvo a instalar primero GINGER, lo activo.
    No aparece.
    Instalo el GDPR sin borrar GINGER y ¡Tachán! Vuelve a aparecerme la configuración de GINGER (aunque no la de GDPR).

    ¿Conclusión? Que por alguna extraña razón, ninguno de los dos plugins me funciona solo (lo sé, es extraño) y Ginger solo me funciona si tengo GDPR instalado (claro que entonces me salen ambos banners que no tiene ningún sentido).

    A ver si consiguen ayudarme en el foro de soporte de GINGER, no sé.

    Iniciador del debate fornarina

    (@fornarina)

    @lgrusin ya lo hice… Si desactivo el GDPR, Ginger deja de aparecer en mi escritorio (y sigue sin aparecer el plugin GDPR para poder configurarlo).

    También probé al reves, desactivar Ginger para ver si así aparecian las opciones de GDPR y tampoco.

    Iniciador del debate fornarina

    (@fornarina)

    @kgrusin le página es https://www.mamichula.es/, y si te fijas abajo, se ve el aviso legal en gris y rosa, y una linea gruesa negra debajo. Es el otro aviso legal que sale por defecto con el plugin GDPR. Si aceptas el gris y rosa, verás que te sale debajo el otro. Y no se como deasctivarlo porque no me sale el panel de preferencias el plugin GDPR en mi escritorio. Y si lo desactivo, desaparecen las preferencias del plugin GINGER, deben ir complementados.

    Iniciador del debate fornarina

    (@fornarina)

    No @lgrusin, no lo he solucionado.

    A ver si a alguien se le ocurre una solución…

    Iniciador del debate fornarina

    (@fornarina)

    El plugin en cuestión que muestra dicha barra de privacidad es este: https://es.wordpress.org/plugins/gdpr/

    El plugin que yo instalé para usar la barra de privacidad y la cual he configurado es: https://es.wordpress.org/plugins/ginger/

    El caso es, que haciendo comprobaciones, si desactivo el plugin GDPR, el plugin que yo instalé para la privacidad (GINGER), deja de aparecer en mi menu del escritorio de WordPress. Es como si para que funcione el plugin GINGER, debo tener activo el plugin GDPR.

    He probado también a desactivar el plugin GINGER para ver si asi, el plugin GDPR aparece en mi menú de la izquierda de WordPress, pero nada.

    Asi que no sé que ocurre. No me deja desactivar la barra negra pero tampoco editarla. Y la cosa es que salen las dos barras. Puedo desactivar la de GINGER, aunque es la que quiero y la que he hecho a mi gusto, pero aun con esas, no soluciono el problema. Porque la barra de GDPR no está configurada con los enlaces y textos correctos, asi que estoy en las mismas.

    Iniciador del debate fornarina

    (@fornarina)

    Ya he encontrado el plugin en cuestión, es el «RGPD» pero el problema es que no aparece en mi menú de la izquierda de mi escritorio de WordPress. Lo he desinstalado y vuelto a instalar, pero no entiendo porque no aparece por ningun lado para poder editarlo.

    En la página de plugins de WordPress, en las capturas que hay sobre este plugin, se supone que sale en la parte izquierda del menu. ¿Alguien sabe por qué podría ser que no aparece? Gracias.

    Iniciador del debate fornarina

    (@fornarina)

    Si alguien supiera decirme de donde viene, no cosigo encontrarlo por ninguna parte. Luego estará a la vista, y será una tontería, pero no doy con él.

    Dejo una captura: https://ibb.co/jbThCd

    • Esta respuesta fue modificada hace 4 años, 2 meses por fornarina.
    • Esta respuesta fue modificada hace 4 años, 2 meses por fornarina.
    Iniciador del debate fornarina

    (@fornarina)

    Almendron, ya lo he probado. No desaparece al desactivarlo.

    No se si es que en algún momento revisando código o algo, se me colaron dos letras o que, pero no hay manera.

    A ver si alguien puede ayudarme.

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)