Respuestas de foro creadas

Viendo 15 respuestas - de la 31 a la 45 (de un total de 73)
  • Iniciador del debate margarit0

    (@margarit0)

    He encontrado dos plugins que me han ayudado:

    WP Private Content Plus

    Simple Buddypress Profile Privacy

    Iniciador del debate margarit0

    (@margarit0)

    ¿Cómo se pueden ocultar las fotos de los miembros y el buscador avanzado a los usuarios visitantes?

    ¿Y cómo se puede ocultar el primer campo del primer nivel del registro a los usuarios visitantes?

    Iniciador del debate margarit0

    (@margarit0)

    Solucionado!

    Por el tema de uso de recursos desinstalé algunos plugins que pensé que no usaba, entre ellos el pluin «WPFront User Role Editor», lo he vuelto a instalar y los usuarios No registrados no tienen acceso al widget de actividad ni ala página miembros.

    Peeero… sigue el siguiente fallo, si un usuario registrado está en la página de su perfil, de un perfil de otro usuario registrado o estando en la página miembros y se desconecta, esa página queda visible aunque él ya no está logueado.

    Estoy probando con el plugin «Restrict content», me permite que en la página «Miembros»
    elegir el rol que por defecto puede ver la página, y debajo hay la opción d epoder tildar «Hide from Feed?» «Hide the excerpt of this post / page from the Feed?»
    ¿Qué significa esta segunda opción?

    Iniciador del debate margarit0

    (@margarit0)

    Antes la página de miembros y el widget de actividad de buddypress no eran visibles a los visitantes , pero ahora se ven! ¿Será un fallo de la versión 4.8.1?

    Iniciador del debate margarit0

    (@margarit0)

    Instalé los dos plugins siguiendo un tutorial que lo recomendaba, no activando unas opciones en el w3 total cache y sí activándolas en el autoptimize.

    Lo postitivo es que no sé cómo ha sido que ahora la pestaña html sale desactivada, me alegro porque estuve muchos días intentando desactivarla y no podía, ahora no sé cómo pero está desactivada 🙂

    Iniciador del debate margarit0

    (@margarit0)

    Al finale he desinstalado el w3 total cache y he copiado el siguiente código en el .htaccess, después de la línea » # END WordPress»:

    # BEGIN EXPIRES <IfModule mod_expires.c> ExpiresActive On ExpiresDefault «access plus 10 days» ExpiresByType text/css «access plus 1 week» ExpiresByType text/plain «access plus 1 month» ExpiresByType image/gif «access plus 1 month» ExpiresByType image/png «access plus 1 month» ExpiresByType image/jpeg «access plus 1 month» ExpiresByType application/x-javascript «access plus 1 month» ExpiresByType application/javascript «access plus 1 week» ExpiresByType application/x-icon «access plus 1 year» </IfModule> # END EXPIRES # BEGIN GZIP <ifmodule mod_deflate.c> AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript </ifmodule> <IfModule mod_headers.c> <FilesMatch «\.(ico|pdf|flv|swf|js|css|gif|png|jpg|jpeg|txt|html|htm)$»> Header set Cache-Control «max-age=2592000, public» </FilesMatch> </IfModule> <IfModule mod_filter.c> AddOutputFilterByType DEFLATE «application/atom+xml» \ «application/javascript» \ «application/json» \ «application/ld+json» \ «application/manifest+json» \ «application/rdf+xml» \ «application/rss+xml» \ «application/schema+json» \ «application/vnd.geo+json» \ «application/vnd.ms-fontobject» \ «application/x-font-ttf» \ «application/x-javascript» \ «application/x-web-app-manifest+json» \ «application/xhtml+xml» \ «application/xml» \ «font/eot» \ «font/opentype» \ «image/bmp» \ «image/svg+xml» \ «image/vnd.microsoft.icon» \ «image/x-icon» \ «text/cache-manifest» \ «text/css» \ «text/html» \ «text/javascript» \ «text/plain» \ «text/vcard» \ «text/vnd.rim.location.xloc» \ «text/vtt» \ «text/x-component» \ «text/x-cross-domain-policy» \ «text/xml» </IfModule> <IfModule mod_deflate.c> # Insert filters / compress text, html, javascript, css, xml: AddOutputFilterByType DEFLATE text/plain AddOutputFilterByType DEFLATE text/html AddOutputFilterByType DEFLATE text/xml AddOutputFilterByType DEFLATE text/css AddOutputFilterByType DEFLATE text/vtt AddOutputFilterByType DEFLATE text/x-component AddOutputFilterByType DEFLATE application/xml AddOutputFilterByType DEFLATE application/xhtml+xml AddOutputFilterByType DEFLATE application/rss+xml AddOutputFilterByType DEFLATE application/js AddOutputFilterByType DEFLATE application/javascript AddOutputFilterByType DEFLATE application/x-javascript AddOutputFilterByType DEFLATE application/x-httpd-php AddOutputFilterByType DEFLATE application/x-httpd-fastphp AddOutputFilterByType DEFLATE application/atom+xml AddOutputFilterByType DEFLATE application/json AddOutputFilterByType DEFLATE application/ld+json AddOutputFilterByType DEFLATE application/vnd.ms-fontobject AddOutputFilterByType DEFLATE application/x-font-ttf AddOutputFilterByType DEFLATE application/x-web-app-manifest+json AddOutputFilterByType DEFLATE font/opentype AddOutputFilterByType DEFLATE image/svg+xml AddOutputFilterByType DEFLATE image/x-icon # Exception: Images SetEnvIfNoCase REQUEST_URI \.(?:gif|jpg|jpeg|png)$ no-gzip dont-vary # Drop problematic browsers BrowserMatch ^Mozilla/4 gzip-only-text/html BrowserMatch ^Mozilla/4\.0[678] no-gzip BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html # Make sure proxies don’t deliver the wrong content <IfModule mod_headers.c> Header append Vary User-Agent env=!dont-vary </IfModule> </IfModule> <IfModule mod_gzip.c> mod_gzip_on Yes mod_gzip_dechunk Yes mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$ mod_gzip_item_include handler ^cgi-script$ mod_gzip_item_include mime ^text/.* mod_gzip_item_include mime ^application/x-javascript.* mod_gzip_item_exclude mime ^image/.* mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.* </IfModule>
    # END GZIP

    Después he visto que lo que pasaba era que el plugin «autooptimize» me había cambiado el css , la letra salía blanca por eso parecía que NO escribía. he tenido que añadir código al archivo css para que volviera a salir negra.

    Iniciador del debate margarit0

    (@margarit0)

    También he activado el OpCache

    Iniciador del debate margarit0

    (@margarit0)

    En el hosting me han activado el Memcached ¿la caché dinámica está incluida dentro de memcached o es una una opción aparte? El operador del hosting me ha dicho que él cree que la caché activa está dentro de la opción memcached ¿es así?

    Aparte puedo contrarar 1g de ram de más para el hosting

    Iniciador del debate margarit0

    (@margarit0)

    qué plugin de cahcé debería usar ¿W3 total cache?

    Iniciador del debate margarit0

    (@margarit0)

    Ok.

    ¿Tengo que pedir a los del hosting un hosting que permita tener memcached y cache dinámica?

    ¿Qué tipo de hosting necesitaría?

    La compañía me habló de un hosting de wordpress administrado, que es un hosting dedicado a wordpress ¿me aconsejas éste?

    Iniciador del debate margarit0

    (@margarit0)

    Por cierto. Antes de hacer la última prueba actualicé buddypress y wordpress, ahora tengo la versión 4.8.1, sí que vi que ahora lo que gasta más es CPU que antes de actualizar hasta la memoria se colapsaba en color rojo.

    Iniciador del debate margarit0

    (@margarit0)

    Gracias por tu ayuda Fernando, paso a responderte:

    1.-Hosting ultimate, linux. Servidor compartido.

    2.-Sólo tengo instalados los plugins que tengo activados, es decir, que uso, son 48, son muchos sí, pero son necesarios, ya he borrado algunos de los que sí podía pasar aunque a regañadientes.

    La lista total de los plugins que tengo es:

    BuddyDev) BP Deactivate Account

    AddToAny Share Buttons

    Adminimize

    amr shortcode any widget

    ARVE Advanced Responsive Video Embedder

    Aviso de Cookie

    BP Block Users

    BP Force Profile Photo

    BP Member Type Manager

    BP Profile Search

    BP Redirect To Profile

    BP Required Field Notification

    Bp Xprofile Custom Textarea

    Buddypress

    BuddyPress Avatar Moderator

    BuddyPress Members only

    BuddyPress Simple Terms And Conditions

    BuddyPress Xprofile Custom Fields Type

    Contact Form 7

    Duplicate Post

    Easy Updates Manager

    Image Widget

    List category posts

    LoginPress – Customizing the WordPress Login

    MediaPress

    Mostrar IP del servidor y uso de memoria

    New User Approve

    Pluginception

    Popups – WordPress Popup

    qTranslate-X

    Really Simple SSL

    Redirection

    Register IPs

    Simple Custom Post Order

    TinyMCE Advanced

    User Activation Keys

    WP Author, Date and Meta Remover

    WP Change Default From Email

    WP Encrypt

    WP Fastest Cache

    WP Maintenance Mode

    WP Smush

    WP User Avatar

    WP-PageNavi

    WP-SpamShield

    WPFront User Role Editor

    You Have a New (BuddyPress) Message

    El “Autoptimize” lo desinstalé después de leer que hay quien no lo usa porque gerena lentitud para los usuarios.

    —————

    3-Tema FIRMASITE: https://srd.wordpress.org/themes/firmasite/

    4.-Ayer vi que cuando hay 3 usuarios conectados escribiéndose a con el plugin «BP better messages» mirando yo dentro del c-panel veía como en el apartado de utilazación de CPU se ponía la barra roja marcando 86/100. El uso de memoria no se volvió roja pero subió a 615,92/1024

    5.-Yo no entiendo porqué este hosting/servidor que sólo tiene esta web hecha con wordpress se quede sin recursos, cuando tengo contratado el mismo tipo de hosting y servidor en la misma compañía para una tienda hecha en prestashop, esta web de prestashop tiene clientes siempre en movimiento y nunca ha habido problemas de recursos ni nada. En teoría este hosting es multisite permite tener muchas webs hospedadas ¿y se queda sin recursos con una sola de wordpress?

    Es más, tengo contratado un tercer hosting/servidor igual que estos dos anteriores, en la misma compañía y en este tercer hosting/servidor estoy haciendo de momento 4 webs distintas con wordpress, no uso wordpress multisite, y cada wordpress tiene sus plugins, una de estas 4 webs está activa hace tiempo y de momento no he tenido problemas, entonces… si en un hosting se consumen todos los recursos con una sola web ¿qué pasará con el hosting que tiene varias webs de wordpress con sus plugins? ¿es por culpa de Buddypress? Sólo está instalado buddypress en la web que está consumiendo los recursos.

    • Esta respuesta fue modificada hace 6 años, 5 meses por margarit0.
    Iniciador del debate margarit0

    (@margarit0)

    No se visualizan las imágenes que subo, así que lo transcribo:

    NIVEL 7
    —–
    NIVEL 1
    —–
    NIVEL 2
    —–
    NIVEL 3
    ——
    NIVEL 4
    —-
    NIVEL 5
    —–
    NIVEL 6

    No sé por qué, pero el nivel 7 no aprece debajo del 6.

    Iniciador del debate margarit0

    (@margarit0)

    Me he instalado el «Server IP & Memory Usage Display» y según él, ahora que he desconectado los 3 usuarios de prueba que al interactuar entre ellos se había gastado todo el espacio de memoria ram:

    | Memoria: 2 de 1024 MB (0%) | LÍMITE WP: 40 MB | PHP 7.0.21 @64BitOS

    Iniciador del debate margarit0

    (@margarit0)

    Muchísimas gracias Fernando!

Viendo 15 respuestas - de la 31 a la 45 (de un total de 73)