Respuestas de foro creadas

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • Foro: Seguridad
    En respuesta a: https no seguro
    Iniciador del debate marort4

    (@marort4)

    Solucionado, el plugin Better search & replace me había dado un error el cual ya he solucionado contactando con ellos. Actualmente, la web, funciona perfectamente y hace la redirección sin ningún problema.

    Gracias por vuestra ayuda, sois geniales!!

    Un saludo,
    Kevin.

    Foro: Seguridad
    En respuesta a: https no seguro
    Iniciador del debate marort4

    (@marort4)

    Efectivamente, no lo había incluido en el mod.header,,

    Ya he editado el código en el htaccess.

    Puesto que mi web es bastante extensa y me ha sido «imposible» buscar y editar cada uno de los posibles «http» he utilizado el plugin «Better search & replace» para reemplazar todos los enlaces http a https.

    Ha funcionado bien, en las versiones en español y en inglés funciona perfectamente, ya redirige automáticamente hacia https todas las peticiones.

    Sin embargo en el apartado «fr.miamiortiz.com» tras haber hecho los mismos pasos sigue sin mostrarme el candado, en el cual, además, he perdido los enlaces al logo y demás :S

    Foro: Seguridad
    En respuesta a: https no seguro
    Iniciador del debate marort4

    (@marort4)

    Gracias por tu tiempo, Javier.

    He añadido esa linea tal cual pero no parece haber cambio alguno.

    Foro: Seguridad
    En respuesta a: Intento de hackeo
    Iniciador del debate marort4

    (@marort4)

    Contactaré a 1and1 a ver que me pueden ofrecer y sino seguiré probando con plugins.

    Gracias, Kevin.

    Iniciador del debate marort4

    (@marort4)

    He borrado el plugin Really Simple SSL, el cual me hacía too_many_redirects, y tenía este codigo en el htaccess, el cual no me deja eliminar o me da errores.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    Al codigo le he añadido lo siguiente:
    RewriteCond %{HTTPS} off [OR]
    RewriteCond %{HTTP_HOST} ^www\. [NC]
    RewriteRule ^ https://es.miamiortiz.com%{REQUEST_URI} [R=301,L,NE]

    Con esto he conseguido que me haga la redirección a https y a la vez del main site al subsite.

    Aunque el candado ya no me aparece en verde y me dice que el sitio no es del todo seguro, a que se debe esto?

    Iniciador del debate marort4

    (@marort4)

    He probado con ambas lineas y sigue sin funcionar.

    Creo que ya se donde debe estar el error; tengo un plugin, Really Simple SSL, que me hace una redireccion 301 para evitar que la gente pueda entrar en http y siempre sean redirigidos a https.

    Puede que esto esté influyendo?

    Iniciador del debate marort4

    (@marort4)

    Ahora me da el error » la página es.miamiortiz.com te ha redirigido demasiadas veces.

    Es correcta esta sintaxis para el .htaccess?

    «Redirect 301 / http://es.miamiortiz.com/»

    • Esta respuesta fue modificada hace 3 años, 5 meses por marort4.
    Iniciador del debate marort4

    (@marort4)

    Cierto, había creado el subdominio desde el panel de control..

    Ya he podido duplicar la instalación.

    Iniciador del debate marort4

    (@marort4)

    Correcto, era la caché del navegador la que me daba el error.

    He vuelto atrás, he borrado la rewrite rule del archivo .htaccess y el sitio duplicado.

    Ahora todo ha vuelto a la normalidad.

    Después he vuelto a hacer un duplicado y parece que la página sigue en blanco; he comprobado que en el servidor ftp no se genera ningún archivo.

    Que hay algún plugin más con el que pueda trabajar? De lo contrario contactaré con el soporte del plugin Duplicator a ver si ellos me saben solucionar el problema.

    Gracias, Kevin.

    Iniciador del debate marort4

    (@marort4)

    Hola Jose, gracias por tu atención; He utilizado el plugin duplicator para clonar el sitio principal a un subsite «es.miamiortiz.com» y después he cambiado el .htaccess de miamiortiz (la carpeta del sitio principal) añadiendo «Redirect 301 / http://es.miamiortiz.com/».

    El redirect ha funcionado bien, sin embargo el duplicator no me ha clonado nada, la página está en blanco.

    Habiendo borrado el redirect y sobreescrito el archivo .htaccess con el original, aun así me redirecciona a la página en blanco. Trato de entrar en «Mis sitios -> Administrador de la red» para ir a sitios y eliminar el sitio duplicado pero cuando hago esto me redirecciona automáticamente a «es.miamiortiz.com» la cual está en blanco.

    Me he quedado atascado, no puedo duplicar el sitio, no puedo borrar el sitio duplicado en blanco, no puedo evitar que me redireccione a pesar de que en .htaccess ya no está la redirección… :$

    • Esta respuesta fue modificada hace 3 años, 5 meses por marort4.
Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)