Respuestas de foro creadas

Viendo 15 respuestas - de la 1 a la 15 (de un total de 18)
  • Hola de nuevo,

    ¿Podrías indicar si aparece algún error en la consola de Opera tras cargar la galería e intentar clicar en las opciones de tamaño de imagen que no funcionan?

    Gracias por el enlace, quería ver si había errores en la consola. Veo que hay un par de ellos relacionados con Rocket Loader, pero eso no debería influir en los errores que estás experimentando, así como que jQuery Migrate está instalado ya y no te ha solucionado el error 🙁

    Galería de Fotos: en la opción «tamaño de la imagen» no te permite seleccionar, solo queda fijo el «miniatura». Aparecen las otras 2 opciones pero no permite setearlas.

    Esto que comentas podría ser un problema de estilos relacionado con que haya algún elemento que, aunque visualmente no lo parezca, tiene un margen muy grande y queda posicionado por encima de otros elementos, como las dos opciones del tamaño de la imagen, de manera que al intentar clicar en ellas estás clicando ese elemento grande cuya capa queda por encima.

    Por desgracia me temo que no puedo darte indicaciones más concretas al tratarse de un problema en al parte de administrador, salvo que pudieras adjuntar alguna captura. ¿Conoces el inspector de código de Opera?

    Hola!

    Te recomiendo que preguntes directamente en el soporte del plugin WC Marketplace y consultes su base de conocimiento, en la que hay un apartado dedicado a este tema, en el que indican que los vendedores necesitan tener marcada la opción «Submit product».

    Un saludo.

    Buenas!

    ¿Podrías indicar la web en la que has apreciado el problema así como el navegador que has utilizado?

    Me temo que sin esa información lo único que te puedo recomendar es instalar, si no lo has hecho ya, el plugin jQuery Migrate Helper, ya que en la versión de WordPress 5.6 puede haber pequeños problemas de compatibilidad que se solucionan con dicho plugin.

    Un saludo.

    Consulta los datos incluidos más adelante para saber cuál ha sido el motivo.

    ¿Entonces No te da más información ni te dice nada? Qué extraño :S

    No sé si esto último tiene alguna relevancia porque mi página es en sí https://www.naturagodella.com/, con las tres uves dobles.

    Depende de si has añadido el sitio como «Dominio» o como «Prefijo de la URL». Yo te recomiendo que uses «Dominio» y registres «naturagodella.com», ya que al registrar el dominio, eso incluye el subdominio http://www.naturagodella.com y Google lo tratará como si fueran lo mismo.

    Y por otra parte, si pongo en el Search Console «http://naturagodella.com/» sin el www me pone como que está duplicada y que google ha puesto como canónica esta web: «http://www.plasticmurs.com/» que no tengo ni idea de quién es ni veo la relación entre una y otra.

    Plasticmurs.com no aparece en ningún sitio en tu web, ni en el código ni SEO Spider encuentra nada relacionado con ella. Sí que veo que el dominio apunta al mismo sitio que tu web, a 10dencehispahard, por lo que puede que Google se haya hecho un lio con las DNS o que el hosting estuviera mal configurado en el momento en que Google trató de indexar tu dominio (y encontró por error plasticmurs.com al ir a consultar naturagodella.com). ¿Desde cuándo te viene pasando este problema?

    En resumen, como siguiente paso yo probaría a añadir a la Search Console el dominio y le indicaría a mano a la misma que indexe la página https://www.naturagodella.com/. También generaría un sitemap con YOAST y lo añadiría a la Search Console.

    Hola Julia!

    En efecto, no aparece en Google, aunque comprobando el robots.txt y haciendo un escaneo en Screaming Frog SEO Spider todo parece corrector y la web es indexable.

    Una acción que puede ayudar con la indexación es instalar Yoast SEO si no lo has hecho ya, el cual además te permitirá generar un sitemap de tu web, ayudando a los buscadores a indexar correctamente el contenido. También te recomiendo encarecidamente, a menos que ya lo hayas hecho, registrar tu dominio en la consola de búsqueda de Google, en la que el propio Google te reportará cuál es el estado de indexación de tu web, si hay algo que no le gusta, etc., además de poderle «forzar» (más bien «pedir que se de prisa») la indexación de páginas dentro de tu web.

    Por favor, comenta qué errores reporta la consola de búsqueda de Google y estaré encantado de ayudarte 🙂

    Hola!

    Por lo que veo, el botón del primer producto no funciona porque queda oculto debajo del área del segundo producto; como puedes ver en la siguiente imagen, el recuadro azul corresponde al área que ocupa el segundo producto.

    En cualquier caso, parece que el primer producto tiene un estilo completamente distinto al resto, ya que ni siquiera aparece centrado como los demás. ¿Podrías intentar aplicarle al primer producto el mismo diseño que a los demás?

    Un saludo.

    ¡Buenas!

    Ya que se trata de un problema con productos y la web tiene WooCommerce, entiendo que el problema surge al usar el importador de WooCommerce, ¿no? Por lo que comentas, tiene pinta de que el importador no está cogiendo bien el delimitador de las columnas. Normalmente las columnas están separadas por comas, ¿podrías abrir tu CSV en un editor de texto y confirmar si el delimitador son comas, punto y coma o tabulaciones?

    En caso de no ser comas, puedes cambiar el delimitador durante el proceso de importación tal y como indica la documentación de WooCommerce.

    Un saludo.

    Vale, mi respuesta llega tarde, lo siento!

    Me alegro de que ya esté arreglado 🙂

    Hola!

    Cuando entro a www.aires-acondicionados.es (o aires-acondicionados.es, sin www), con o sin https, me redirige a www.aires-acondicionados.es/recambios/ en todos los casos, por lo que no consigo ver el error generado por Plesk que comentas.

    ¿Estoy entendiendo mal y necesitas otra cosa como que la página principal sea www.aires-acondicionados.es sin /recambios/ o simplemente no consigo reproducirlo? Si es el primer caso, probablemente se trate de un tema de caché con las redirecciones. En el segundo caso, ¿podrías profundizar un poco más en cuál es el objetivo que necesitas?

    Un saludo!

    Buenas!

    Para solucionar este problema, hay que añadir un par de propiedades a los estilos del encabezado. Veo que hay unos estilos embebidos que modifican el tema Astra, estos son los que necesitan un par de retoques:

    Donde pone:

    @media (min-width: 922px) {
      .ast-theme-transparent-header #masthead {
        position: absolute;
        left: 0;
        right: 0;
      }
    }

    Hay que modificarlo para que sea:

    @media (min-width: 922px) {
      .ast-theme-transparent-header #masthead {
        position: relative;
        left: 0;
        display: flex;
        right: 0;
      }
      .main-header-bar-wrap {
        position: relative;
        width: 100%;
      }
    }

    Y se verá tal que así 🙂

    Un saludo.

    Ya que tienes cPanel, ¿podrías acceder al fichero de log error.log y pegar las últimas líneas que aparecen tras intentar acceder a la pantalla de recuperar contraseña y/o login fallido, por si hubiera más información? Puedes encontrar las instrucciones tanto para acceder al fichero como para activar las trazas aquí.

    Hola de nuevo!

    Intenté cambiarla desde php my admin pero no se cambia.

    Tan sólo por confirmarlo, ¿has cambiado la contraseña editando el campo de la base de datos tal cual, en texto plano, o la has insertado en MD5?

    ¡Hola!

    Por lo que veo en el código, parece que el hook no devuelve nada si no entra en el if (es decir, si no tiene el rol ‘franquicia’). Si todos los demás roles deben poder añadir productos sin ejecutar la validación, deberías devolver true en ese caso.

    Puedes añadir return true; entre las dos llaves } finales, aunque en su lugar te recomiendo usar el patrón return early y dejar la comprobación inicial así:

    $user = wp_get_current_user();
    if ( ! in_array( 'franquicia', (array) $user->roles ) ) {
        return true;
    }
    
    function avoid_add_to_cart_from_different_main_categories( $passed, $product_id, $quantity ) {
    ...
    ...
    ...
        return $passed;
    }
    add_filter( 'woocommerce_add_to_cart_validation', 'avoid_add_to_cart_from_different_main_categories', 10, 3 );

    ¡Un saludo!

    • Esta respuesta fue modificada hace 1 año, 11 meses por Héctor Prieto. Razón: Añadidos más puntos suspensivos
    • Esta respuesta fue modificada hace 1 año, 11 meses por Héctor Prieto.

    ¡Hola!

    Podrías activar el modo debug con el fin de poder ver el mensaje de error en sí? Si no puedes acceder al fichero wp-config.php, puedes obtener el mismo resultado instalando el siguiente plugin (puedes desactivar el plugin después para deshabilitar el modo debug).

    ¡Gracias!

Viendo 15 respuestas - de la 1 a la 15 (de un total de 18)