Respuestas de foro creadas

Viendo 15 respuestas - de la 151 a la 165 (de un total de 167)
  • Shinjiru_fred

    (@shinjiru_fred)

    Hola Marulo.

    ¿No tienes el sitio montado para poder entrar y ver lo que quieres hacer?.

    Creo que puedo ayudarte aunque así sin pocos dats es algo complicado para mi. No se si te refieres a un tema con 3 columnas donde el contenido va en el centro o a la izquierda.

    Si puedes publica el link de tu sitio aquí para ver que podemos hacer.

    Saludos.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola cascamorris.

    Para hacer lo que quieres necesitas modificar el archivo functions.php de tu tema. Recuerda tener una copia del archivo que vas a modificar, sobre todo el functions.php que es algo delicado.

    Deber hubicarte en la siguiente línea de código:

    if(function_exists('register_sidebar')){

    Inmediatamente debajo debes ver algo similar a esto (no todo el código tiene porque ser igual):

    //widget sidebar
    register_sidebar(array(
    	'name' => 'widgets-header',
    	'before_widget' => '<div class="widget %1$s">',
    	'after_widget' => '</div>',
    	'before_title' => '<h4>',
    	'after_title' => '</h4>',
    ));

    Puedes copiar uno de los que tiene tu tema. Lo elemental que debes cambiar es el nombre del widget para que no sea igual a los que ya tienes. Las otras partes del código las cambiaras en función de tus conocimientos de xHTML.

    Así tu nuevo widget ya esta listado pero no funciona. Para que funcione debes ir a tu archivo header.php y pegar donde quieras que aparesca tu flamante widget lo siguiente:

    <?php if(function_exists('dynamic_sidebar')) { dynamic_sidebar('widgets-header') ; } ?>

    Recuerda siempre que el nombre del widget debe estar dentro de dynamic_sidebar(‘aquí el nombre del widget’) para que llame al correcto.

    En esta dirección tienes otra explicación de lo que deseas:

    http://www.creativasfera.com/wordpress-como-crear-zonas-listas-para-widgets/

    Tambien tienes la documentación oficial:

    http://codex.wordpress.org/Widgetizing_Themes

    En ingles pero igual puedes tirar de google para traducirlo.

    Espero que todo esto te sirva de ayuda.

    Suerte.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola amigo Cascamorris.

    Entra en este link y copia el código en el final de tu hoja css.

    http://wordpress.pastebin.ca/2151812

    Tambien necesitas descargar y guardar las siguientes imágenes en la carpeta images de tu plantilla, recuerda conservar los nombres de la imágenes.

    http://imageshack.us/photo/my-images/23/ms6zky9f.png/

    http://imageshack.us/photo/my-images/17/p1fivb39.png/

    Con eso ya deberían estar resueltos los problemas.

    Saludos.

    Shinjiru_fred

    (@shinjiru_fred)

    Vamos a hacer algo, borra todo lo que te he dicho que hagas, hagamos una chapuza más elegante.

    Avisame por aquí cuando lo hagas.

    Shinjiru_fred

    (@shinjiru_fred)

    Saludos Comodo.

    Te diré que en tu caso haré de índio, tiraré flechas a ver si acierto ya que no conosco ese tema. Sabes que en el editor de entradas, al subir una imagen, te da la opción de colocarla como destacada. Muchos temas trabajan con dicha imagen para colocarla en los resumenes de las entradas y en los sideshow. ¿Has asignado ya la imagen destacada?

    Te repito, va la flecha, a ver si doy en el blanco. Revisa eso a ver si te funciona.

    Suerte.

    Shinjiru_fred

    (@shinjiru_fred)

    Amigo Cascamorris, creo que la cosa se esta complicando un poco, espero que tengas una copia de la hoja de estilo de tu plantilla.

    Lo que estamos haciendo es practicamente una chapuza debido a que tendriamos que borrar y no sobreescribir elementos pero bueno…

    pega esto al final de la hoja:

    body#home div#sidebar div#firstcol {
        width: 329px;
    }

    los bordes rojos de firstcol lo quitas borrando border: 1px solid red;

    div#sidebar div#firstcol div.widget {
        border: 1px solid red; /*debes borrar toda esta línea*/
        width: 329px;
    }

    Con eso si se va a cuadrar aunque vamos a tener otro problemita que lo vas a ver. Para solucionarlo tienes que modificar unas imagenes de fondo…

    La cosa se esta complicando te lo repito, te recomiendo que tengas una copia de tu hoja de estilo y de tu plantilla.

    Saludos.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola Cascamorris.

    Amigo, elimina esto que colocaste:

    body#home #sidebar #secondcol, body#home #sidebar div.widget { width: 330px!important; }

    y copia y pega esto justo donde estaba lo anterior:

    body#home #sidebar #secondcol div.widget {
        width: 330px !important;
    }
    div#sidebar div#firstcol div.widget {
        width: 239px !important;
    }

    Con eso se soluciona. Prueba verlo desde otros navegadores porsi, sobre todo con Internet Explorer.

    Avisa cualquier problema.

    Saludos.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola Petelo.

    Que bien que se solucionó el problema. IE es la típica chica rubia popular y caprichosa, para ella no vale el mismo trato que con las demás, a ella hay que dedicarle todo el tiempo del mundo. Menos mal que la IE9 es una chica menos complicada.

    Suerte 😉

    Shinjiru_fred

    (@shinjiru_fred)

    hola Petelo.

    El problema que tienes esta en este pedazo de CSS

    #homebottom .widget {
        display: inline;
        float: left;
        padding: 5px;/*Este es el culpable*/
        width: 250px;
    }

    Veo que tienes una hoja de estilo que puedes usar para solucionar problemas con los IE.

    Modifica la hoja de estilo llamada lte-ie7.css que esta en esta ruta:
    /wp-content/themes/SaveTheDate/lte-ie7.css

    coloca esto para que se solucione el problema:

    #homebottom .widget {
        padding: 0;/*Así se soluciona*/
    }

    Luego de esto debes entrar en tu plantilla y llegar a head.php, dentro busca más o menos las siguientes líneas (he tirado a adivinar con lo de ‘template_directory’):

    <!--[if lte IE 7]>
    <link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/SaveTheDate/lte-ie7.css" type="text/css" media="screen" />
    <![endif]-->

    y cambiarás:

    <!--[if lte IE 7]-->

    por:

    <!--[if gte IE 7]-->

    La modificación afectará solo a IE7 y superiór, osea al IE8 e IE9.

    Si desearas que la modificación afectara a todos los IE solo coloca:

    <!--[if IE]-->

    Bueno, espero haber servido de ayuda, cualquier cosa no dudes en comentarlo para tratar de solucionarlo.

    Ah, en hora buena a los futuros esposos.

    Suerte.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola Laura20.

    Pues, no sabría decirte si hay una página que de soporte a tu plantilla, sería cuestión de buscar.

    Si creo entender lo que quieres eliminar son esos bordes grises, si realmente es eso puedes buscar y comentar el siguiente código:

    /*
    .sf-menu {
        border-left: 2px solid #F0F0F0;
    }
    
    .sf-menu a {
        border-right: 2px solid #F0F0F0;
    }
    */

    para comentar código CSS se inicia con /* y se termina con */

    /*Este es un comentario en CSS*/

    Es preferible comentar código antes que borrarlo cuando se estan haciendo estos pequeños cambios, luego, cuando estes segura de que esta bien lo que has hecho puedes borrarlo.

    La hubicación del archivo dice que es:

    http://be-science.com/?itx=css&ver=3.3.2

    Shinjiru_fred

    (@shinjiru_fred)

    Saludos Laura20, me alegra ser de ayuda.

    ¿Modificar cosas específicas? ¿tan específicas como?. Que otra cosa quieres modificar para ver si puedo ayudarte.

    Estoy viendo tu página con Firefox 12 y no veo botones con border, no se si sea cosa de navegadores.

    Saludos.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola ferbovi.

    Ahora si te entiendo. Bueno, para empesar te diré que el funcionamiento de los dos temas es muy distinto. En el tema imbalance2 usan unas librerias jquery para asignar las posiciones de las capas, en tu tema, tienes 3 div que sirven como contenedor a tus entradas, de 3 en 3. El ancho de estos ‘contenedores’ es 100%, y el alto depende del largo del contenido e imagen que colocas en las entradas.

    La solución más simple es que siempre coloques la misma cantidad de texto y el mismo tamaño de la imagen, así, todo estará bien organizado y sin toca código alguno.

    Shinjiru_fred

    (@shinjiru_fred)

    Saludos Ferbovi.

    En realidad me gustaría ayudarte un poco pero no se bien lo que necesitas. Lo que si veo es que tienes un problema con las imagenes y los extractos de las entradas (Ahora estoy usando firefox 12, no se como se muestra en otros navegadores) si el problema es en todos puedes probar eliminando:

    .lay1 .post_content {
        height: 100px;
    }

    Primero comenta el código, si se te soluciona puedes borrarlo o dejarlo comentado:

    /*
    .lay1 .post_content {
        height: 100px;
    }
    */

    De esta manera se resuelve el que las imagenes tapen el extracto de la entrada.

    Soy medio lento para entender las cosas, ¿podrias reformular tu pregunta para ver si la puedo entender y tratar de ayudarte?.

    Suerte.

    Shinjiru_fred

    (@shinjiru_fred)

    De nuevo hola Alberto.

    Sí, esas son las propiedades que tienes que modificar pero no notas ningún cambio porque tienes otra propiedad que te cambia de nuevo el tamaño.

    body#home #sidebar #firstcol, body#home #sidebar #secondcol {
        width: 239px;
    }

    Recuerda que en CSS si colocas en una clase un valor y más abajo hay otra que actua sobre la primera la sobre escribirá, es decir, la última propiedad es la que manda, ejemplo:

    carlos=mujer

    carlos=hombre

    Para este pequeño ejemplo carlos será igual a ‘hombre’ aunque le hubieramos colocado previamente el valor ‘mujer’.

    prueba modificando esa linea con algo como:

    body#home #sidebar #firstcol {
        width: 239px; /*El tamaño que requieras*/
    }
    body#home #sidebar #secondcol {
        width: 100px; /*El tamaño que requieras*/
    }

    Así debería funcionar.

    Suerte.

    Shinjiru_fred

    (@shinjiru_fred)

    Hola laura20.

    Si entendí bien tu pregunta te puedo decir que el menú horizontal principal usa una imagen (que también es compartida por otras zonas de la plantilla), especificamente esta:

    http://wp-themes.com/wp-content/themes/bombax/css/ui/redmond/images/ui-bg_gloss-wave_55_5c9ccc_500x100.png

    Tendrías que buscar la imagen y cambiarle el color con un programa de edición de imagenes como paint.net por mencionar alguno.

    La ruta del archivo css es: ../wp-content/themes/bombax/css/ui/redmond/jquery.ui.theme.css o al menos lo es en el theme de muestra de wordpress.org

    La ruta de la imagen debería estar por: ../wp-content/themes/bombax/css/ui/redmond/images/ui-bg_gloss-wave_55_5c9ccc_500x100.png

    un saludo! espero que esto te ayude un poco.
    Suerte.

Viendo 15 respuestas - de la 151 a la 165 (de un total de 167)