Respuestas de foro creadas

Viendo 15 respuestas - de la 1 a la 15 (de un total de 34)
  • Podéis probar a instalar el plugin Enable jQuery Migrate Helper y activarlo, para ver si así se soluciona hasta que el desarrollador del tema/plugin actualice a la última versión con todo el código compatible, y así no sería necesario hacer el downgrade.

    Efectivamente tu web está usando SwipeBox, que no está actualizado para las nuevas versiones de jQuery (lleva sin tocarse casi cinco años) y casi seguro que es eso lo que da problemas.

    Parece que lo llama el plugin ‘pt-real-estate-professional’ que te debe venir con el tema, ¿si desactivas ese plugin te sigue dando fallos?

    El problema es que entiendo que es un plugin vital para que funcione tu web… Supongo que la manera más rápida sería contactar con los creadores del tema (https://thepixeltribe.com/contact/) y ver qué solución te pueden ofrecer…

    Si no tendrías que ver la manera de desencolar los scripts y los estilos relacionados con swipebox para que no carguen, o al menos, quitar donde se inicializa (parece que en /plugins/pt-real-estate-proffesional/public/js/pt-real-estate-proffesional-public.js justo abajo del archivo), pero claro, no es muy recomendable editar un plugin a mano, pero si no te dan otra solución…

    Hola @jfsoliscr, ¿tienes instalado el plugin Responsive Lightbox & Gallery? ¿O alguno similar para que se abran las fotos en grande?

    Si lo tienes instalado y en los ajustes de Lightbox tienes marcado SwipeBox, prueba a cambiarlo a otro, como por ejemplo TosRUs, actualiza y mira a ver si se soluciona. Es un fallo en el que están trabajando los de dFactory para arreglar aparentemente según su foro de soporte.

    Si no tienes instalado este plugin, puede que sea otro similar que utilice una de esas librerías para ello… échale un ojo a ver si te da alguna pista o nos comentas.

    Foro: Diseño – Temas y plantillas
    En respuesta a: hover

    Hola @ocio132, estás aplicando muchas reglas CSS que no están apuntando donde tú quieres.

    Te valdría con algo así:

    #new_subscriber > p > a:hover {
        color: #5ee5c7;
    }

    En tu regla el :hover debería ir en el elemento a:nth-child(1) o en el b:nth-child(1) que habrías puesto, ya que no hay otro elemento enlace después en el HTML.

    Pero a no ser que vayas a crear más párrafos con enlaces dentro, no hace falta que selecciones los :nth-child(n) para diferenciarlos.

    ¡A ver si te funciona!

    Hola @cesarat, asegúrate que en el tema propio que estás creando añades la compatibilidad con los post_thumbnails. En el archivo de funciones añade:

    add_theme_support( 'post-thumbnails' );

    Tienes más info en este enlace

    Si esto ya lo tienes, podemos ver si es alguna otra cosa lo que está fallando, ¡nos cuentas!

    Juan Hernando

    (@unintended8)

    Hola @teddypicker91, entiendo que ahora mismo tienes por un lado menús, widgets y artículos en inglés, y después los artículos en español y quieres que te salgan también en español el menú y widgets.

    Para el menú tienes que ir a Apariencia > Menús, y crear uno nuevo con las páginas correspondientes en español. En la parte de abajo en los ajustes de menú te saldrá ‘Donde se verá’ y tendrás que marcar Primary Español, o Menú principal Español, o como se llame el menú principal de tu página. Seguramente tengas ahí uno con el mismo nombre duplicado, uno que sale English y otro Español. Ahí eliges el correspondiente.

    Para los widgets, igual, en Apariencia > Widgets, te saldrá la barra lateral o barras laterales donde tengas widgets. Si pinchas en cada uno te saldrá una opción que es ‘El widget se muestra para’ y un desplegable con ‘Todos los idiomas’, y cada uno de los idiomas. Si quieres que te salgan unos en inglés y otros en español, tienes que añadir por ejemplo, dos diferentes y que cada uno te salga para cada uno de los idiomas.

    Si es algo más específico, si nos pones la URL o unos pantallazos o algo para aclararnos mejor, guay 🙂

    Juan Hernando

    (@unintended8)

    Hola @vinilopolis, el problema no es que no estén las imágenes, que sí que están, sino que salen tan pequeñas que las tapa totalmente el recuadro de ‘seleccionar opciones’.

    Tendrías que revisar los estilos CSS de la página para pantallas pequeñas. Por ejemplo, si añades a tu hoja de estilos esto, ya deberían verse:

    @media only screen and (max-width:500px) {
        .woocommerce ul.products.columns-3 li.product, .woocommerce-page ul.products.columns-3 li.product {
            width: 100%;
        }
    }

    También lo puedes añadir desde Apariencia > Personalizador > CSS adicional, si no tienes creado un tema hijo para hacer tus modificaciones de este estilo.

    Juan Hernando

    (@unintended8)

    Hola @scorpandy, ¿esa hoja de estilos la estás intentando cargar desde el functions.php de tu tema?

    En ese caso te bastaría con

    function my_styles() {
        wp_register_style('cc_styles', plugins_url( 'Checkout-customizer/cc-styles.css' ));
        wp_enqueue_style('cc_styles');
    }
    add_action( 'wp_enqueue_scripts', 'my_styles' );

    Si la estás intentando cargar desde un plugin que estás creando, en ese caso tendrías que quitar el nombre del plugin de la URL, ya que con __FILE__ ya estarías cargando la ruta relativa al directorio padre de ese archivo.

    + info sobre plugins_url()

    Juan Hernando

    (@unintended8)

    Hola @luicasan, una vez que tienes la URL de tu archivo de Keynote en iCloud, puedes ir a esta web https://keynoteiframe.com/ que metiendo esa URL te genera el código del iframe que tienes que meter en tu web.

    Ese código iframe lo puedes meter en cualquier página o entrada usando el bloque HTML personalizado, lo pegas y ya lo podrías ver en tu web (no en la parte de edición, pero sí en el frontend).

    Foro: Plugins y Hacks
    En respuesta a: qTranslator arranque

    Hola Pimpinela, la verdad es que el plugin qTranslate-X lleva años sin ser actualizado y aunque funciona tal cual, es probable que con algún plugin que estés utilizando para crear el contenido (Elementor tal vez) no sea compatible. Tampoco es compatible con Yoast, con lo cual no es una solución que yo te recomendaría para crear el multilenguaje de tu web.

    Existe un proyecto en GitHub donde están intentando resolver estos problemas y muchos otros (compatibilidad con el nuevo editor de bloques, por ejemplo) pero aún no está el proyecto avanzado del todo: https://github.com/qtranslate/qtranslate-xt

    Mi recomendación sería que utilizaras otro plugin para realizar el multilenguaje de tu web, una solución gratuita como Polylang o una de pago muy extendida como WPML pueden ser mejor solución.

    En qTranslate-X en principio, cuando estás editando el contenido, tienes el conmutador de los idiomas y cuando pulsas en cada pestaña debería aparecerte el contenido de cada una de las versiones, pero imagino que no es así, ¿verdad? Si estás utilizando el editor de bloques y no es totalmente necesario para tu web, probaría instalando el plugin del Editor Clásico, para ver si así sí te funciona y entonces sería un problema de compatibilidad con el nuevo editor.

    Ya nos dices si pruebas esta opción para ver si se arregla o si nos das alguna otra pista sobre el comportamiento no deseado del plugin.

    Gracias! 🙂

    El tema es que con Gutenberg en la parte de atrás estás viendo lo mismo que en la parte pública de la página. Entonces, si tu tema tiene un ancho para el contenido, digamos de 600px, en la parte de atrás lo vas a ver así para que sea la misma experiencia. Si tienes una pantalla grande se va a ver raro, sí, pero al final es como va a ver la gente tu página.

    De todos modos, perfecto el código para modificarlo para la gente que prefiera verlo así! 🙂

    Iniciador del debate Juan Hernando

    (@unintended8)

    Ya, si la recomendación la entiendo y la comparto, pero es un tema llamemoslo de marketing. Imagínate que lanzas una campaña que sea «Tu año feliz» y tienes una landing que es tuweb.com/tu-ano-feliz y lo tienes que imprimir en flyers y demás… (es una exageración del caso). Por eso la pregunta de si es posible evitar que WP lo transforme.

    Iniciador del debate Juan Hernando

    (@unintended8)

    Gracias chicos, le echaré un ojo a la opción de Pablo, aunque no tengo mucha experiencia llamando directamente a la base de datos. Lo estudiaré con calma 😉

    Iniciador del debate Juan Hernando

    (@unintended8)

    El tema es que el ‘relation’ sólo es válido dentro del array tax_query que mira categorías, etiquetas u otras taxonomías. Me valdría para posts que estuvieran en la categoría X o con la etiqueta Y, pero el autor es otro tipo de parámetro que no encaja ahí, por eso la solución que encontré. Más que nada era por si alguno se había encontrado algo similar, ¡gracias de todos modos Carlos!

    Sí, sin problema, sólo tienes que decirle a la «subcategoría de subcategoría» que su padre es la «subcategoría principal».

Viendo 15 respuestas - de la 1 a la 15 (de un total de 34)