Breeze – WordPress Cache Plugin

Descripción

Breeze es un plugin de almacenamiento en caché de WordPress gratuito, simple (pero potente) y fácil de usar, desarrollado por el equipo de Cloudways. Ofrece varias opciones para optimizar el rendimiento de WordPress en varios niveles. Funciona igualmente bien con WordPress, WordPress con WooCommerce y WordPress Multisite.

Breeze sobresale en las siguientes áreas:

  • Rendimiento: Breeze mejora la velocidad del web y la optimización de recursos. Otras características incluyen sistema de caché a nivel de archivos, limpieza de bases de datos, minimización, soporte para caché de Varnish y opciones de integración CDN simplificadas.

  • Comodidad: Breeze es fácil de instalar y configurar directamente desde WordPress. Configurar Breeze es fácil y la mayoría de las opciones por defecto funcionan bien desde el primer momento. Los ajustes recomendados deberían funcionar en todos tus webs WordPress sin problemas.

  • Simplicidad: Breeze está diseñado para ser sencillo para todos los usuarios. Simplemente instala y activa el plugin y verás los resultados instantáneamente.

Lo que hace que Breeze WordPress Cache Plugin sea increíble es que viene con compatibilidad incorporada para Varnish. Si Varnish no está instalado en tus servidores, Breeze utilizará su mecanismo de caché interno para mejorar el rendimiento de tu sitio de WordPress.

FEATURES

  • Seamless integration with Varnish Cache for efficient content delivery. No manual adjustments needed – all settings come pre-configured for your convenience.
  • Optimize performance using Cloudflare’s caching capabilities. No specific Breeze configurations are needed – it works out of the box.
  • Effortlessly integrate your preferred Content Delivery Network (CDN) for global content distribution with Breeze instead of using the the CDN providers’ plugins.
  • Trim WordPress database bloat effortlessly. Breeze’s Database Options optimize and declutter your database, boosting performance by removing unneeded data like post revisions and trashed content.
  • Take command over caching exclusions. With Breeze, you have the power to prevent specific URLs, JS files, and CSS files from being cached.
  • Achieve smaller page sizes and faster load times through HTML, CSS, and JavaScript minification, including inline CSS and JavaScript minification.
  • Load images when they’re visible, not all at once, for faster webpage performance by implementing lazy loading for images.
  • Load JS files with deferred loading, enhancing overall performance.
  • Supercharge your site’s speed with Breeze’s advanced preloading features: load fonts early, quicken link clicks, and enhance DNS requests for a seamless user experience.
  • Master real-time interactions with Breeze’s Heartbeat API management. Fine-tune notifications, sales data, autosaves, and more to optimize WordPress performance by adjusting API call frequencies.
  • Effortlessly manage Breeze settings using Import/Export. Download your configurations as a .json file for backup, or effortlessly import existing settings to quickly fine-tune your optimization.

Soporte: ¡Nos encanta proporcionar soporte! Publica tus preguntas en los foros de soporte de WordPress.org o, si eres cliente de Cloudways, puedes preguntar en el foro de la comunidad de Cloudways.

Requerimientos

PHP 7.4, PHP 8 recomendado para un mejor rendimiento, WordPress 6.0+

Instalación

Para instalar el plugin a través del escritorio de WordPress:

  • En el panel de administrador de WordPress, navega hasta Plugin y Añadir nuevo
  • Búsqueda de Breeze
  • Haz clic en instalar y espera a que la instalación termine. Después pulsa el enlace de activación.

Para instalar el plugin manualmente:

  • Descarga y descomprime el paquete del plugin – breeze.1.0.0.zip
  • Sube Breeze a /wp-content/plugins/
  • Activa el plugin a través del menú «Plugins» en WordPress
  • Accede a Breeze desde WordPress Admin – Ajustes – Breeze

FAQ

Instrucciones de instalación

Para instalar el plugin a través del escritorio de WordPress
1. En el panel de administración de WordPress, ve a «Menú > Plugins > Añadir nuevo»
2. Busca Breeze
3. Haz clic en «Instalar» y espera a que finalice la instalación. Luego, haz clic en el enlace de activación

Para instalar el plugin manualmente
1. Descarga y descomprime el paquete del plugin: breeze.1.0.0.zip
2. Sube el archivo /breeze a /wp-content/plugins/
3. Activa el plugin a través del menú «Plugins» en WordPress
4. Accede a Breeze desde WordPress Admin – Ajustes – Breeze

¿Breeze es compatible con Varnish? ¿En qué medida?

Breeze, por defecto, es compatible con Varnish. Se ha probado que es totalmente compatible con los servidores Cloudways que vienen con Varnish preinstalado. Si estás utilizando proveedores de alojamiento que no sean Cloudways, te sugerimos que confirmes el soporte de Varnish con tu proveedor de alojamiento.

¿Breeze es compatible con WooCommerce?

Breeze es totalmente compatible con Woocommerce, además no requiere ninguna configuración especial.

¿Breeze es compatible con WordPress multisitio?

Breeze es totalmente compatible con WordPress multisitio sin necesidad de ninguna configuración adicional.

¿Cómo gestiona Breeze los multisitios de WordPress?

Breeze gestiona todas las instancias de WordPress multisitio globalmente. Ahora, todos los ajustes de multisitios se gestionan a nivel de red.

¿Es Breeze compatible con otros plugins de caché de WordPress?

NO recomendamos el uso de dos plugins de caché para WordPress al mismo tiempo en cualquier web WordPress.
Recomendamos que uses Breeze como el único plugin de caché para tu web. Si hay cualquier otro plugin de caché instalado, asegúrate de que lo has desactivado antes de proceder con la instalación de Breeze.

¿Breeze es compatible con HTTPS?

Breeze no requiere ningun ajuste especial para trabajar con páginas HTTP o HTTPS.

¿Tiene Breeze problemas de compatibilidad con otros plugins conocidos?

Breeze ha sido probado con los plugins más populares disponibles en WordPress.org. Siéntete libre de informar de cualquier incompatibilidad en el foro de Soporte de WordPress o en el Foro de Comunidad de Cloudways.

¿Breeze es compatible con CDN?

Breeze es compatible con integración con CDN. También permite que todos los elementos estáticos (como imágenes y ficheros CSS y JS) sean servidos mediante la CDN.

¿Qué hace la característica de optimización de la base de datos de Breeze?

Las bases de datos de WordPress son conocidas por almacenar información como revisiones de entradas, comentarios de spam y mucho más. Con el tiempo, las bases de datos se sobrecargan y es una buena práctica vaciar la información no deseada para reducir el tamaño de la base de datos y mejorar la optimización.

La optimización de base de datos de Breeze limpia información innecesaria de un solo clic.

¿Aparecerán inmediatamente los comentarios y otras partes dinámicas de mi blog?

Los comentarios aparecerán con moderación según el sistema (o política) de comentarios establecido por el propietario del blog. Otros cambios dinámicos, como cualquier modificación en los archivos, necesitarán una purga completa de la caché.

¿Puedo excluir las URL de archivos y páginas individuales de la caché?

Puedes excluir un archivo mencionando su URL o el tipo de archivo (mencionando la extensión del archivo) en los campos de exclusión (disponible en la configuración de Breeze). Excluir no dejará que la caché impacte en esa URL o tipo de archivo.

Si Varnish está activo, necesitarás excluir URLs y tipos de fichero en la configuración de Varnish. Si estás alojando tus sitios WordPress en los servidores de CloudWays sigue este artículo para excluir URLs de la cache de Varnish .

¿Funciona con todos los proveedores de alojamiento?

Breeze ha sido probado para funcionar con los principales proveedores de alojamiento. Además, las principales opciones de Breeze, como Gzip, la caché del navegador, la minimización, la agrupación y la optimización de la base de datos. La integración de CDN funcionará como se esperaba en todos los proveedores de alojamiento.

¿Dónde puedo obtener soporte para Breeze?

Puedes obtener respuestas a tus preguntas en los foros de soporte de WordPress. Si eres cliente de Cloudways, por favor, no dudes en iniciar un debate en el foro de la comunidad de Cloudways.

¿Cómo puedo probar y verificar los resultados?

Podrás ver el impacto del plugin de caché de Breeze casi de inmediato. También recomendamos utilizar las siguientes herramientas para generar métricas:
Google Page Speed
WebPagetest
Pingdom

¿El plugin Breeze funciona con Visual Builder?

Sí, el plugin Breeze es compatible con Visual Builder.

¿Qué CDN populares son compatibles con el plugin Breeze?

Breeze es compatible con las siguientes tres CDN populares:
MaxCDN
KeyCDN
Amazon Cloudfront

¿Breeze es compatible con Push CDN?

No, Breeze no es compatible con Push CDN. Sin embargo, puedes utilizar Breeze con Push CDN utilizando plugins de terceros.

¿Breeze funciona con CloudFlare?

Sí. El proceso de configuración de CloudFlare con Breeze es sencillo. Consulta el siguiente artículo de la base de conocimiento para obtener más detalles.

¿Cómo Breeze Cache usa Gzip?

Con Gzip, Breeze comprime los archivos de solicitud, lo que reduce aún más el tamaño de los archivos de descarga y acelera la experiencia del usuario.

Reseñas

13 de enero de 2024 1 respuesta
I recently tried using the Breeze plugin for a multisite setup and was thoroughly disappointed. Here's why I'm giving it a one-star rating: Lack of Optimization for Multisites: The plugin falls short in efficiently handling multisite networks. This deficiency significantly hinders its utility in environments where multisite functionality is a core requirement. Display Notices to Unauthorized Users: Breeze exhibits a concerning flaw by displaying notices to users who should not have authorization to view them. This not only poses a security risk but also leads to confusion among users who do not have administrative privileges. Poor and Unprofessional Support: The support team's response to issues was far from satisfactory. Their approach was unprofessional and lacked the necessary expertise to resolve even basic problems. This lack of competent support further exacerbates the plugin's shortcomings. In conclusion, I cannot recommend Breeze, especially for those managing multisite networks. The plugin's current state, coupled with inadequate support, makes it a liability rather than an asset. I hope the developers take this feedback seriously and make the necessary improvements.
23 de diciembre de 2023 1 respuesta
The plugin was very pleased!Simple, understandable, without excesses. 100% performs the declared functionality!
9 de diciembre de 2023 1 respuesta
It's frustrating to keep seeing the same permissions error repeatedly, not just one website, but multiple websites! And it always alarmed the clients. After fixing it by deleting the plugin and reinstalling it, the error will reappear a few months down the road. Like seriously, I cannot be doing this every single time! Get better devs to work on this plugin.
Leer todas las 101 reseñas

Colaboradores y desarrolladores

«Breeze – WordPress Cache Plugin» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«Breeze – WordPress Cache Plugin» ha sido traducido a 9 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «Breeze – WordPress Cache Plugin» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

= 2.1.4=

  • Fix: Addressed a vulnerability discovered by CovertSwarm.
  • Fix: Limited the thank-you message display to admin and super admin users after activating Breeze.
  • Fix: Resolved file permission warning issues in the multisite network, ensuring seamless operation when adding a new subsite.
  • Fix: Modified the Mobile Detect PHP Namespace in the third-party library to prevent conflicts with other plugins or themes, improving overall compatibility.
  • Fix: Ignored images with both JSON and JSON encryption to prevent adverse effects on other libraries handling those tags, ensuring smooth functionality.
  • Fix: Separated lazy load functionality for videos and iframes, providing increased control over website lazy loading behavior for a more optimized user experience.
  • Add: Implemented distinct functionality for tags specifically with the ‘src’ attribute, excluding video tags with tags, enhancing flexibility and control over video elements.

= 2.1.3=

  • Fix: Functionality is improved to handle cases where no «HTTP_USER_AGENT» header is sent.

= 2.1.2=

  • Fix: Enhanced the conditions of device-based caching for users on the Cloudways Autoscale Platform.

= 2.1.1=

  • Fix: Resolve issue of Breeze plugin directory location.

= 2.1.0=

  • Add: Device-based caching for desktops, tablets, and mobile devices.
  • Add: WordPress REST API Integration for cache purging.
  • Add: Ability to set authentication key for REST API integration.

= 2.0.33=

  • Fix: Breeze plugin is now fully compatible with PHP 8.2 as all the compatibility issues are solved.
  • Fix: Lazy load option is enhanced to ensure compatibility with diverse themes and avoid image or video loading conflicts.
  • Fix: Host font locally option is improved to handle special characters effectively, enhancing font display.
  • Fix: WooCommerce cart caching is prevented when the preload option is enabled, preventing unwanted cart data caching.

= 2.0.32=

  • Add: Now users can exclude their custom HTTP headers from caching when HTML minification is on. Simply pass your custom headers through the WP filter ‘breeze_custom_headers_allow’ for a more tailored and dynamic caching experience.
  • Fix: Breeze now seamlessly supports both relative and absolute URL paths for preloading. Say goodbye to errors – and more assets effortlessly with the enhanced Breeze preload feature.

= 2.0.31=

  • Add: Breeze now supports the Aelia Currency Switcher for WooCommerce.
  • Add: Breeze will automatically clear the cache for order products, homepage, and shop page if the «Out of stock visibility» option is enabled and the stock is no longer available.

= 2.0.30=

  • Add: Host Files Locally improve website speed by serving Google Fonts, Google Analytics, Facebook, and Gravatar files directly from your application’s local path.

= 2.0.29=

  • Add: Breeze now supports the latest version of the CSS minified library for superior performance.
  • Add: Preload Link option is enabled by default now to boost your website performance.

= 2.0.28=

  • Add: JavaScript file deferred loading feature now supports external third-party files alongside WP Core, themes, and plugins files.

= 2.0.27=

  • Add: Installing and activating Breeze using WP CLI will now automatically add GZIP compression and browser cache rules to the .htaccess file. Similarly, deactivating and deleting Breeze using WP CLI will remove these rules from the .htaccess file.

= 2.0.26=

  • Fix: The issue caused by CLI plugin update, resolving error related to WP_Upgrader_Skin class requirement removal.

= 2.0.25=

  • Fix: Purging the cache from Breeze for WordPress Multisite applications will not purge the OCP cache.

= 2.0.24=

  • Fix: Handling of the ‘WP_Upgrader_Skin’ class for seamless update functionality via wp-cli.

= 2.0.23=

  • Add: Smart Cache Purge Configuration for Cloudflare is now available for Flexible Platform for Cloudways users.
  • Add: Environment detection is now available for Cloudways users to automatically detect the platform, e.g., Flexible or Autoscale.
  • Add: Filters are added to interact with the content buffer before cache files are created. Use a filter called «breeze_cache_buffer_before_processing» to interact with buffer content before performing any changes and «breeze_cache_buffer_after_processing» after markup changes are finished.

= 2.0.22=

  • Fix: Issues with Lazy Load and Cross-origin have been fixed by rewriting the engine to avoid interfering with bad markup.

= 2.0.21=

  • Add: Moved the Cloudflare Cache option to Purge Modules for Cloudways users only.
  • Add: Purge Varnish option will not be shown if varnish header not available.

= 2.0.20=

  • Fix: Fatal error displayed while editing WooCommerce attributes and other entities.

= 2.0.19=

  • Fix: Purge All Cache permalink for WordPress subdirectory installations.

= 2.0.18=

  • Add: Integrated Cloudflare Cache in Breeze for Cloudways users only.
  • Add: s-maxage in cache-control of Response Headers.
  • Fix: Stopped purging the OCP cache while cache purging from Breeze.
  • Fix: Improved compatibility of Breeze with Woodmart theme.
  • Fix: Improved compatibility of Breeze with Buddyboss theme.
  • Fix: Preserving declared media for styles on combine CSS.

= 2.0.17=

  • Fix: P-Tag will not be added when Lazy Load Images and Cross-Origin Safe Links are enabled.

= 2.0.16=

  • Fix: Ninja Forms now works when Lazy Load Images and Cross-Origin Safe Links are enabled.
  • Fix: All types of Google Tag Manager scripts will work with the «Delay JS Inline Scripts» option.
  • Add: «Reset Now» option has been added for default settings. It can also operate with WP-CLI.
  • Add: Enabled «Combine JS» option will disable «Delay JS Inline Script» or «Delay All JavaScript» and vice versa.

= 2.0.15=

  • Add: Internal cache Purge while changing Theme.
  • Add: Internal cache Purge while using the options WP Customizer.
  • Fix: Improvise handling of Optimize Database option under the Database Options Tab by adding a message and loading bar.
  • Fix: Improvise the handling of the Request header while Varnish proxy behind and re-download necessary.

= 2.0.14=

  • Fix: Applied condition to look new Facebook feed link in the plugin Facebook for WooCommerce.

= 2.0.13=

  • Fix: DOMDocument class was removed while enabling the options Lazy Load Images and Cross-origin Safe Links.

= 2.0.12=

  • Fix: Synchronized the reset cache option of the Avada theme with Breeze.

= 2.0.11=

  • Add: Scanning of CDN URL to verify it is not malicious in the CDN.
  • Fix: Improvised process of generating JS files from PHP files.
  • Fix: Improvised handling of multi-byte characters, languages, symbols such as Unicode icons, etc.
  • Fix: Improvised the functionality of the Defer option while using an external JS file.
  • Fix: Enhanced the compatibility with Weglot Translate.

= 2.0.10=

  • Add: More options added in the Database option tab.
  • Add: Display Autoload summary with Autoload total size as well as Autoload count.
  • Fix: Enhance the functionality of the options Combine CSS and Inline CSS while CSS is generated by Elementor.
  • Fix: Overwrite the TimeZone To UTC being sent out in ticket/order confirmations of The Events Calendar plugin.

= 2.0.9=

  • Fix: Added nonce check to import settings ajax request, in order to improve security and prevent cross-site requests.

= 2.0.8=

  • Fix: Enhance compatibility with the Pickingpal plugin to load the orders.
  • Fix: Remove duplication header calls in Varnish requests.
  • Fix: Invalid Certificate never accepted and its default value is TRUE now.
  • Add: Include the option to Clear Object Cache.

2.0.7

  • Fix: In some cases call to undefined function is_plugin_active() shows, it is fixed now by replacing it with a check for class_exist in CURCY and WOOCS plugins.

2.0.6

  • Fix: Overwrites the TimeZone To UTC of The Events Calendar plugin.
  • Fix: currency menu is cached with HTML, changing it with the currency is difficult in CURCY and WOOCS plugins.
  • Fix: Preloading links that do not have “href“ attribute or the “href“ attribute contains the value “#” was displaying errors in the console log.
  • Fix: Some inline javascript files were not displayed when the option «JS Files With Deferred Loading» had at least one value-added breaking functionality for other JavaScript scripts.

2.0.5

  • Add: UI improvement to provide better accessibility and user experience.

2.0.4

  • Add: Improve page load by delaying JavaScript execution. Delay JS is disabled by default for new installations.
  • Fix: Added JavaScript checks to see if the sortable library is loaded or not, if not then the JS code that requires the library will not execute.
  • Fix: Undefined variable in Breeze minification scripts.

2.0.3

  • Fix:All ajax actions are now restricted to the users that have manage_options capabilities. Vulnerability discovered from patchstack team.
  • Fix: Administrator has only capable to handle manage_options by default.
  • Fix: Added restriction to option-tabs-loader.php, if the user does not have manage_options capability, then the tabs will not load.

2.0.2

  • Fix: Atarim – Client Interface Plugin conflict with UI of Breeze in the admin area.
  • Add: Make LazyLoad for iframes compatible
  • Add: Control WordPress Heartbeat API. Users can disable it, independently on the admin, post editor page, and frontend.
  • Add: DNS prefetch on pages.
  • Add: Improve the handling of warning message while permission is not correct.

2.0.1

  • Fix: Improved handling of minification in Never Cache URL(s) option.

2.0.0

  • Add: Implement a new UI interface.
  • Fix: Duplicate script while using the option Move JS Files to Footer.
  • Fix: Improvise the optimization of WordPress core functions to clean the database correctly.
  • Fix: Implement condition in .htaccess rules while disable «mod_env”.
  • Fix: Compatibility issue with Facebook For WooCommerce plugin.

1.2.6

  • Add: Varnish cache will be clear while plugin deactivate.
  • Add: Enable cache for specific user role.
  • Add: Disable Emojis to reduce request
  • Add: Delete breeze options values from database on plugin deletion.
  • Fix: Compatibility issue of map short codes with GeoDirectory plugin.
  • Fix: Compatibility issue with Ad Inserter plugin.
  • Fix: Compatibility issue of minification with Beaver Builder Plugin.
  • Fix: Compatibility issue of JS scripts with AMP Plugin.
  • Fix: Reduce cookie life time span while user posts a comment.
  • Fix: HTML elements filtered from RestAPI end point of lazy-load scripts.
  • Fix: Config file of each subsite save with appropriate ID in advance cache file.
  • Fix: Google Analytics script exclude from Minification.

1.2.5

  • Añadido: Las URL que contienen cadenas de consulta no se almacenarán en caché por defecto.
  • Añadido: Ignora cadenas de consulta específicas mientras sirve el caché para mejorar el rendimiento.
  • Añadido: Capacidad de almacenar en caché las URL con variables de cadenas de consulta específicas.
  • Añadido: Manejo de caché de URL que tienen múltiples parámetros en una cadena de consulta.
  • Añadido: Manejo de caché excepcional para el caso en el que el enlace permanente se establece en SENCILLO, que incluye enlaces para ENTRADAS, PÁGINAS, ADJUNTOS, CATEGORÍAS, ARCHIVOS.

1.2.4

  • Añadido: Funcionalidad para vaciar TODO el caché a través de la interfaz de línea de comandos (wp-cli).
  • Añadido: Funcionalidad para vaciar el caché de Varnish a través de la interfaz de línea de comandos (wp-cli).
  • Añadido: Funcionalidad para vaciar el caché interno a través de la interfaz de línea de comandos (wp-cli).
  • Añadido: Si bien el permiso del archivo no es correcto, se ha añadido el mensaje de advertencia.
  • Corregido: Compatibilidad con la página Próximamente, el Modo de mantenimiento Páginas de destino de SeedProd.
  • Corregido: Mejora el manejo de la clave array indefinida de advertencia del script JS de retraso mientras se activa el modo de depuración.

1.2.3

  • Añadido: Adición en las reglas de activos de medios para objetos que se pueden almacenar en caché del navegador.
  • Añadido: Adición en las reglas de recursos de fuentes para el objeto almacenable en caché del navegador.
  • Añadido: Adición en las reglas de intercambio de datos para los objetos que se pueden almacenar en caché del navegador.
  • Añadido: Adición en las reglas de archivos de manifiesto para el objeto almacenable en caché del navegador.
  • Añadido: Adición en las reglas de compresión Gzip.
  • Corregido: Improvisa el manejo de la cabecera de la solicitud mientras Varnish está desactivado
  • Corregido: Improvisa la condición de la opción «Activar caché para usuarios registrados»

1.2.2

  • Añadido: Ajustes de exportación a través de la interfaz de línea de comandos (wp-cli).
  • Añadido: Importa ajustes a través de la interfaz de línea de comandos (wp-cli).

1.2.1

  • Corregido: Mejora el manejo del índice indefinido de advertencia de la imagen de carga diferida mientras activas el modo de depuración.
  • Añadido: Opción de activar/desactivar de los scripts en línea JS de Delay.

1.2.0

  • Añadido: Etiqueta de atributos «noreferrer noopener» en enlaces externos cuando procese HTML para el almacenamiento en caché.
  • Añadido: Las fuentes precargadas permiten que el texto permanezca visible durante la carga de la fuente web.
  • Añadido: Solicitud de clave de precarga de fuentes o archivo CSS que cargan fuentes desde el recurso local.
  • Añadido: Los enlaces de precarga permiten activar la precarga de la siguiente página de la aplicación.
  • Añadido: La carga diferida muestra imágenes en una página solo cuando son visibles para el usuario.
  • Añadido: Minimiza el impacto del código de terceros.

1.1.11

  • Corregido: Manejo mejorado de formularios usando nonce en las páginas Enlaces permanente y Opciones.

1.1.10

  • Corregido: Aplica la carga diferida en un archivo individual.
  • Corregido: Excluye la URL del feed generada por el plugin «Facebook para WooCommerce».
  • Corregido: Purgar el caché del sitio en la subcarpeta.
  • Corregido: Las existencias de inventario ahora se actualizan en la página del carrito.
  • Corregido: Soporte mejorado para la nueva versión del plugin WooCommerce Booking Calendar
  • Añadido: Compatible con los plugins EDD y cartflow.
  • Añadido: Las páginas que incluyen shortcode han sido excluidas por Breeze.

1.1.9

Añadido: Manejo mejorado de la minimización para la Exclusión basada en cadenas de consulta en la opción Nunca almacenar en caché estas URL.
Añadido: Aumenta la compatibilidad con Multilingual.

1.1.8

  • Fix: Cache refresh issue when Varnish is disabled.
  • Fix: Replaced functions deprecated in WordPress 5.5 that were causing warning messages.
  • Fix: Replaced deprecated minification libraries to improve compatibility with PHP 7.x onward.
  • Fix: resolved the warning generated by the Query Monitor plugin.
  • Add: compatibility with PHP 7.4

1.1.7

  • Fix: Add HTTP and HTTPS for validation of CDN integration.
  • Fix: Custom settings for multisite will be reapplied after Breeze reactivation.
  • Fix: General improvements to improve support for the WooCommerce Booking Calendar plugin.
  • Fix: Improved handling of minification for Wildcard based exclusion in Never Cache These URLs option.

1.1.6

  • Add: Wildcard (.*) based exclusion of pattern URL strings in Never Cache These URLs option.
  • Fix: Improved validation for CDN integration.
  • Fix: General improvements to support for Elementor Forms/Elementor Pro and CDN integration.

1.1.5

  • Fix: Revised duration for browser cacheable objects

1.1.4

  • Fix: PHP Fatal error while running commands through WP_CLI

1.1.3

  • Fix: Undefine error for inline JS when JS Group file is enabled.
  • Fix: Several files displayed when Group Files was enabled.
  • Fix: Varnish auto purge slowed down admin area while varnish is not running.
  • Fix: PDF files are not downloadable with CDN enabled.
  • Fix: miscellaneous UI issues.
  • Add: The Google Analytics script/tag is now excluded form Minification.
  • Add: Option to enable cache for admin user.
  • Add: Handling of 404 error of JS/CSS/HTML when cache files are not writeable.
  • Add: Exclude @import directive from CSS Minification.

1.1.2

  • Fix: Improved handling of exclusion of CSS and JS while Minification and Group Files options are enabled.
  • Fix: Allow wildcard (.*) based exclusion of pattern files/URIs in exclude JS and exclude CSS fields.
  • Fix: Increase the duration for leverage browser cacheable objects

1.1.1

  • Fix: Removed the use of remote JS. Now uses built-in version of jQuery Libraries.

1.1.0

  • Add: Optional separate cache settings for subsites.

1.0.13

  • Fix: Validation of nonce.
  • Fix: Remove duplication of calls in Varnish purge requests.

1.0.12

  • Fix: Deprecated create_function

1.0.11

  • Fix: Change wp_redirect to wp_safe_redirect to fix redirect vulnerability of URL

1.0.10

  • Add: Allow Purge Cache for Editors role.

1.0.9

  • Add: Option to move JS file to footer during minification
  • Add: Option to deffer loading for JS files
  • Add: Option to include inline CSS
  • Add: Option to include inline JS

1.0.8

  • Fix: Cache exclusion for pages that returns status code other than 200

1.0.7

  • Fix: Grouping and Minification issues for PHP 7.1
  • Fix: Cache purge after version update issue
  • Fix: Increase in cache file size issue.
  • Fix: Server not found error notification
  • Fix: Default WP comments display not require cache purge

1.0.6

  • Fix: All Multisite are now handled globally with settings being handled at network level

1.0.5

  • Fix: Issue with JS minification

1.0.4

  • Fix: Browser Cache issues with WooCommerce session
  • Fix: Clearing Breeze rules from .htaccess upon deactivating of GZIP/Broswer Cache
  • Fix: Regex fix for accepting source url’s without quotes while enabling minifcation
  • Add: FAQ section added

1.0.3-beta

  • Arreglado : Desactivada la caché de navegador en las páginas de WooCommerce de carrito, tienda y cuenta.
  • Arreglado : Eliminación de htaccess cuando se desactivan las opciones de caché de navegador o compresión gzip
  • Arreglado : Problemas con la CDN que no servía tdos los contenidos configurados en el servicio de la CDN

1.0.2-beta

  • Arreglado : Problemas de compatibilidad con WooCommerce

1.0.1-beta

  • Fix : Purging issue to allow only admin users to Purge
  • Añadido : enlace de Feedback

1.0.0

  • Añadir : Primera beta liberada