WordPress.org

Plugin Directory

Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others

Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others

Descripción

Photonic toma la galería de WordPress y la sobrecarga con una gran cantidad de funciones adicionales. Añade compatibilidad con varias fuentes y parámetros nuevos para mejorar el contenido y la apariencia de tus galerías. Es compatible con fotos de Flickr, álbumes (photosets), galerías y colecciones, junto con fotos y álbumes de Google Photos, carpetas de SmugMug, álbumes e imágenes, y fotos de Zenfolio, photosets y grupos. También puedes configurar la identificación para que los visitantes puedan ver fotos privadas y protegidas de cada proveedor.

Cuando se utiliza sin el editor de Gutenberg, Photonic por defecto anula el shortcode gallery. En caso de que estés usando un tema o plugin que anule el shortcode gallery, Photonic te ofrece la opción de usar tu propio shortcode para las galerías Photonic. Esto permite que tus plugins puedan convivir. Ten en cuenta que si desactivas Photonic, tendrás que eliminar todas las instancias de este shortcode personalizado, algo que no es necesario si mantienes el shortcode gallery.

Cuando se utiliza con Gutenberg, Photonic no crea shortcodes, sino que crea bloques. Si algunas de tus entradas se escribieron con Gutenberg y otras no, Photonic es compatible con ambos escenarios.

Caja de luz

De todos los plugins o de pago, Photonic es compatible con la mayor cantidad de scripts de caja de luz. Esto incluye scripts que se ejecutan en JavaScript puro sin depender de bibliotecas externas o aquellos que requieren jQuery.

Bibliotecas JS puras

Bibliotecas basadas en jQuery

Bibliotecas obsoletas

  • Fancybox 1 – ninguna actualización desde noviembre de 2010
  • Magnific Popup – ninguna actualización desde febrero de 2016
  • PrettyPhoto – ninguna actualización desde mayo de 2015

Para las alternativas que no son GPL como Fancybox2 y las bibliotecas obsoletas, Photonic tiene un código para trabajar con ellas, pero debes instalar los scripts tu mismo. o confíar en ellos desde tu tema u otro plugin.

Con la excepción de Thickbox, las cajas de luz se han adaptado para que sean táctiles y gestuales. Consulta la página de Lightboxes para obtener más información.

Compatibilidad con varias plataformas

Flickr

Los siguientes conceptos de flickr son compatibles con Photonic:

Para ver las demostraciones de soporte de Flickr, visite la pagina de Flickr .

Google Fotos

Los siguientes conceptos de Google Fotos son compatibles con Photonic:

Para ver las demostraciones que son compatibles con Google Photos, visita la página de Google Photos.

SmugMug

Los siguientes conceptos de SmugMug son compatible con Photonic:

Para ver las demostraciones que son compatibles con SmugMug, visita la página de SmugMug.

Zenfolio

Los siguientes conceptos de Zenfolio son compatible con Photonic:

Para ver las demostraciones que son compatibles con Zenfolio, visita la página de Zenfolio.

Instagram

A mediados de septiembre de 2022, Meta / Facebook / Instagram cambió sus reglas para impedir que los desarrolladores individuales (es decir, los desarrolladores que no operan como una empresa) utilicen de manera significativa su API. Como resultado, Photonic ya no funciona con fotos de Instagram. Sin embargo, el código todavía está vigente y puede ser utilizado por cualquier persona con una empresa que desee adoptarlo.

Galerías nativas de WordPress

Tus galerías existentes se dejan intactas. Sin embargo, puedes añadir un parámetro style a una galería nativa para abrirla en Photonic. El parámetro style puede tomar cualquiera de los valores documentados en la página de diseños.

Otros bienes de Photonic

Asistente de galería

El editor clásico de WordPress aparece con un botón que dice «Añadir / Editar galería Photonic». Al hacer clic en él, se inicia un asistente que te ayuda a crear una galería de forma interactiva con solo unos pocos clics.

Es compatible con Gutenberg

También se puede acceder al asistente de galería a través de Gutenberg / el Editor de bloques. Mientras creas un bloque, busca Photonic. Por favor, consulta la documentación.

Compatibilidad para vídeo

Photonic ofrece ser compatible con galerías y lightbox para videos también . Videos de los siguientes tipos son compatibles:

  • Se pueden abrir vídeos externos de YouTube o Vimeo en cualquiera de las cajas de luz, además de Image Lightbox, Thickbox o BaguetteBox
  • Los videos autohospedados o externos en formatos MP4 se pueden abrir en cualquiera de las cajas de luz, excepto Image Lightbox, PrettyPhoto, Strip o Thickbox.
  • Los vídeos alojados por proveedores de servicios externos (Flickr, Google, etc.) se pueden abrir como parte de una galería en cualquiera de las cajas de luz, además de Image Lightbox, PrettyPhoto, Strip o Thickbox. Algunas cajas de luz tienen problemas con características específicas. Por favor, consulta la documentación de Lightboxes para más información.

Enlaces profundos y compartir en redes sociales

Photonic proporciona compatibilidad de enlace profundo para imágenes que no son de WP, y por extensión, admite compartir socialmente con Facebook, Twitter, Google+ y Pinterest.

Hermosos diseños

Photonic muestra tus galerías en múltiples formas:

  • Una cuadrícula de miniaturas cuadradas (el valor por defecto)
  • Una cuadrícula de miniaturas circulares (como Jetpack)
  • Una cuadrícula justificada y ordenada
  • Una estructura de muro
  • Un mosaico aleatorio en celda (una variante muy mejorada del diseño de la galería en celda de Jetpack)
  • Una presentación de diapositivas, usando el script Splide

Consulta la página de documentación de Layouts para obtener detalles y ejemplos.

Obsessively Comprehensive Documentation (OCD)

La documentación de Photonic es exhaustiva hasta el punto de la obsesión. Y, sin embargo, si encuentras algo que falta, por favor, no dudes en ponerte en contacto a través del foro de soporte.

Capturas

  • Si estás utilizando Gutenberg, busca el bloque «Photonic».
  • Si no estás utilizando Gutenberg, crea el shortcode de Photonic a través del cargador de medios haciendo clic en «Añadir / editar galería Photonic».
  • Al hacer clic en el bloque de Gutenberg o en «Añadir / editar galería Photonic» se muestra un asistente para que puedas crear tu galería.
  • El asistente te muestra las opciones disponibles y te ayuda a construir la galería fácilmente.
  • Si haces clic en «Añadir medios», verás una nueva pestaña para «Photonic». Esto no está disponible para Gutenberg.
  • Al hacer clic en la pestaña «Photonic», se mostrarán nuevas pestañas, una para cada tipo de galería. Completa lo que necesitas y haz clic en «Insertar en la entrada».
  • El marcador de posición de la galería se muestra en el «Editor visual» o en el editor de Gutenberg. El marcador de posición de cada proveedor está designado por su logotipo.
  • Al hacer clic en el marcador de posición, puedes editar los atributos del shortcode si no se utiliza Gutenberg y se desactiva el flujo de trabajo interactivo.
  • Un ejemplo del diseño «Galería justificada aleatoria»

Bloques

Este plugin proporciona 1 bloque.

  • Photonic Gallery

Instalación

Puedes instalar el plugin a través del instalador de WordPress en Plugins → Añadir nuevo buscando «Photonic» o subiendo el archivo descargado desde aquí.

Alternativamente, puedes descargar el archivo desde aquí, descomprimirlo y mover el contenido descomprimido a la carpeta wp-content/plugins de tu instalación de WordPress. Entonces podrás activar el plugin.

Una vez que hayas activado el plugin, consulta Photonic → Cómo empezar para obtener una lista de capacidades y documentación.

FAQ

Si desactivo el plugin, ¿qué sucede con las galerías?

Obviamente, tus galerías no se mostrarán. Si estás utilizando Gutenberg no tienes que preocuparte acerca de nada. Si no estás utilizando Gutenberg y estás utilizando el shortcode nativo gallery, no verás ninguna etiqueta de shortcode abierto en tu sitio. Pero si no estás utilizando Gutenberg y estás usando un shortcode personalizado, esa etiqueta de shortcode ahora se mostrará.

Cuando hago clic en una galería en el Editor Visual no pasa nada. ¿Está funcionando el plugin?

Sí, el plugin está funcionando. Desafortunadamente, la integración de Photonic con el editor visual es compleja, y existe la posibilidad de conflictos con otros plugins específicos de TinyMCE. Si te encuentras con un conflicto así, por favor infórmalo en el foro de dar soporte. Mientras tanto, puedes desactivar la capacidad de edición visual de Photonic (Photonic → Ajustes → Opciones genéricas → Ajustes generico → Desactivar edición de shortcodes en el editor visual) y aún deberías poder editar el shortcode de la galería directamente a través del editor de texto.

El diseño de mi galería parece estar en mal estado con el texto al azar que aparece en varios lugares. ¿Estás seguro de que el plugin está funcionando?

Sí, el plugin está funcionando. El problema al que te enfrentas es que tienes otro plugin (por lo general, un tipo de plugin de caja de luz) que esta modificando el marcado generado por Photonic.

Por supuesto, sería más fácil si desactivas ese plugin. Si lo único que necesitas es una caja de luz, la caja de luz de Photonic también se puede usar para mostrar fotos regulares, desde tu escritorio de administración bajo Photonic → Ajustes → Ajustes genéricos → Ajustes genéricos → Caja de luz de Photonic para imágenes que no son de Photonic. Esto garantizará la coherencia entre las imágenes de Photonic y las que no son de Photonic.

Sin embargo, si realmente deseabas mantener ese plugin, ¡Photonic ofrece una manera de salir también! Para cada proveedor (por ejemplo, Flickr, Picasa, etc.) ves a la página de ajustes, p.ej Photonic → Ajustes → SmugMug → Ajustes de SmugMug → Desactivar el enlace de caja de luz y establece esa opción.

Mi galería de Instagram no funciona. ¿Está realmente seguro de que el plugin está funcionando?

Sí, el plugin funciona, pero Meta no permite que los desarrolladores individuales (es decir, los desarrolladores que no operan como empresa) accedan a su API. Mientras el código de trabajo para Instagram se incluye con el plugin, no podrás usarlo ya que Photonic está creado por un desarrollador individual. Por favor, cambia a un plugin diferente si deseas usar Instagram.

¿Por qué cuesta tanto el proceso de configuración de Google Photos?

¡Culpar a la gran G aquí! La API de Google Photos tiene varias deficiencias, la principal de ellas es la gran cantidad de llamadas a la API necesarias para obtener una galería. Esto ocasionaría que las claves API alcanzaran sus límites de forma rutinaria si se usaran para demasiadas galerías. Esto hace que sea imposible para los desarrolladores identificar a los usuarios usando sus claves API sin registrarse en el programa Partners. Lamentablemente, el diseño de Photonic no es uno de los casos de uso admitidos por el programa Google Partners.

Como resultado claro, para evitar que los usuarios no se bloqueen con la clave API de Photonic, es un requisito desafortunado que los usuarios usen su propia clave. Y aquí es donde Google complica las cosas innecesariamente. La documentación de Photonic es muy completa con instrucciones sobre cómo identificarse, pero eso no cambia el hecho de que el proceso de Google es complicado.

Después de todo el dolor para conseguí que Google Photos funcionara ayer, pero hoy mis galerías no aparecen. ¿Por qué?

Comprueba si tienes un plugin de almacenamiento en caché activo. Si es así, excluye la página con Google Photos del caché. Las URL de Google Photos son de corta duración, por lo tanto, no se pueden almacenar en caché. Este problema no ocurre para otras fuentes.

¿Qué pasa con otras plataformas de intercambio de fotos?

Las sugerencias son bienvenidas para otras plataformas para compartir fotos.

¿Qué pasa con otras bibliotecas de cajas de luz de JS?

¿Quieres decir aparte de los 17 que son compatible actualmente con Photonic? Si tienes sugerencias específicas, por favor, no dudes en ponerte en contacto con el autor del plugin, pero a partir de la versión 2.60, el enfoque se está desplazando hacia las bibliotecas JS de caja de luz puras.

Ten en cuenta que se han realizado ligeras modificaciones en algunas de las cajas de luz para que funcionen bien con el código más nuevo.

¿Hay algún conflicto conocido?

La integración de TinyMCE para el plugin es compleja, sobre todo porque Photonic no depende de un shortcode separado. Esto puede causar conflictos potenciales con otros plugins. Si surge una situación de este tipo, por favor, informar en el Foro de soporte y desactivar la capacidad del editor visual para el shortcode por tipos de publicaciones especificas (Photonic → Ajustes → Opciones genéricas → Ajustes genéricos → Desactivar edición visual para tipos de publicaciones específicas). Si eso no funciona, puedes volverte termonuclear en la edición visual de Photonic (Photonic → Ajustes → Opciones genéricas → Ajustes genéricos → Desactivar la edición de shortcode en el editor visual) – aún podrás editar el shortcode usando el editor de texto en WordPress.

El diseño «Mosaico» puede mostrar a veces un espacio de 1px entre imágenes si ajustas el relleno entre las imágenes a 0. Esto ocurre debido a errores de redondeo en los cálculos de altura y ancho. Para evitar esto, se recomienda utilizar un relleno > 0 entre imágenes para este diseño.

Aparte de éstos, mientras que el plugin pueda manejar casi todo lo que le lances a él, La Ley de Entomología Cibernética de Lubarsky establece:

There is always one more bug.

Los informes de fallos son bienvenidos, y se manejan con entusiasmo.

¿Son compatible las traducciones?

Sí, pero solo para la portada del plugin y el asistente. Las páginas de ajustes no están traducidas en este momento. También, ten en cuenta que cualquier cadena incluida en los scripts JS de terceros no están traducidas.

Reseñas

8 de mayo de 2024
Best gallery for different platforms. Regular updates, good support. I have been using this plugin for smugmug and flickr for many years.
3 de abril de 2024
My blog is primary a photo journal. Having a plugin which does such a good job displaying photos from my flickr collection is essential. This does the job. I can republish changes in Flickr and they are automatically replicated here,
27 de febrero de 2024
Now wait a minute. This plugin basically just worked as advertised, immediately, with a few minutes of clear and minimal setup, and no hairpulling required. And, it’s free, not a come on for «pro» cash grab.Is it still 2024? Is this still Wordpress? Eight stars. Ten stars. Five is not enough. Thank you, developer!
20 de febrero de 2024
Photonic is exactly what I needed. It is easy to use and has lots of variations. Amid a sea of photo gallery plug-ins, Photonic rises to the top, not just because of the awesome variety available but because it is amazingly free as well. I love it.
Leer todas las 184 reseñas

Colaboradores y desarrolladores

«Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others» está traducido en 1 idioma. Gracias a los traductores por sus contribuciones.

Traduce «Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

3.10

  • Añadido: Nueva estructura, «Mosaico horizontal», para ordenar de izquierda a derecha en diseños de mosaico.
  • Añadido: Capacidad para seleccionar más opciones para el título en las galerías de WP.
  • Cambiado: La compatibilidad mínima de la versión PHP aumentó a 6.2.
  • Cambiado: La compatibilidad mínima de la versión PHP aumentó a 7.2.
  • Corregido: Las colecciones de Flickr ampliadas de forma diferida no mostraban miniaturas cuadradas.
  • Corregido: Problema de Zenfolio donde las miniaturas cuadradas no mostraban un tamaño uniforme.
  • Corregido: Las miniaturas de LightGallery no se mostraban en las galerías cargadas de forma diferida.
  • Corregido: Se ha corregido una advertencia específica de PHP 8.1.
  • Cambiado: Se ha eliminado el marcado innecesario (atributos de datos) de las pases de diapositivas.