Este plugin no se ha probado con las últimas 3 versiones mayores de WordPress. Puede que ya no tenga soporte ni lo mantenga nadie, o puede que tenga problemas de compatibilidad cuando se usa con las versiones más recientes de WordPress.

PUZZLER is JS + CSS combine

Descripción

Puzzler – it excellent js/css aggregator for advanced users:

  • Automatically combines all enqueued scripts/styles into a single file, for faster loading blog.
  • Starts immediately without setting.
  • You can adds scripts and styles in queue, change the order, edit – and Puzzler automatically make recombines.

Puzzler – don’t worry be happy.

Require PHP 5.4 or high.

You should remember 3 key rules before using:

Key rule 1

All scripts and styles must include ONLY 1 time and ONLY in 1 place, e.g. in wp_enqueue_scripts hook

Key rule 2

Styles(css) aggregation perform only for media=’all’ ( without alternative stylesheets, titles, conditionals )

Key rule 3

Avoid register/enqueue scripts/styles in conditional expressions
add_action(‘wp_enqueue_scripts’, ‘my_enqueue_scripts’);
function my_enqueue_scripts() {

  // -- don't do it !
  if ( is_single() || is_page() ) { 
      wp_enqueue_script('myscript');
  }

  // -- correct !
  wp_enqueue_script('myscript');

}

Funcionalidades

  • Auto detect files change
  • Autocorrect internal links in the CSS after aggregation ( url/src )
  • Auto +20 scores in Google PageSpeed Insights
  • Async/lazy load aggregated scripts/styles
  • Windows compatible

Capturas

  • Puzzler settings

Instalación

  1. Make sure PHP version is 5.4 or high.
  2. Create in your wp-content directory, cache folder with 0777 permissions
  3. Upload the plugin files to the plugins/puzzler directory, or install the plugin through the WordPress plugins screen directly.
  4. Activate the plugin through the ‘Plugins’ screen in WordPress
  5. You can configure plugin through «Puzzler» item in main admin menu

FAQ

None FAQs

Reseñas

3 de septiembre de 2016
interested, all scripts&styles (include themes+plugins) must enqueued only in wp_enqueue_scripts(). in this case - working perfectly, else - can be crash)
3 de septiembre de 2016
This plugin completely broke my site. My server fulfills the requirements but changing any settings of the plugin didn't help at all but at least after deactivating it everything was back to normal. What a relief. I took a look at the compressed files it genereated and already saw that this would not work without bothering to look into details. Also: I'm pretty sure relying on a cache folder with CHMOD 777 is bad practice.
Leer todas las 4 reseñas

Colaboradores y desarrolladores

«PUZZLER is JS + CSS combine» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

Traduce «PUZZLER is JS + CSS combine» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.0

  • First version