TinyMCE Advanced

Descripción

Este plugin te permitirá añadir, quitar y mover los botones a mostrar en la barra de herramientas del editor visual. Puedes configurar hasta cuatro filas de botones incluidos tamaños de fuente, familia de fuente, colores de texto y fondo, tablas, etc. También te permitirá activar el menú del editor, echa un vistazo a las capturas de pantalla.

Incluye 15 plugins para TinyMCE que se activan o desactivan automáticamente dependiendo de los botones que hayas elegido. Además este plugin añade algunas de las opciones más utilizadas, como las etiquetas de párrafo en el editor de texto y la importación de clases CSS de editor-style.css del tema.

Algunas de las características añadidas por este plugin

  • Compatible con la creación y modificación de tablas.
  • Más opciones al insertar listas.
  • Buscar y reemplazar en el editor.
  • Posibilidad de elegir la familia de fuentes y tamaños de fuente.
  • Y muchos otros.

Con este plugin también puedes activar el menú TinyMCE por encima de las barras de herramientas.
Esto hará que el editor sea aún más potente y útil.

Privacidad

TinyMCE Advanced no recopila ni almacena ningún dato relacionado con el usuario. No instala cookies ni se conecta a páginas web de terceros. Solo utiliza las funcionalidades disponibles en WordPress y en el editor TinyMCE.

En estos términos, TinyMCE Advanced no afecta en modo alguno a la privacidad del usuario de la web.

Capturas

  • El editor de WordPress después de instalar este plugin (con los ajustes por defecto del plugin).
  • La página de ajustes de TinyMCE Advanced, opciones de la barra de herramientas.
  • La página de ajustes de TinyMCE Advanced, opciones de usuario.
  • La página de ajustes de TinyMCE Advanced, opciones avanzadas.
  • La página de ajustes de TinyMCE Advanced, opciones de administración

Instalación

Lo mejor es instalarlo directamente desde WordPress. Si fuese necesaria la instalación manual,asegúrate de que los archivos del plugin estén en una carpeta llamada “tinymce-advanced” (no en otra carpeta) dentro de la carpeta de plugins de WordPress, normalmente “wp-content/plugins”.

Preguntas frecuentes

Instrucciones de instalación

Lo mejor es instalarlo directamente desde WordPress. Si fuese necesaria la instalación manual,asegúrate de que los archivos del plugin estén en una carpeta llamada “tinymce-advanced” (no en otra carpeta) dentro de la carpeta de plugins de WordPress, normalmente “wp-content/plugins”.

No se ha importado ningún estilo en el submenú Formatos.

Estos estilos se importan del archivo editor-style.css de tu tema actual. Sin embargo algunos temas no tienen esta funcionalidad. Para estos temas, TinyMCE Advanced tiene la opción de permitirte añadir un editor-style.css personalizado para importarlo en el editor.

Acabo de instalar el plugin pero no hace nada.

Cambia algunos botones en una de las barras de herramientas, guarda tus cambios, limpia la caché del navegador e inténtalo de nuevo.
Si eso no funciona trata de recargar varias veces la página del editor mientras pulsas la tecla May o Ctrl.
Puede que también haya una caché de red en algún lugar entre tú y tu servidor. Puede que debas esperar unas horas
hasta que expire esta caché.

Cuando añado “smilies” no se ven en el editor.

El botón “Emoticonos” de TinyMCE añade los códigos para los smilies. Las imágenes reales las añade WordPress cuando se visualiza la entrada. Asegúrate de que esté seleccionada la casilla “Convertir emoticonos a gráficos al visualizarlos” en “Ajustes – Escritura”.

El plugin no añade ningún botón.

Asegúrate de que no está marcada la casilla “Desactivar el editor visual en el editor” en “Usuarios – Tu perfil”.

Todavía veo los “viejos” botones en el editor

Haz clic en el botón “Restaurar ajustes por defecto” de la página de ajustes del plugin y luego coloca de nuevo los botones y guarda.

¿Otras preguntas? ¿más capturas?

Por favor, publica en el foro de soporte o visita la web de TinyMCE Advanced.

Reseñas

Love this plugin but!

I love this plugin, simple and useful.

Sadly today I updated my Wp and also my theme in use.
Since then it seems like the ‘Stopping html stripping’ ist not working properly.

it f***d up my website

Without even touching it, one day this plugin decided to stop uploading my images, stopped to even add old images I already had in my website to the posts, unexpected errors to the admin area PLUS something about adding extra whitespace.
I’ve spend numerous hours to find the error and that was something the json was calling a mini.css of the tiny! I deactivated and deleted the plugin. Nada, zip, zero. It’s still there – propably in the database or I don’t know where else, because I don’t see it in the plugins- and like the Lazarus still gives errors and I CANNOT work on my website at all. I wish it had minus – 100 stars to vote this plugin. Has happened to me in the past with another website back in 2015 (totally crashed forever) and now 2018 I thought that “the technology and the knowledge has improved, so they will have been improved”. ABSOLUTE NOT. DO NOT download it if you want a healthy running smoothly website.

the future of Gutenberg!

Thank you thank you and thank you again for continuing to develop this plugin, because it is the only escape from the announced death of wordpress if Gutenberg becomes the new standard!

Great free plugin:

two major shortcomings:
1) There should be the possibility to insert and use any Font by uploading there from the PC, directly in Tiny.
2) The option for text size should also be customizable (with sizes like 13 or 27, for example).

Leer todas las 276 reseñas

Colaboradores y desarrolladores

“TinyMCE Advanced” es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

“TinyMCE Advanced” ha sido traducido a 32 idiomas. Gracias a los traductores por sus contribuciones.

Traduce “TinyMCE Advanced” a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN , o suscríbete al log de desarrollo por RSS .

Registro de cambios

4.8.0

  • Actualizado para WordPress 4.9.8 y TinyMCE 4.8.0.

4.7.13

  • Actualizados los plugins de tabla y ancla a 4.7.13 (2018-05-16). Se corrige un error en el plugin de tabla en Edge.

4.7.11

  • Actualizado para WordPress 4.9.6 y TinyMCE 4.7.11.

4.6.7

  • Arreglada la compatibilidad con el bloque de forma libre de Gutenberg.
  • Actualización forzada de los plugins de TinyMCE después de la activación.
  • Actualizado para WordPress 4.9 y TinyMCE 4.6.7.

4.6.3

  • Actualizado para WordPress 4.8 y TinyMCE 4.6.3.

4.5.6

  • Actualizado para WordPress 4.7.4 y TinyMCE 4.5.6.
  • Corregido el aviso PHP después de importar la configuración.

4.4.3

  • Actualizado para WordPress 4.7 y TinyMCE 4.4.3.
  • Corregido el botón “Código fuente” que faltaba.

4.4.1

  • Actualizado para WordPress 4.6 y TinyMCE 4.4.1.
  • Corregido error guardado en multisitio.
  • Se ha añadido un nuevo botón en el Editor de texto para añadir o restablecer los saltos de línea. Añade saltos de línea sólo entre etiquetas. Funciona sólo cuando detecta que faltan saltos de línea, por lo que no reformatea las entradas con párrafos eliminados.

4.3.10.1

  • Se ha corregido el problema de añadir etiquetas de párrafo al cargar entradas que se guardaban antes de desactivar el modo automático.
  • Desactivada la (nueva) barra de herramientas en línea para las tablas, ya que en algunos casos se superponía a la tabla.

4.3.10

  • Actualizado para WordPress 4.5.1 y TinyMCE 4.3.10.
  • Corregido la compatibilidad para añadir editor-style.css a temas que no lo tienen.

4.3.8

  • Actualizado para WordPress 4.5 y TinyMCE 4.3.8.
  • Opciones estándar y opciones de administración separadas.
  • Añadidos ajustes que pueden deshabilitar el plugin para el editor principal, otros editores en wp-admin o editores en el front-end.
  • Traducción al coreano de Josh Kim y al griego de Stathis Mellios.

4.2.8

  • Actualizado para WordPress 4.4 y TinyMCE 4.2.8.
  • Traducción al japonés de Manabu Miwa.

4.2.5

  • Actualizado para WordPress 4.3.1 y TinyMCE 4.2.5.
  • Corregido el dominio de texto y las cabeceras de los plugins.

4.2.3.1

  • Corregido el error al eliminar el plugin ‘textpattern’.

4.2.3

  • Actualizado para WordPress 4.3 y TinyMCE 4.2.3.
  • Eliminado el plugin ‘textpattern’ ya que WordPress 4.3 incluye funcionalidad similar por defecto.
  • Traducción al francés por Nicolas Schneider.

4.1.9

  • Actualizado para WordPress 4.2 y TinyMCE 4.1.9.
  • Corregidos errores al mostrar vistas previas de oEmbed cuando se pega una URL.
  • Corregidos errores al obtener el contenido de TinyMCE con saltos de línea.

4.1.7

  • Actualizado para WordPress 4.1 y TinyMCE 4.1.7.
  • Arreglado error donde los shortcodes consecutivos de piue de foto se pueden dividir con una etiqueta vacía del párrafo.

4.1.1

  • Corrección de errores en los subtítulos de las imágenes cuando wpautop está desactivado.
  • Añadida compatibilidad de traducción a la página de configuración. Los nombres/descripciones de los botones se traducen desde JS utilizando la traducción existente de WordPress, por lo que esta parte de la página de configuración se traducirá de forma predeterminada. El otro texto aún necesita una traducción por separado.

4.1

  • Actualizado para WordPress 4.0 y TinyMCE 4.1.
  • Añada el plugin textpattern’ que permite parte de la sintaxis de reducción de marcas mientras escribe, (más información).
  • Añadido plugin actualizado ‘table’ que permite de fondo y borde.

4.0.2

  • Arreglada la visualización de la segunda, tercera y cuarta filas de botones cuando no se utiliza el botón Alternar de la barra de herramientas.
  • Se corrige la adición del plugin ”direccionalidad” cuando se selecciona el botón RTL o LTR.
  • Mostrar las “Opciones avanzadas” a los superadministradores en instalaciones multisitio.
  • Añadido el plugin ”link”’ incluyendo el ajuste de rel de enlace. Reemplaza el cuadro de diálogo Insertar/Editar enlace cuando está habilitado.
  • Incluido el plugin actualizado ”table” que tiene soporte para alinear verticalmente para celdas.

4.0.1

Corregir las advertencias en páginas que no sean Editar publicación. Actualice la descripción.

4.0

Actualizado para WordPress 3.9 y TinyMCE 4.0. Actualizar la pantalla de configuración. Añadido soporte para la exportación e importación de la configuración.

3.5.9.1

Actualizado para WordPress 3.8, se corrigió la autoincrustación de URLs de una sola línea cuando no se eliminaban las etiquetas de párrafo.

3.5.9

Actualizado para WordPress 3.7 y TinyMCE 3.5.9.

3.5.8

Actualizado para WordPress 3.5 y TinyMCE 3.5.8.

3.4.9

Actualizado para WordPress 3.4 y TinyMCE 3.4.9.

3.4.5.1

Corregido un error que impedía a TinyMCE importar clases CSS desde editor-style.css.

3.4.5

Actualizado para WordPress 3.3 o posterior y TinyMCE 3.4.5.

3.4.2.1

Arreglada la eliminación del plugin media para que no sea necesario volver a guardar la configuración.

3.4.2

Compatibilidad con WordPress 3.2 y TinyMCE 3.4.2, eliminó las opciones de soporte para elementos iframe y HTML 5.0 ya que son soportados por defecto en WordPress 3.2, eliminó el plugin media ya que está incluido por defecto.

3.3.9.1

Opciones avanzadas añadidas: dejar de eliminar iframes, dejar de eliminar elementos HTML 5.0, mover el soporte para estilos de editor personalizados a editor-style.css en el tema actual.

Atención: si tienes un archivo tadv-mce.css personalizado y tu tema no tiene editor-style.css, descarga tadv-mce.css, renómbralo a editor-style.css y súbelo al directorio de tu tema actual. Alternativamente puedes añadir el editor-style.css del tema Twenty Ten. Si tu tema tiene editor-style.css puedes añadir estilos personalizados.

3.3.9

Compatibilidad con WordPress 3.1 y TinyMCE 3.3.9, opción mejorada de etiquetas P y BR.

3.2.7

Compatibilidad con WordPress 2.9 y TinyMCE 3.2.7, varias correcciones de errores menores.

3.2.4

Compatibilidad con WordPress 2.8 y TinyMCE 3.2.4, correcciones menores de errores.

3.2

Compatibilidad con WordPress 2.7 y TinyMCE 3.2, correcciones menores de errores.

3.1

Compatibilidad con WordPress 2.6 y TinyMCE 3.1, mantiene los párrafos vacíos al desactivar la eliminación de las etiquetas P y BR, los botones para MCImageManager y MCFileManager se pueden organizar (si están instalados).

3.0.1

Compatibilidad con WordPress 2.5.1 y TinyMCE 3.0.7, opción añadida para desactivar la eliminación de las etiquetas P y BR al guardar y en el editor HTML (automático), se añadieron dos botones más al editor HTML: automático y deshacer, se ha corregido la eliminación de los botones TinyMCE no predeterminados.

3.0

Compatibilidad con WordPress 2.5 y TinyMCE 3.0.

2.2

Desactivar/Desinstalar página de opciones, menú desplegable de tamaño de fuente y otros pequeños cambios.

2.1

Selección de idioma mejorada, compatibilidad mejorada con WordPress 2.3 y TinyMCE 2.1.1.1.1, opción para anular algunas de las clases css importadas y otras pequeñas mejoras y correcciones de errores.

2.0

Incluye una página de administración para organizar los botones de la barra de herramientas de TinyMCE, fácil instalación, una gran cantidad de correcciones de errores, un plugin personalizado de “Smilies” que utiliza los smilies de WordPress incorporados, etc. La página de administración usa jQuery y jQuery UI que le permite “arrastrar y soltar” los botones TinyMCE para organizar sus propias barras de herramientas y habilitar/deshabilitar los plugins correspondientes dependiendo de los botones utilizados.