WP Downgrade | Specific Core Version

Descripción

Volver a una versión anterior/actualizar el núcleo de WordPress

ES: el plugin WP Downgrade fuerza a la rutina de actualización de WordPress a realizar la instalación de una versión específica de WordPress. La versión del núcleo que especifiques es descargada de wordpress.org e instalada como si fuera cualquier actualización normal. Puedes permanecer permanentemente en una versión anterior de tu elección o actualizar a la que selecciones.

El usuario Gahapati lo describe mucho mejor que yo. (¡Gracias!)

WP Downgrade | Specific Core Version tiene el potencial para convertirse en uno de los plugins más queridos entre aquellos que simplemente no pueden actualizar a la última versión de WP.

En el pasado, la última versión de WP era la única ofrecida para la rutina de actualización automática de WP. Esto dejó a todos aquellos atrás, teniendo que esperar para actualizar el núcleo hasta que sus plugins fueran compatibles con las nuevas versiones de WP. Cuando esto finalmente sucedía, la mayoría de las veces ya había otra actualización del núcleo. Al final, una actualización manual, temida, engorrosa, lenta y propensa a errores, era el único camino a seguir.

Con WP Downgrade | Specific Core Version esto es ahora una cosa del pasado. Cualquiera que se quede atrás respecto de la última versión de WP, ahora es capaz de usar las actualizaciones automáticas, incluso para bajar de versión de WP. Lo que simplemente hace WP Downgrade es hacer creer a WP que la versión a la que quieres actualizar es actualmente la última versión. Debido a esto, no hay diferencia en la actualización a la última versión.

Por razones de seguridad, creo que es un plugin imprescindible para cualquiera que esté ejecutando una instalación «veterana» de WP y, realmente, debería ser una característica del núcleo para poder actualizar, no sólo a la última versión de WP exclusivamente, sino también para tener la posibilidad de elegir entre las versiones seguras.

Nueva opción avanzada: ahora, si es necesario, puedes editar manualmente el enlace de descarga. Esto permite, por ejemplo, un cambio de idioma para el núcleo de WP. O puedes obtener la versión desde otra fuente.

DE: Das Plugin «WP Downgrade» zwingt die WordPress-interne Update-Funktion, ein bestimmtes WordPress-Release zu installieren. Das definierte Core-Release wird wie ein reguläres Update von wordpress.org bezogen und direkt installiert.
Das klappt wie gewohnt per Update-Button im Admin-Bereich oder per Auto-Update. Die Versionsnummer kann sowohl höher als auch niedriger sein als die aktuell installierte Version. Somit ist also auch ein Rollback auf frühere Releases möglich. Dein WordPress wird solange auf dieser Version bleiben, bis du eine neue Versionsnummer in WP-Downgrade hinterlegst (oder bis du die Versionsnummer leerst oder das Plugin deaktivierst).

Atención: ¡Úsalo bajo tu propio riesgo!

WP-Downgrade normalmente funciona bien. Sin embargo, un cambio de versión es siempre una operación arriesgada. En cualquier caso, ¡deberías hacer una copia de seguridad de tus archivos y de la base de datos por anticipado! No me hago cargo de ninguna garantía de su instalación y no daré ningún soporte.

¿El plugin es útil? ¡Da las gracias!

Proporciono el plugin de forma gratuita, pero me alegran mucho las donaciones o un enlace a mi blog de viajes https://www.reisetiger.net! 🙂
¡Valora WP Downgrade si lo encuentras útil!

Capturas

  • Definir el número de versión
  • Activar la vuelta a una versión anterior de WordPress
  • WordPress ofrece una versión anterior como actualización

Instalación

La forma más fácil:

  1. En la administración de WordPress, ve a «Plugins > Instalar» y busca «WP Downgrade».
  2. Haz clic en «Instalar ahora» WP Downgrade en la lista de resultados.
  3. Activa el plugin.
  4. Ahora, encontrarás un nuevo elemento en «Ajustes» llamado «WP Downgrade». Allí puedes introducir el número de la versión principal deseada y luego realizar la actualización de WordPress.

La forma manual:

  1. Descarga el plugin.
  2. Descomprime el archivo ZIP.
  3. Sube toda la carpeta wp-downgrade por FTP al directorio /wp-content/plugins/ de tu blog.
  4. Ve a «Plugins» en la administración de WordPress y activa el plugin.
  5. Ahora, encontrarás un nuevo elemento en «Ajustes» llamado «WP Downgrade». Allí puedes introducir el número de la versión principal deseada y luego realizar la actualización de WordPress.

FAQ

P: El botón para actualizar/reinstalar no está visible

R: Si no hay un botón para actualizar/reinstalar el núcleo en /wp-admin/update-core.php, es porque está siendo bloqueado por un código personalizado. Puede ser otro plugin o tu tema. Quizás puedas probar algo como esto:

  1. Desactiva todos los demás plugins
  2. Cambia a un tema estándar
  3. Elimina esto de wp-config: define( 'WP_AUTO_UPDATE_CORE', false );
  4. Elimina algo como esto de wp-config: remove_action( 'init', 'wp_version_check' );
  5. Elimina algo como esto de wp-config: add_filter('pre_option_update_core','__return_null');
  6. Elimina algo como esto de from wp-config: add_filter('pre_site_transient_update_core','__return_null');
  7. Elimina «gd-system-plugin» de /wp-content/mu-plugins/
  8. Elimina la referencia a gd-config.php en wp-config.php.

Reseñas

28 de noviembre de 2020
I was asked to look at an ancient site that had all sorts of out of date custom code on it. It was pretty obvious that WP5.5 had broken it. To make matters worse the site was hosted on WP Engine, which has no cpanel-style file manager. This plugin saved me the hassle of manually reverting WP back to v4.4 without have to use FTP. Brilliant plugin, that works very well and super easy to use.
13 de noviembre de 2020
Thanks for making this plugin. After updating to the latest version of WP, my webshop couldn't be updated anymore because of the plugin I use for that. With this plugin I reverted back to an earlier version of WP without any effort whatsoever. Two thumbs up from me 🙂
11 de noviembre de 2020
This plugin won't work if your PHP version is below 5.6.20. It shows an error message that "WordPress X.X require PHP version 5.6.20 or higher", even if the WP version was released before PHP 5.6 was. Disappointed.
24 de octubre de 2020
Good plugin! Easy to use and no issues whatsoever.
9 de octubre de 2020
What a great plugin that saves me hours. I don't worry about updating clients and having issues because it takes me 30 seconds to switch them back to a previous WordPress version. This has been instrumental in helping me troubleshoot issues quickly. I can't recommend this plugin enough.
Leer todas las 115 reseñas

Colaboradores y desarrolladores

«WP Downgrade | Specific Core Version» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«WP Downgrade | Specific Core Version» ha sido traducido a 6 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «WP Downgrade | Specific Core Version» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.2.2

  • Compatibilidad con WordPress 5.5.1
  • Añadido enlace de donación. ¡Estaré muy contento con un café o una cerveza!

1.2.1

  • Compatibilidad con WordPress 5.3.2
  • Corrección de fallo en la URL con idioma EN

1.2.0

  • Opción avanzada: ahora, si es necesario, puedes editar manualmente el enlace de descarga. Esto permite, por ejemplo, un cambio de idioma. O puedes obtener la versión desde otra fuente.
  • Notas un poco mejoradas.
  • Compatibilidad con WordPress 5.0.2

1.1.4

  • Acceso mejorado a la página de ajustes (enlace desde el resumen del plugin)
  • Compatibilidad con WordPress 4.7.1

1.1.3

  • Corrección del fallo en la descarga de determinados idiomas
  • Compatibilidad con WordPress 4.7

1.1.2

  • Limpieza del código
  • Pequeño cambio de diseño
  • Añadido el número de comprobación de versión

1.1.1

  • Añadidos los archivos en inglés. ¡Gracias a Gahapati!

1.1.0

  • Corregido el error con los idiomas que no son iguales a «de_DE». ¡Gracias a Gahapati!

1.0.0

  • Primera versión beta estable
  • Elegir bajar de versión o actualizar WordPress
  • Funciona para la versión en alemán