Soporte » Diseño – Temas y plantillas » Problema CSS Responsive

  • jagomez

    (@jagomez)



    Hola,

    Tengo un problema con el css responsive en algunas de mis páginas ya que no me coge las medidas específicas como @media según la medida de pantalla y me coge la medida general a pesar de tener en cuenta los dos códigos, es como que prevalece el incorrecto. En la imagen adjunta se ve lo descrito para el banner de la parte superior.
    A ver si alguien sabe que puede pasar.

    Gracias.

    Imagen del problema

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • jagomez

    (@jagomez)

    La imagen está en este link

    .container .one-column.column, .container .one-full.column, .container .twentyfour.columns {
        width: 940px;
    }
    
    @media only screen and (min-width: 1140px)
    .container .one-column.column {
        width: 1120px;
    }
    • Esta respuesta fue modificada hace 1 mes por  jagomez.
    Moderador almendron

    (@almendron)

    No se si tiene que algo que ver pero yo siempre meto entre llaves @media

    @media only screen and (min-width: 1140px) {
    código
    }

    https://www.w3schools.com/cssref/css3_pr_mediaquery.asp

    jagomez

    (@jagomez)

    Gracias por la respuesta @almendron , si, lo tengo así puesto y no me lo coge, de hecho me pasa todas las medidas @media, tengo este codigo en el css personalizado

    Código CSS

    Moderador almendron

    (@almendron)

    Es que en en el ejemplo lo habías puesto sin las llaves, pero ya veo que era el css del inspector.

    Y también veo que la regla está, la coge pero tiene prioridad otra. Yo, de momento, usaría !important para @media.

    Otra opción es borrar la regla general. Si tienes cogidas todas las medidas, debería dar igual.

    Y avisa cuando esté en línea para echarle un vistazo.

    jagomez

    (@jagomez)

    Disculpa, ayer lo dejé en modo mantenimiento por la noche, eso he hecho, he quitado el general y ya lo coge bien aunque me falta alguna medida que me queda descontrolada, tengo que repasar todo el abanico de medidas responsive para dejarlas optimizadas.

    Está online por si quieres verla.
    Gracias por la ayuda.

    Moderador almendron

    (@almendron)

    Por lo que veo, ahora lo hace bien.

    Si quieres probar con distintos dispositivos: http://mobiletest.me/

    jagomez

    (@jagomez)

    Si, parece que ya conseguí arreglarlo, a base de parches creo haberlo conseguido.
    Ahora no sé que me pasa que en la versión móvil para pantallas mas pequeñas de 768px la zona donde se ponen los datos de pago desde el móvil se desplaza hacia la izquierda si la arrastras, como si el fondo fuera más ancho que la pantalla y tuviera desplazamiento horizontal. No encuentro qué parámetro está dando ese ancho de pantalla sólo en esa parte y no lo puedo cambiar.

    Moderador almendron

    (@almendron)

    Eso no lo vas a poder solucionar con css. Hay un desplazamiento horizontal pero creo que tiene que ver con el formulario. Revísalo.

    jagomez

    (@jagomez)

    Pero la parte de los datos de usuario está bien y solo le pasa a los datos de pago, es raro, el formulario es todo el mismo pero solo afecta a una parte.
    A ver si consigo encontrarlo algo habrá mal.

    Gracias por la ayuda!

Viendo 9 respuestas - 1 de 9 (de 9 total)
  • Debes estar registrado para responder a este tema.